Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 215687 - kde-base/kpdf-3.5.8-r1 presentation broken
Summary: kde-base/kpdf-3.5.8-r1 presentation broken
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-04-01 10:52 UTC by Philipp Reinkemeier
Modified: 2009-05-29 14:50 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Screenshot (snap0000.jpg,111.89 KB, image/jpeg)
2008-04-01 10:55 UTC, Philipp Reinkemeier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Reinkemeier 2008-04-01 10:52:53 UTC
When you want a PDF (which one does not matter, i have tried a few) to be displayed in presentation mode in KPDF (Ctrl+Shift+P), the appearing window does not cover the whole screen (fullscreen) as one would expect. The resulting window is much smaller than fullscreen.
After googeling a bit, i found a few hints on what the problem could be. I'll create a few attachments regarding this.

Reproducible: Always

Steps to Reproduce:
1. open a pdf in kpdf
2. switch to presentation using menu->view->presentation or shortcut Ctrl+Shift+P
Actual Results:  
No fullscreen but a smaller window

Expected Results:  
pdf should be viewed in fullscreen

i am using xfce-base/xfce4-4.4.2 right now. I do not know whether this problem also occurs when starting kpdf in KDE.

emerge --info:
Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r4 i686)
=================================================================
System uname: 2.6.24-gentoo-r4 i686 Mobile Intel(R) Pentium(R) 4 CPU 2.80GHz
Timestamp of tree: Tue, 01 Apr 2008 08:17:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="de_DE.UTF-8"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa asf bash-completion berkdb bitmap-fonts bzip2 cairo cdr cdrw cjk cli cracklib crypt cups curl cvs dbus dri dvd dvdr dvdread emboss encode evo fam ffmpeg firefox gdbm gif glitz gpm gs gstreamer gtk hal iconv imagemagick imap ipv6 irda isdnlog jpeg kerberos ldap libnotify mad midi mikmod mmx mp3 mpeg mudflap ncurses network nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline reflection ruby sdl session spell spl sqlite sqlite3 sse sse2 ssl startup-notification subversion svg tcpd tiff truetype truetype-fonts type1-fonts unicode usb vcd vorbis win32codecs x86 xcomposite xinetd xml xorg xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="kbd mouse synaptics keyboard ps2mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Wulf Krueger (RETIRED) gentoo-dev 2008-04-06 15:50:06 UTC
I can't reproduce this using KWin. You need to find out how to make xfce behave. Re-assigning this to the xfce maintainers.
Comment 3 Philipp Reinkemeier 2008-04-18 12:21:59 UTC
(In reply to comment #2)
> I can't reproduce this using KWin. You need to find out how to make xfce
> behave. Re-assigning this to the xfce maintainers.
> 
Hm, not much activity around here. Does no one have any time to take care of this?
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2008-05-04 11:28:14 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > I can't reproduce this using KWin. You need to find out how to make xfce
> > behave. Re-assigning this to the xfce maintainers.
> > 
> Hm, not much activity around here. Does no one have any time to take care of
> this?
> 

Patch would help, yes.
Comment 5 Mattes 2008-08-16 07:16:48 UTC
The same here. Works fine on kde-3.5.9, but not on xfce 4.4.2
Comment 6 Pariksheet Nanda 2008-09-18 02:21:35 UTC
Bug persists in kpdf-0.5.9 (Help > About KPDF)

Since this problem does not exist with other KDE apps (kmplayer, konqueror) on Xfce 4.4.2, this issue seems inherent to kpdf's procedure of involking fullscreen.

Assuming this is the same bug -
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/151138
What setting in xfwm4 can be changed that is analogous to that Compiz-Fusion Workarounds plugin "legacy fullscreen support" setting?

I'm no developer, but for someone who is, maybe this helps -
[1] $ bzless /usr/share/doc/xfwm4-4.4.2/README.bz2
[2] http://gitweb.compiz-fusion.org/?p=fusion/plugins/workarounds;a=blob;f=workarounds.c;h=0e4e0ea09082b62c30693ea4ac924ac431c6c373;hb=5a2255a4ffceb9ba0853f623da4c8ee02c2636a8

[1] List of fuction compliance of xfwm4
[2] Code for Compiz fusion "workarounds" plugin
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-10-27 04:26:10 UTC
(In reply to comment #6)

> Since this problem does not exist with other KDE apps (kmplayer, konqueror) on
> Xfce 4.4.2, this issue seems inherent to kpdf's procedure of involking
> fullscreen.

Indeed, and thus this is why we (the xfce team) cannot do much about this particular bug. http://lists.berlios.de/pipermail/ion-general/2007-September/001495.html I'm not even sure why Comment #2 happened. Other distros & other WM's clearly have this "problem" too, so IMO it isn't proper to assign to the xfce team.
Comment 8 Pariksheet Nanda 2008-10-30 03:35:50 UTC
(In reply to comment #7)
> (In reply to comment #6)
> 
> this issue seems inherent to kpdf's procedure of involking
> fullscreen.
> 
> Other distros & other WM's clearly have
> this "problem" too, so IMO it isn't proper to assign to the xfce team.
> 
Brought this to the attention of Upstream:
https://bugs.kde.org/show_bug.cgi?id=171477
Comment 9 Christoph Mende (RETIRED) gentoo-dev 2008-12-05 17:34:00 UTC
reassigning wrt comment #7
Comment 10 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 14:50:34 UTC
Upstream didn't fix and since development of kde3 has stopped it won't be fixed, we can't do anything so closing