Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 194668 - kitchensync conflict dialog is empty, missing xml parse libs?
Summary: kitchensync conflict dialog is empty, missing xml parse libs?
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2007-10-04 03:18 UTC by Joshua Moore-Oliva
Modified: 2009-05-29 11:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Moore-Oliva 2007-10-04 03:18:46 UTC
When kitchensync has a conflict resolution dialog, it is empty.  I found a similar bug at the URL below, but I have no idea which xml library is being referred to.

http://lists.opensuse.org/opensuse-bugs/2006-11/msg10734.html

Reproducible: Always

Steps to Reproduce:
1. Attempt to sync with a pda when a conflict would occur
Comment 1 Wulf Krueger (RETIRED) gentoo-dev 2007-10-04 17:04:37 UTC
Which version of kitchensync? emerge --info? emerge -pv kitchensync?
Comment 2 Joshua Moore-Oliva 2007-10-04 20:20:25 UTC
[ebuild   R   ] kde-base/kitchensync-3.5.7  USE="arts xinerama -debug -kdeenablefinal" 0 kB

I am only using the following plugins to sync my Palm with Korganizer.

app-pda/libopensync-plugin-kdepim-0.22
app-pda/libopensync-plugin-palm-0.22

Comment 3 Joshua Moore-Oliva 2007-10-18 17:10:18 UTC
While watching this bug, I realized that I hadn't given the emerge --info output.  Here it is.

chatgris@localhost ~ $ emerge --info
Portage 2.1.3.9 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22.1 i686)
=================================================================
System uname: 2.6.22.1 i686 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Thu, 18 Oct 2007 05:50:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.3.5-r3, 2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://adelie.polymtl.ca/ ftp://cs.ubishops.ca/pub/gentoo ftp://gentoo.risq.qc.ca/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.ca.gentoo.org/gentoo-portage"
USE="X alsa arts berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus dri dvd dvdr eds emboss encode esd fam firefox fortran gdbm gif gpm gstreamer hal iconv ipv6 isdnlog jpeg kde ldap mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre perl png ppds pppd python qt qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts unicode vorbis win32codecs x86 xinerama xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 ScytheMan 2009-01-16 17:41:57 UTC
This patch should fix it (i didn't test it):

http://lists.opensuse.org/opensuse-commit/2007-09/msg00080.html

Comment 5 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-28 14:29:02 UTC
patch from opensuse applied, but highly changed due to conflicts with the libopensync patch. Thanks
Comment 6 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 11:15:03 UTC
hmmm patch seems to have problem, reopening
Comment 7 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 11:58:04 UTC
taking a closer look at the patches, i saw that xmldiffalgo.(cpp,h) files, which are the major ones that fix this bug, are already included in the patch for libopensync-0.36 activity. Since noone else confirmed this bug and since the patch was included after the opening of this specific bug, i'll close it. If anyone hits the bug please reopen. ATM i don't have pda to reproduce. Thanks and sorry for the mess