Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 252739 - incorect handling of USE="-arts" in noatun-plugins-3.5.9
Summary: incorect handling of USE="-arts" in noatun-plugins-3.5.9
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-12-27 19:35 UTC by John (EBo) David
Modified: 2009-10-17 09:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John (EBo) David 2008-12-27 19:35:40 UTC
A recent upgrade triggered a rebuild of noatun-plugins-3.5.9 which failed.  The problem turned out to be that noatun-plugins-3.5.9.ebuild supports building without USE="arts", but the Makefiles/build-scripts still looks for the libarts library; which causes the build to fail.

to reproduce:

  build noatun-plugins on a system without arts (the entire system would need to be built this way so that the libarts library is not floating around)

Expected results:

  build failure

Workaround:

  add "arts" to the USE flags in /etc/make.conf and update the entire system

  EBo --

ps: please note that the "emerge --info" is provided *after* adding "arts" to the useflags...

=================== emerge --info =========================

Portage 2.1.6.3 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.7-r2, 2.6.26-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.26-gentoo-r4-i686-Intel-R-_Pentium-R-_Dual_CPU_T2330_@_1.60GHz-with-glibc2.0
Timestamp of tree: Sat, 27 Dec 2008 01:45:02 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer nostrip parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.gtlib.gatech.edu/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo ftp://mirror.iawnet.sandia.gov/pub/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://cudlug.cudenver.edu/gentoo/ http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo ftp://gentoo.mirrors.tds.net/gentoo http://gentoo.netnitco.net ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://mirror.espri.arizona.edu/gentoo/ http://prometheus.cs.wmich.edu/gentoo http://mirror.mcs.anl.gov/pub/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/ http://mirror.fslutd.org/linux/distributions/gentoo/ ftp://mirror.fslutd.org/linux/distributions/gentoo/ nehet"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/pd-overlay /usr/portage/local/layman/science /usr/local/portage_overlays /old_root/home/ebo/gtd/projects/computer/local_portage/ref/local-portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa arts audiofile bash-completion berkdb blas blender-game bluetooth branding bzip2 cairo cdr cli cracklib crypt css cups curl cvs dbus divx dri dvd dvdr dvdread eds emacs emboss encode esd evo fam ffmpeg fftw firefox fits fortran ftp gd gdbm geos gif git gmedia gnome gpg gpm graphviz gstreamer gtk hal hddtemp hdf5 iconv ieee1394 ipv6 ipw3945 isdnlog jack java java5 javascript jpeg jpeg2k kde lapack laptop latex ldap libnotify lm_sensors mad midi mikmod mp3 mpeg mudflap ncurses netcdf nls nptl nptlonly nsplugin ogdi ogg openal opengl openmp osc pam pcre pdf perl png portaudio ppds pppd python qt3 qt3support qt4 quicktime readline realmedia reflection sasl sdl session spell spl ssl startup-notification subversion svg sysfs tcl tcpd threads tiff tk truetype unicode usb vorbis wavpack win32codecs wmf wmp x86 xine xml xorg xpm xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" FOO2ZJS_DEVICES="hpp1006" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="i810 vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 21:40:11 UTC
noatun-plugins depends on noatun which according to eclass depends always to arts. So it will pull arts-3.5.X and kdemutlimedia-arts-3.5.X, with the later failing if kdelibs is compiled without arts. But we plan to remove arts completely from tree, right after we strip it from kde3 applications that still use it. Then i'll have to change eclass and disable arts from all kde ebuilds, either misc or kde-base. So i won't fix it for now. Thanks
Comment 2 John (EBo) David 2009-05-29 22:17:00 UTC
ok.  Thanks for looking at this.  

Would it be reasonable, as a temporary fix, to add arts to DEPEND?  I see that the real fix will be a bit of a pain...
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 22:19:47 UTC
to be honest i have the same problem in one of my machines and i'll try to find a workaround. i just want this bug closed because i don't want it to block kde3 stabilization (see tracker). i'll report back if i do anything. thanks for the understanding :)
Comment 4 John (EBo) David 2009-05-30 04:14:18 UTC
Thanks again Theo.  Do not worry on my concern -- I was able to work around the problem by simply including arts in the USE flags and rebuilding.  Best of luck on the kde3 stabilization.  

BTW, after reading the kde3 stabilization thread I see the issue.  Maybe a small test program/suite can be added to portage to check for deprecated situations and point the user to instructions on how to deal with updating the effected packages before actually updating portage (and effecting the eclasses, etc.).  As a note, the last time I had an issues with an old laptop which was not sync'ed for nearly a year had a fried ethernet jack and I am able to maintain it via sneakernet shuffling a thumbdrive.

Cheers ;-)
Comment 5 Jonathan Callen (RETIRED) gentoo-dev 2009-10-17 09:26:34 UTC
reopening to mark "FIXED"
Comment 6 Jonathan Callen (RETIRED) gentoo-dev 2009-10-17 09:27:04 UTC
This has been fixed in 3.5.10; 3.5.9 is no longer in the tree.