Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 216603 - Konqueror: Netscape plugins default path is missing
Summary: Konqueror: Netscape plugins default path is missing
Status: RESOLVED DUPLICATE of bug 234326
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-04-06 19:49 UTC by Andreas Thalhammer
Modified: 2009-05-27 23:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Thalhammer 2008-04-06 19:49:02 UTC
I've built a Gentoo Linux 2007.0 from stage1 on a PPC machine and discovered, that Konqueror lacks the Gentoo default path to Netscape plugins.

The way I built KDE/Konqueror:
emerge -v kde-base/kde-meta

Thereafter some Netscape compatible plugins:
emerge -v net-www/mplayerplug-in media-video/vlc net-www/swfdec-mozilla net-www/gnash app-text/djvu dev-java/ibm-jdk-bin

This path is missing:
/usr/lib/nsbrowser/plugins

I had to manually add it (on a user basis) to
Setting -> Konqueror -> Plugins -> Netscape plugins.

If there is a way to add /usr/lib/nsbrowser/plugins by default, it should be done in the ebuild(s).

I think that this bug is arch independet.
Comment 1 Andreas Thalhammer 2008-04-06 20:00:06 UTC
I forgot:

I use stable tree ACCEPT_KEYWORDS="ppc". I suppose it's the same with "x86 amd64": KDE 3.5.8.

A Gentoo user who installs (=builds) a fresh Gentoo system, and who doesn't do anything after all packages are merged, is left with a KDE whose Konqueror doesn't use the installed plugins.

That's what happened to me first. I installed some plugins (Java to begin with) and wondered, why Konqueror didn't use any of them.

If it is the Gentoo way to install Netscape compatible plugins into /usr/lib/nsbrowser/plugins it should also be automatically set to every Netscape-compatible browser by default.

Greetings,
Andi
Comment 2 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 23:27:55 UTC

*** This bug has been marked as a duplicate of bug 234326 ***