Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264767 - kde-base/kdelibs-3.5.10-r2 doxygen hangs when doc USE flag is set
Summary: kde-base/kdelibs-3.5.10-r2 doxygen hangs when doc USE flag is set
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on: 266693
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2009-04-03 15:02 UTC by Juergen Rose
Modified: 2009-06-11 19:51 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2009-04-03 15:02:51 UTC
emerge kdelibs-3.5.10-r2 hangs at:
...

Warning: Tag `USE_WINDOWS_ENCODING' at line 2 of file kdeprint/Doxyfile has become obsolete.
To avoid this warning please update your configuration file using "doxygen -u"
Warning: Tag `MAX_DOT_GRAPH_WIDTH' at line 154 of file kdeprint/Doxyfile has become obsolete.
To avoid this warning please update your configuration file using "doxygen -u"
Warning: Tag `MAX_DOT_GRAPH_HEIGHT' at line 155 of file kdeprint/Doxyfile has become obsolete.
To avoid this warning please update your configuration file using "doxygen -u"
Warning: Tag `DETAILS_AT_TOP' at line 181 of file kdeprint/Doxyfile has become obsolete.
To avoid this warning please update your configuration file using "doxygen -u"

top shows:
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND   
21687 root      20   0  220m 214m 1892 R  100 28.4  55:13.41 doxygen


Reproducible: Always




emerge --info
Portage 2.1.6.11 (hardened/x86/2.6, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r4-i686-Pentium_III_-Katmai-with-glibc2.0
Timestamp of tree: Thu, 02 Apr 2009 23:15:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:     4.0_p10-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r4, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.7
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-pipe -O3 -march=pentium3 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/ge
ntoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox
.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-pipe -O3 -march=pentium3 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
FFLAGS="-pipe -O3 -march=pentium3 -fomit-frame-pointer"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://f
tp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ rsync://ftp.fi.muni.cz/pub/linux/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo rsync:/
/gd.tuwien.ac.at/opsys/linux/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://gentoo.oregonstate.edu http://212.219.2
47.17/sites/www.ibiblio.org/gentoo/"
LDFLAGS=""
LINGUAS="de fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclu
de=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/science /usr/local/portage/layman/java-overlay /usr/local/portage/layman/zugaina /usr/local/port
age/layman/dotnet /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl administrator afs alsa amrr ao aotuv apache2 asf atlas auctex audacious audiofile automount bash-completion beagle
 berkdb bjam blas bonobo boo boost bzip2 c++ cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli corba cracklib cran crypt curl cxx daap db
us device-mapper dga dia divx djvu dlloader dmi doc dri ds3490 dv dvb dvd dvdr dvi dxr3 dynagraph eds effects elf emacs emboss encode epiph
any esd evo examples exif expat extra fam fame ffmpeg fftw firefox fits flac fltk foomaticdb fpx galago gd gdal geos gif gimp gimpprint gin
ac glade glitz gml gmp gnokii gnome gnuplot gnutls gphoto2 graphics graphviz gs gsl gsm gstreamer gtk guile hal hardened harness hddtemp hd
f hdf5 hlapi http icq icu id3 ide imagemagick imap innodb irda irmc ithreads jabber java jbig john jpeg jpeg2k kerberos kexi keyring ladspa
 lame lapack latex lcms ldap libffi libgda libsamplerate lm_sensors lua lzo lzw mad maildir math matroska matrox midi mmx mmxext mng mod mo
no motif mozdevelop mozilla mozsvg mozxmlterm mp3 mp4 mp4live mpeg mpeg2 mplayer musicbrainz mysql mysqli nautilus neXt netcdf netpbm netwo
rk networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs numarray numeric obex ocaml octave odbc ogdi ogg ole opengl pae pam pcre pda pdf
 perl pic plotutils plugins png posix postgres postscript preview-latex proj projectx pstricks python qhull quicktime readline reiserfs rhy
thmbox rle rpc rrdcgi rrdtool samba sasl science sdl slang slp smp sndfile snmp soup sox speex spell sqlite sse ssl stlport subtitles subve
rsion suexec svg sysfs t1lib tcl tcpd tex theora threads thunderbird tidy tiff tk truetype unicode urandom userlocales utempter v4l2 vorbis
 webkit win32codecs wmf wxwindows x86 xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc zlib zvbi" ALSA_CARDS
="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap
_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_
dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock 
dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mim
e_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack 
vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse                " KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 l
b216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="ide websvccommon nb harness apisupport groovy gsf j2ee java xml" USERLA
ND="GNU" VIDEO_CARDS="mga vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_O
PTS
Comment 1 Joe Harvell 2009-04-04 17:03:52 UTC
I found someone reporting a similar problem here after I had the same problem you described:

http://www.mail-archive.com/blfs-dev@linuxfromscratch.org/msg08953.html

I'm working around it by emerging with USE=-doc
Comment 2 Juergen Rose 2009-04-10 21:55:32 UTC
Thanks for the hint.
Comment 3 kavol 2009-04-12 06:29:25 UTC
the same for me ... I left emerge running overnight just to find in the morning that nothing is done and system is swapping, as runaway doxygen process takes 1,5 GiB resident memory (out of 2 GiB available) and nearly twice as much virtual memory

I just tried to kill that process, and kdelibs installation continued without a problem, except the kdeprint docs ...



*** Creating apidox in kdeprint
*
Warning: Tag `USE_WINDOWS_ENCODING' at line 2 of file kdeprint/Doxyfile has become obsolete.
To avoid this warning please update your configuration file using "doxygen -u"
Warning: Tag `MAX_DOT_GRAPH_WIDTH' at line 154 of file kdeprint/Doxyfile has become obsolete.
To avoid this warning please update your configuration file using "doxygen -u"
Warning: Tag `MAX_DOT_GRAPH_HEIGHT' at line 155 of file kdeprint/Doxyfile has become obsolete.
To avoid this warning please update your configuration file using "doxygen -u"
Warning: Tag `DETAILS_AT_TOP' at line 181 of file kdeprint/Doxyfile has become obsolete.
To avoid this warning please update your configuration file using "doxygen -u"
/var/tmp/portage/kde-base/kdelibs-3.5.10-r2/work/kdelibs-3.5.10/admin/doxygen.sh: řádek 504:  2613 Ukončen (SIGTERM)      doxygen "$subdir/Doxyfile"
* Post-processing files in kdeprint/html
grep: kdeprint/html/index.html: není souborem ani adresářem
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2009-04-12 12:23:35 UTC
Nerdboy this is more of doxygen issue.
Because we cant just replace the invalid data. it should die, fail what so ever, but not leak.
Comment 5 Graham Murray 2009-05-08 20:29:43 UTC
emerging kdelibs-3.5.10-r3 fails in the same way
Comment 6 August Hörandl 2009-05-13 20:42:23 UTC
kdelibs-3.5.10-r4 fails in the same way, too.
Comment 7 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 11:55:49 UTC
According to comment 1, there is a symlink that i removed inside the ebuild, although in my ebuild i didn't have that (maybe generated?). Fixed in kdelibs-3.5.10-r6 in kde3 overlay, it will hit tree as soon as i fix more kdelibs-3.5.10 bugs (don't want to revbump it every day :) )
Comment 8 Neil Cathey 2009-05-31 06:32:15 UTC
I think the symlink is generated.  Right at this moment, I have a doxygen stuck eating more and more memory:

#ps aux
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
[snip]
portage  17499 99.9 14.1 683412 573772 pts/1   R+   01:03  14:25 doxygen kdeprint/Doxyfile

#ls -al /var/tmp/portage/kde-base/kdelibs-3.5.10-r6/work/kdelibs-3.5.10/kdeprint
total 1772                                                                                           
drwxr-xr-x 15 portage portage 12288 2009-05-31 00:52 .                                               
drwxr-xr-x 46 portage portage  4096 2009-05-31 01:01 ..                                              
[snip]
-rw-r--r--  1 portage portage  2403 2009-05-31 00:52 kded_kdeprintd.la                               
lrwxrwxrwx  1 portage portage    12 2009-05-31 00:52 kdeprint -> ./management                        
-rw-r--r--  1 portage portage  3628 2005-10-10 10:06 kdeprintcheck.cpp                               

(Apologies if all that gets line wrapped.)

The symlink is still there.

In an overlay, I was removing the symlink right above the "emake apidox || die" line and it worked for me.

Also, supposedly doxygen-1.5.9 fixes this problem (see bug #266693).
Comment 9 Stefan Kiesler 2009-06-07 06:39:12 UTC
Wow, after waiting 9 months for KDE 3.5.10 to turn stable, it doesn't even compile.
I wonder just why this doesn't surprise me at all... :-/
Comment 10 craven 2009-06-07 18:02:04 UTC
This bug is NOT fixed. 3.5.10-r6 still hangs in an infinite doxygen loop. please mask the doc useflag or make kde-base/kdelibs depend on doxygen 1.5.9 (see bug #266693)
Comment 11 mephinet 2009-06-11 19:51:51 UTC
sorry, but considering this as fixed is not correct as long as you don't bump the ebuild revision imho. Affected users have to manually `emerge -1 doxygen` to enjoy the patch...