Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242796 - Basket Kontact Integration fails with recent Kontact versions
Summary: Basket Kontact Integration fails with recent Kontact versions
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-10-19 17:10 UTC by Christian Loosli
Modified: 2009-05-29 17:42 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
basket-1.0.3.1-r1.ebuild.patch (basket-1.0.3.1-r1.ebuild.patch,617 bytes, patch)
2009-01-21 05:38 UTC, Boian Berberov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Loosli 2008-10-19 17:10:57 UTC
With recent Kontact versions (1.2.9 tested), basket integration fails due to a plugin version mismatch in the .desktop file. 

The same problem was solved some time ago by adding

/usr/share/services/kontact/basket.desktop
/usr/share/services/kontact/basket_v4.desktop

so that in basket.desktop the X-KDE-KontactPluginVersion was set to 5, however, in the meantime plugin version 6 is necessary.

This problem can be solved by changing the line

X-KDE-KontactPluginVersion=5

to 

X-KDE-KontactPluginVersion=6

in 

/usr/share/services/kontact/basket.desktop

Reproducible: Always

Steps to Reproduce:
1. emerge basket (doesn't matter which version, but take the more recent) 
2. emerge kontact (1.2.9 or newer) or the kdepim package containing it
3. launch kontact

Actual Results:  
basket integration missing

Expected Results:  
basket integration is there

easy to solve, look at the bug description. Fix tested, works here. 

Maybe adding a third file would be better than changing, so you have backwards compatibility.
Comment 1 Alexander Stein 2008-11-07 10:41:19 UTC
I can confirm (though I'm using x11-misc/basket-1.0.3.1), that this version number change fixes the problem for KDE-3.5.10, but AFAIK in KDE-3.5.8 X-KDE-KontactPluginVersion=5 is still necessary, because X-KDE-KontactPluginVersion increased in KDE-3.5.9.
Comment 2 radim 2009-01-02 12:31:40 UTC
Hmm it does not wrk for me :-(

changed to  X-KDE-KontactPluginVersion=6

in 
/usr/share/services/kontact/basket.desktop
also in
/usr/kde/3.5/share/services/kontact/basket.desktop

but still no basket in kontact.

I'm using:


nice -n 19 emerge -avD basket kontact

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-misc/basket-1.0.3.1  USE="crypt -arts -debug -xinerama" 0 kB
[ebuild   R   ] kde-base/kontact-3.5.10  USE="-debug" 0 kB



Comment 3 Markos Chandras (RETIRED) gentoo-dev 2009-01-02 12:47:20 UTC
Basket integration fails for me too . I am using stable kde3.5 so I have kontact-3.5.9 installed

[ebuild   R   ] x11-misc/basket-1.0.2  USE="crypt -arts -debug -xinerama" 0 kB
[ebuild   R   ] kde-base/kontact-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB

So , I guess this issue is not just for recent kontact/basket versions
Comment 4 Boian Berberov 2009-01-21 05:38:52 UTC
Created attachment 179140 [details, diff]
basket-1.0.3.1-r1.ebuild.patch

This patch works for me.  I am using kde-base/kontact-3.5.10
Comment 5 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 17:42:14 UTC
Thank you very much for the patch, applied in CVS