Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 104088 (gnome-doc-sandbox) - xml2po breakage (ImportError: No module named libxml2)
Summary: xml2po breakage (ImportError: No module named libxml2)
Status: RESOLVED INVALID
Alias: gnome-doc-sandbox
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 105638 106069 108967 113286 114029 115360 115972 118699 120819 122687 122688 123314 127895 133650 136004 141195 150530 183630 190037 190139 190231 190369 190628 190679 190877 190881 191285 191911 195333 197854 198008 198877 199426 202454 231903 233247 234035 253003 253008 (view as bug list)
Depends on:
Blocks: 2.12
  Show dependency tree
 
Reported: 2005-08-28 19:33 UTC by Waldo
Modified: 2008-12-29 17:21 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Waldo 2005-08-28 19:33:04 UTC
Making all in help
make[2]: Entering directory
`/var/tmp/portage/file-roller-2.11.92/work/file-roller-2.11.92/help'
cd .. && \
  /bin/sh /var/tmp/portage/file-roller-2.11.92/work/file-roller-2.11.92/missing
--run automake-1.7 --gnu  help/Makefile
cd .. && /bin/sh ./config.status help/Makefile
config.status: creating help/Makefile
make[2]: Leaving directory
`/var/tmp/portage/file-roller-2.11.92/work/file-roller-2.11.92/help'
make[2]: Entering directory
`/var/tmp/portage/file-roller-2.11.92/work/file-roller-2.11.92/help'
if ! test -d de/; then mkdir de/; fi
if test -f "C/file-roller.xml"; then d="../"; else d=".././"; fi; \
(cd de/ && \
  `which xml2po` -e -p \
    ${d}de/de.po \
    ${d}C/file-roller.xml > file-roller.xml.tmp && \
    cp file-roller.xml.tmp file-roller.xml && rm -f file-roller.xml.tmp)
if ! test -d es/; then mkdir es/; fi
if test -f "C/file-roller.xml"; then d="../"; else d=".././"; fi; \
(cd es/ && \
  `which xml2po` -e -p \
    ${d}es/es.po \
    ${d}C/file-roller.xml > file-roller.xml.tmp && \
    cp file-roller.xml.tmp file-roller.xml && rm -f file-roller.xml.tmp)
Traceback (most recent call last):
  File "/usr/bin/xml2po", line 34, in ?
    import libxml2
ImportError: No module named libxml2
make[2]: *** [de/file-roller.xml] Error 1
make[2]: *** Waiting for unfinished jobs....
Traceback (most recent call last):
  File "/usr/bin/xml2po", line 34, in ?
    import libxml2
ImportError: No module named libxml2
make[2]: *** [es/file-roller.xml] Error 1
make[2]: Leaving directory
`/var/tmp/portage/file-roller-2.11.92/work/file-roller-2.11.92/help'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/var/tmp/portage/file-roller-2.11.92/work/file-roller-2.11.92'
make: *** [all] Error 2

!!! ERROR: app-arch/file-roller-2.11.92 failed.
!!! Function gnome2_src_compile, Line 48, Exitcode 2
!!! compile failure
!!! If you need support, post the topmost build error, NOT this status message.



Reproducible: Always
Steps to Reproduce:


Actual Results:  
merge info
Portage 2.0.51.22-r2 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-r9 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r9 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.6.13
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [disabled]
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -pipe -O2 -mtune=k8 -ftracer -fprefetch-loop-arrays
-funroll-loops"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -pipe -O2 -mtune=k8 -ftracer -fprefetch-loop-arrays
-funroll-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="rsync://csociety-ftp.ecn.purdue.edu/pub/gentoo/
http://mirror.espri.arizona.edu/gentoo/
ftp://csociety-ftp.ecn.purdue.edu/pub/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aim alsa amd64 avi berkdb bitmap-fonts cddb cdr crypt cups curl
dvd dvdr eds encode esd faad fam ffmpeg flac foomatic foomaticdb fortran gif
gimpprint glitz gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal imagemagick
imlib ipv6 java jpeg junit libgda libsndfile libwww lzw lzw-tiff mad matroska
mozilla mp3 mpeg ncurses nls nptl nptlonly nvidia offensive ogg oggvorbis openal
opengl oscar oss pam pdflib perl png ppds python qt quicktime readline sdl spell
ssl tcltk tcpd theora tiff tokenizer truetype truetype-fonts type1-fonts usb
userlocales vorbis wxwindows xine xinerama xml2 xpm xv xvid yahoo zlib
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Martin Holzhauer 2005-08-29 03:00:36 UTC
i've got the same error
Reproducible: Always

here my emerge  info

Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.5-r1, 2.6.11-gentoo-r9 i686)
=================================================================
System uname: 2.6.11-gentoo-r9 i686 Intel(R) Pentium(R) M processor 1500MHz
Gentoo Base System version 1.6.13
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r1, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache digest distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo
ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
http://linux.rz.ruhr-uni-bochum.de/downlaod/gentoo-mirror/
ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror
http://mirors.sec.informatik.tu-darmstadt.de/gentoo
http://ftp.uni-erlangen.de/pub/mirrors/gentoo
ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="de_DE"
LINGUAS="de en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/de-portage
/usr/local/overlays/bmg-main.alternative"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib acl acpi aim alsa apache2 audiofile avi bidi
bitmap-fonts bonobo caps cdr cjk crypt cups curl dbus dga divx4linux dv dvd dvdr
eds emboss encode fam fastcgi fbcon flac foomaticdb fortran freewnn gd gdbm gif
gimpprint gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile hal imagemagick
imlib ipv6 java jikes joystick jpeg junit lcms ldap ldsp libcaca libg++ libwww
mad matroska memlimit mikmod mjpeg mmx mng mono motif moznocompose moznoirc mp3
mpeg mpi mysql nas ncurses nls nptl nptlonly odbc offensive ogg oggvorbis opengl
oscar pam pcre pdflib perl plotutils png postgres ppds prelude python quicktime
readline ruby samba sasl scanner sdl slang snmp speex spell sqlite sse sse2 ssl
szip tcltk tcpd tetex theora tiff truetype truetype-fonts type1-fonts unicode
usb videos vorbis win32codecs wmf wxwindows x86 xine xml xml2 xmms xosd xv xvid
yahoo zlib video_cards_nvidia linguas_de linguas_en userland_GNU kernel_linux
elibc_glibc"
Unset:  ASFLAGS, CTARGET, LC_ALL, LDFLAGS
Comment 2 Daniel Drake (RETIRED) gentoo-dev 2005-08-29 03:31:01 UTC
I get this too. Looks like a problem with gnome-doc-utils:

# xml2po
Traceback (most recent call last):
  File "/usr/bin/xml2po", line 34, in ?
    import libxml2
ImportError: No module named libxml2

Comment 3 Leonardo Boshell (RETIRED) gentoo-dev 2005-08-29 03:36:18 UTC
What version of libxml2 do you guys have? Did you emerge it with the 'python'
USE flag enabled?
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2005-08-29 03:52:00 UTC
Version 2.6.20-r2
It works when libxml2 is compiled with USE=python
Comment 5 Martin Holzhauer 2005-08-29 04:57:09 UTC
dev-libs/libxml2-2.6.20-r2  -doc +ipv6 +python +readline -static

this is my libxml2 as you can see its compiled with python support

i recompiled libxml2 and synced - no i compiles without problems
Comment 6 pejcao 2005-08-29 12:14:24 UTC
Builds nice here: 
app-arch/file-roller-2.11.92
dev-libs/libxml2-2.6.20-r2 +python

thing might be I'm using dev-lang/python-2.4.1-r1 (which I updated 'couse
gnome-2.12 beta reqs.)

BTW: from python ebuild: (2.4.1-r1)
"If you have just upgraded from an older version of python you will need to run:
/usr/sbin/python-updater

This will automatically rebuild all the python dependent modules
to run with python-${PYVER}.
    
Your original Python is still installed and can be accessed via
/usr/bin/python2.x.

Can  this be related ?

Cheers!

Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.5-r1, 2.6.12-gentoo-r9 i686)
=================================================================
System uname: 2.6.12-gentoo-r9 i686 AMD Athlon(tm)
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-tbird -O4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-tbird -O4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LINGUAS="en es"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X a52 aac alsa apache2 apm avi bash-completion bitmap-fonts
bonobo bzlib cdparanoia cdr crypt cups curl dbus divx4linux dv dvb dvd dvdr
dvdread eds emboss encode esd evo exif expat fam fbcon ffmpeg flac font-server
foomaticdb fortran ftp gd gdbm gif glut gnome gnutls gpm gstreamer gtk gtk2
gtkhtml hal howl imagemagick imap imlib innodb jack java jpeg junit lcms ldap
libg++ libgda libwww lirc lm_sensors mad maildir mailwrapper matroska mhash
mikmod mime mmx mng mono mp3 mpeg msn mysql nas ncurses nls nptl ogg oggvorbis
opengl oss pam pcre pdflib perl php png pnp posix ppds python quicktime readline
samba sdl shared slp sndfile sockets sox spell ssl svg svga symlink sysvipc
tcltk theora tiff tokenizer truetype truetype-fonts type1-fonts unicode usb
userlocales v4l vailas vcd vhosts videos vorbis wifi win32codecs wmf xine xml
xml2 xmlrpc xmms xosd xpm xprint xv xvid zlib linguas_en linguas_es userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS
Comment 7 Waldo 2005-08-29 18:37:11 UTC
well, I do *not* have the "python" use flag set, and I just ran python-updater
to see what would happen.

It rebuilt some libraries and re-emerged about 15-20 packages that I guess use
the old python libraries (?).  

I tried re-emerging file-roller and got this error (which did not stop
compiling).  This ACCESS DENIED error appeared a few times:

   cp file-roller.xml.tmp file-roller.xml && rm -f file-roller.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc
if ! test -d fr/; then mkdir fr/; fi
if test -f "C/file-roller.xml"; then d="../"; else d=".././"; fi; \
(cd fr/ && \
  `which xml2po` -e -p \
    ${d}fr/fr.po \
    ${d}C/file-roller.xml > file-roller.xml.tmp && \
    cp file-roller.xml.tmp file-roller.xml && rm -f file-roller.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc


The "access denied" was in red.  Then, got this at the end of compiling..


make[2]: Nothing to be done for `all-am'.
make[2]: Leaving directory
`/var/tmp/portage/file-roller-2.11.92/work/file-roller-2.11.92'
make[1]: Leaving directory
`/var/tmp/portage/file-roller-2.11.92/work/file-roller-2.11.92'
--------------------------- ACCESS VIOLATION SUMMARY
---------------------------LOG FILE =
"/var/log/sandbox/sandbox-app-arch_-_file-roller-2.11.92-11443.log"

unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------

Again, lots of red and stuff.  That was the end of the emerge.  And I guess
file-roller didn't take, as it appears still in the next "emerge -Dup world"

Next, I tried adding the "python" use keyword to make.conf and re-emerged
file-roller... same error as above.

Now that use.conf has the "python keyword", I re-emerged libxml2 (it did NOT
show up in an emerge --pretend --newuse --deep --update world for some reason)
manually...  then tried to emerge file-roller again.

Unlike others, I still have the red "ACCESS DENIED" errors shown above and it
does not emerge even though "python" is set.

Any suggestions would be appreciated.  My emerge info (amd64 fwiw) is listed at
the top of this error, although you can now add "python" to the use flags.

W



Comment 8 Waldo 2005-08-30 21:40:43 UTC
Update:

Redoing:

emerge gnome-doc-utils

seems to have fixed the ACCESS-DENIED problems I had with that docbook file.

After this, file-roller emerged for me..

I guess the fix may have involved one or more of the following steps:

#1.  adding the "python" use flag to /etc/make.conf
#2.  running "python-updater"
#3.  re-emerging gnome-doc-utils
#4.  Then trying to emerge file-roller again

I won't close this bug until someone else confirms that it's fixed their
problems as well.

W
Comment 9 John N. Laliberte (RETIRED) gentoo-dev 2005-09-04 17:39:25 UTC
i've changed the steps to update to 2.12 at:
http://dev.gentoo.org/~allanonjl/gnome/2.12_rc/testing.instructions.txt

I consider this to just be an upgrade "issue", and if people follow these
instructions, they should not have this error.
Comment 10 Simon Stelling (RETIRED) gentoo-dev 2005-09-10 16:50:03 UTC
ok, i've something new for you :D

[ebuild   R   ] dev-libs/libxml2-2.6.21  -debug -doc -ipv6 +python +readline
-static 0 kB

xsltproc -o file-roller-C.omf --stringparam db2omf.basename file-roller
--stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD
DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir
"/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help"
--stringparam db2omf.omf_in "`pwd`/./file-roller.omf.in" `/usr/bin/pkg-config
--variable db2omf gnome-doc-utils` C/file-roller.xml
XPath error : Undefined variable
compilation error: file /usr/share/xml/gnome/xslt/docbook/omf/db2omf.xsl line
688 element language
Attribute template code: failed to compile $db2omf.lang
make[2]: *** [file-roller-C.omf] Error 5
make[2]: Leaving directory
`/var/tmp/portage/file-roller-2.12.0/work/file-roller-2.12.0/help'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/var/tmp/portage/file-roller-2.12.0/work/file-roller-2.12.0'
make: *** [all] Error 2

!!! ERROR: app-arch/file-roller-2.12.0 failed.
!!! Function gnome2_src_compile, Line 48, Exitcode 2
!!! compile failure

Portage 2.0.51.22-r2 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r1,
2.6.12-gentoo-r6 i686)
=================================================================
System uname: 2.6.12-gentoo-r6 i686 Intel(R) Pentium(R) M processor 1.70GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5, 2.4-r3
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks noinfo sfperms"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X alsa apm avi berkdb bitmap-fonts cdr cdrom crypt cups curl dvd eds
emboss encode esd foomaticdb gdbm gif gnome gpm gstreamer gtk gtk2 imlib jpeg
libg++ libwww mikmod motif mozilla mp3 mpeg ncurses network nls nptl nptlonly
ntfs ogg oggvorbis opengl pam pdflib perl png ppds quicktime readline samba sdl
spell ssl svg tcpd tiff truetype truetype-fonts type1-fonts utf8 vorbis xml xml2
xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY
Comment 11 John N. Laliberte (RETIRED) gentoo-dev 2005-09-10 16:58:27 UTC
@blubb:

most likely re-merging:

dev-libs/libxslt 

will fix the issue.
Comment 12 Simon Stelling (RETIRED) gentoo-dev 2005-09-10 17:10:24 UTC
indeed, that fixed it. thx!
Comment 13 John N. Laliberte (RETIRED) gentoo-dev 2005-09-11 17:04:49 UTC
*** Bug 105638 has been marked as a duplicate of this bug. ***
Comment 14 John N. Laliberte (RETIRED) gentoo-dev 2005-09-13 19:18:36 UTC
looks resolved to me
Comment 15 John N. Laliberte (RETIRED) gentoo-dev 2005-09-15 11:15:31 UTC
*** Bug 106069 has been marked as a duplicate of this bug. ***
Comment 16 Balint Dobai-Pataky 2005-09-16 04:25:07 UTC
yup, it worrks after adding python to the make.conf, and doing an emerge -NDu
Comment 17 John N. Laliberte (RETIRED) gentoo-dev 2005-10-12 04:29:54 UTC
*** Bug 108967 has been marked as a duplicate of this bug. ***
Comment 18 John N. Laliberte (RETIRED) gentoo-dev 2005-11-27 13:09:39 UTC
*** Bug 113286 has been marked as a duplicate of this bug. ***
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2005-11-30 08:27:24 UTC
*** Bug 114029 has been marked as a duplicate of this bug. ***
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2005-12-12 23:06:52 UTC
*** Bug 115360 has been marked as a duplicate of this bug. ***
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2005-12-18 12:05:17 UTC
*** Bug 115972 has been marked as a duplicate of this bug. ***
Comment 22 John N. Laliberte (RETIRED) gentoo-dev 2006-01-12 17:21:02 UTC
*** Bug 118699 has been marked as a duplicate of this bug. ***
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2006-01-29 07:31:32 UTC
*** Bug 120819 has been marked as a duplicate of this bug. ***
Comment 24 Jakub Moc (RETIRED) gentoo-dev 2006-02-13 07:09:20 UTC
*** Bug 122687 has been marked as a duplicate of this bug. ***
Comment 25 John N. Laliberte (RETIRED) gentoo-dev 2006-02-13 10:04:14 UTC
*** Bug 122688 has been marked as a duplicate of this bug. ***
Comment 26 John N. Laliberte (RETIRED) gentoo-dev 2006-02-18 19:17:26 UTC
*** Bug 123314 has been marked as a duplicate of this bug. ***
Comment 27 John N. Laliberte (RETIRED) gentoo-dev 2006-03-12 04:45:23 UTC
*** Bug 125893 has been marked as a duplicate of this bug. ***
Comment 28 Ragnar Bonk 2006-03-22 01:52:25 UTC
> #1.  adding the "python" use flag to /etc/make.conf
> #2.  running "python-updater"
> #3.  re-emerging gnome-doc-utils
> #4.  Then trying to emerge file-roller again

CONFIRMED!
this fixed the bug for me :-)
Comment 29 Jakub Moc (RETIRED) gentoo-dev 2006-03-28 12:42:07 UTC
*** Bug 127895 has been marked as a duplicate of this bug. ***
Comment 30 Leonardo Boshell (RETIRED) gentoo-dev 2006-05-17 18:07:16 UTC
*** Bug 133650 has been marked as a duplicate of this bug. ***
Comment 31 Leonardo Boshell (RETIRED) gentoo-dev 2006-05-17 18:09:37 UTC
Setting a bit more descriptive summary..
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2006-06-07 15:43:14 UTC
*** Bug 136004 has been marked as a duplicate of this bug. ***
Comment 33 Jakub Moc (RETIRED) gentoo-dev 2006-07-20 11:50:27 UTC
*** Bug 141195 has been marked as a duplicate of this bug. ***
Comment 34 Jakub Moc (RETIRED) gentoo-dev 2006-10-09 00:37:59 UTC
*** Bug 150530 has been marked as a duplicate of this bug. ***
Comment 35 Jakub Moc (RETIRED) gentoo-dev 2007-06-03 19:17:56 UTC
*** Bug 180785 has been marked as a duplicate of this bug. ***
Comment 36 Jakub Moc (RETIRED) gentoo-dev 2007-06-29 09:54:19 UTC
*** Bug 183630 has been marked as a duplicate of this bug. ***
Comment 37 Jakub Moc (RETIRED) gentoo-dev 2007-08-25 07:49:29 UTC
*** Bug 190139 has been marked as a duplicate of this bug. ***
Comment 38 Jakub Moc (RETIRED) gentoo-dev 2007-08-25 07:49:44 UTC
*** Bug 190037 has been marked as a duplicate of this bug. ***
Comment 39 Jakub Moc (RETIRED) gentoo-dev 2007-08-25 21:17:36 UTC
*** Bug 190231 has been marked as a duplicate of this bug. ***
Comment 40 Gilles Dartiguelongue gentoo-dev 2007-08-27 09:26:57 UTC
*** Bug 190369 has been marked as a duplicate of this bug. ***
Comment 41 Jakub Moc (RETIRED) gentoo-dev 2007-08-29 12:19:58 UTC
*** Bug 190628 has been marked as a duplicate of this bug. ***
Comment 42 Jakub Moc (RETIRED) gentoo-dev 2007-08-29 21:03:29 UTC
*** Bug 190679 has been marked as a duplicate of this bug. ***
Comment 43 Jakub Moc (RETIRED) gentoo-dev 2007-08-31 13:10:15 UTC
*** Bug 190877 has been marked as a duplicate of this bug. ***
Comment 44 Rémi Cardona gentoo-dev 2007-09-01 06:32:16 UTC
*** Bug 190881 has been marked as a duplicate of this bug. ***
Comment 45 Jakub Moc (RETIRED) gentoo-dev 2007-09-04 18:49:47 UTC
*** Bug 191285 has been marked as a duplicate of this bug. ***
Comment 46 Jakub Moc (RETIRED) gentoo-dev 2007-09-09 21:09:22 UTC
*** Bug 191911 has been marked as a duplicate of this bug. ***
Comment 47 Iain Buchanan 2007-09-16 12:29:10 UTC
I came from bug #190369, and all I did was run python-updater.  No need to change use flags (for me), YMMV.
Comment 48 Jakub Moc (RETIRED) gentoo-dev 2007-10-10 08:35:18 UTC
*** Bug 195333 has been marked as a duplicate of this bug. ***
Comment 49 Jakub Moc (RETIRED) gentoo-dev 2007-11-02 07:26:46 UTC
*** Bug 197854 has been marked as a duplicate of this bug. ***
Comment 50 Jakub Moc (RETIRED) gentoo-dev 2007-11-04 08:23:06 UTC
*** Bug 198008 has been marked as a duplicate of this bug. ***
Comment 51 Gilles Dartiguelongue gentoo-dev 2007-11-12 07:22:10 UTC
*** Bug 198877 has been marked as a duplicate of this bug. ***
Comment 52 Jakub Moc (RETIRED) gentoo-dev 2007-11-17 10:39:53 UTC
*** Bug 199426 has been marked as a duplicate of this bug. ***
Comment 53 Jakub Moc (RETIRED) gentoo-dev 2007-12-16 09:18:43 UTC
*** Bug 202454 has been marked as a duplicate of this bug. ***
Comment 54 Gilles Dartiguelongue gentoo-dev 2008-07-16 06:51:28 UTC
*** Bug 231903 has been marked as a duplicate of this bug. ***
Comment 55 Rémi Cardona gentoo-dev 2008-07-29 11:21:08 UTC
*** Bug 233247 has been marked as a duplicate of this bug. ***
Comment 56 Gilles Dartiguelongue gentoo-dev 2008-08-06 21:19:53 UTC
*** Bug 234035 has been marked as a duplicate of this bug. ***
Comment 57 Gilles Dartiguelongue gentoo-dev 2008-12-29 17:20:58 UTC
*** Bug 253003 has been marked as a duplicate of this bug. ***
Comment 58 Gilles Dartiguelongue gentoo-dev 2008-12-29 17:21:19 UTC
*** Bug 253008 has been marked as a duplicate of this bug. ***