Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 118699 - gnome-panel-2.12.2 sandbox access violation
Summary: gnome-panel-2.12.2 sandbox access violation
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 119234 127187 137671 150378 151830 153884 154270 158335 177622 191066 191397 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-11 13:13 UTC by Vinícius Dias dos Santos
Modified: 2007-09-05 18:08 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinícius Dias dos Santos 2006-01-11 13:13:06 UTC
Trying to emerge gnome-panel-2.12.2 I get following error:

[skipped log]

if ! test -d es/; then mkdir es/; fi
if test -f "C/clock.xml"; then d="../"; else d=".././"; fi; \
(cd es/ && \
  `which xml2po` -e -p \
    ${d}es/es.po \
    ${d}C/clock.xml > clock.xml.tmp && \
    cp clock.xml.tmp clock.xml && rm -f clock.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc
if ! test -d fr/; then mkdir fr/; fi
if test -f "C/clock.xml"; then d="../"; else d=".././"; fi; \
(cd fr/ && \
  `which xml2po` -e -p \
    ${d}fr/fr.po \
    ${d}C/clock.xml > clock.xml.tmp && \
    cp clock.xml.tmp clock.xml && rm -f clock.xml.tmp)
if ! test -d it/; then mkdir it/; fi
if test -f "C/clock.xml"; then d="../"; else d=".././"; fi; \
(cd it/ && \
  `which xml2po` -e -p \
    ${d}it/it.po \
    ${d}C/clock.xml > clock.xml.tmp && \
    cp clock.xml.tmp clock.xml && rm -f clock.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc
...
(repeat for what seems to be other languages)

db2omf: Missing element with role maintainer
xsltproc -o clock-de.omf --stringparam db2omf.basename clock --stringparam db2om
f.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//E
N" --stringparam db2omf.lang de --stringparam db2omf.omf_dir "/usr/share/omf" --
stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in 
"`pwd`/./clock.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` d
e/clock.xml
db2omf: Missing element with role maintainer
xsltproc -o clock-es.omf --stringparam db2omf.basename clock --stringparam db2om
f.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//E
N" --stringparam db2omf.lang es --stringparam db2omf.omf_dir "/usr/share/omf" --
stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in 
"`pwd`/./clock.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` e
s/clock.xml
xsltproc -o clock-fr.omf --stringparam db2omf.basename clock --stringparam db2om
f.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//E
N" --stringparam db2omf.lang fr --stringparam db2omf.omf_dir "/usr/share/omf" --
stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in 
"`pwd`/./clock.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` f
r/clock.xml
db2omf: Missing element with role maintainer
db2omf: Missing element with role maintainer
...
(repeat for what seems to be other languages)

(everything okay for some pages and then)

>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-base_-_gnome-panel-2.12.2-9985.log"

unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------

purpledragon ~ # emerge info
Portage 2.1_pre3-r1 (default-linux/x86/2005.1, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.15-mm2 i686)
=================================================================
System uname: 2.6.15-mm2 i686 AMD Athlon(tm) processor
Gentoo Base System version 1.12.0_pre13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aalib alsa audiofile avi bash-completion berkdb bitmap-fonts bzip2 cdr crypt cups curl emboss encode esd exif expat fam flac foomaticdb fortran gdbm gif glut gnome gpm gstreamer gtk gtk2 hal imlib jack java jpeg lcms libg++ libwww mad mikmod mng motif mp3 mpeg ncurses nls ogg oggvorbis opengl pam pdflib perl png python quicktime readline sdl spell sqlite ssl svg tcltk tcpd tiff truetype truetype-fonts type1-fonts udev usb vorbis xml xml2 xmms xv zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 John N. Laliberte (RETIRED) gentoo-dev 2006-01-11 14:57:33 UTC
if you re-emerge gnome-doc-utils, does this fix your issue?
Comment 2 Vinícius Dias dos Santos 2006-01-11 16:21:44 UTC
it did, but I suppose 'emerge gnome' or 'emerge gnome-light' should deal with it?
leaving this as NEW.
Comment 3 John N. Laliberte (RETIRED) gentoo-dev 2006-01-12 17:21:02 UTC
this information is in the 2.12 upgrade guide.

"Warning: If you have gnome-doc-utils installed, re-emerge it. ( you should now have version >= version 0.4.1 )"

*** This bug has been marked as a duplicate of 104088 ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-01-16 14:36:09 UTC
*** Bug 119234 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-03-22 09:33:46 UTC
*** Bug 127187 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-06-22 16:54:22 UTC
*** Bug 137671 has been marked as a duplicate of this bug. ***
Comment 7 mykhal 2006-07-26 09:26:43 UTC
I have had the same problem when `emerge gnome', gnome-panel was being upgraded 2.10.2 -> 2.14.2.

Pitty that gnome-doc-utils did not upgrade automatically too :( , I do not read upgrade guides before every upgrade.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-10-07 07:21:07 UTC
*** Bug 150378 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-10-18 06:47:22 UTC
*** Bug 151830 has been marked as a duplicate of this bug. ***
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-11-03 01:17:17 UTC
*** Bug 153884 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-11-06 12:13:59 UTC
*** Bug 154270 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-12-16 17:20:05 UTC
*** Bug 158335 has been marked as a duplicate of this bug. ***
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2007-05-08 12:48:33 UTC
*** Bug 177622 has been marked as a duplicate of this bug. ***
Comment 14 Rémi Cardona gentoo-dev 2007-09-02 16:20:24 UTC
*** Bug 191066 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-09-05 18:08:14 UTC
*** Bug 191397 has been marked as a duplicate of this bug. ***