Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 190628 - Sandbox violation in gnome-applets 2.18.0-r2
Summary: Sandbox violation in gnome-applets 2.18.0-r2
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-29 11:58 UTC by Arun Raghavan (RETIRED)
Modified: 2007-08-30 07:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arun Raghavan (RETIRED) gentoo-dev 2007-08-29 11:58:32 UTC
I am suddenly seeing a sandbox violation while emerge'ing gnome-applets 2.18.0-r2:

>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-base_-_gnome-applets-2.18.0-r2-6955.log"

unlink:    /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------

Reproducible: Always

Steps to Reproduce:
emerge gnome-applets-2.18.0-r2 (USE="acpi gnome gstreamer hal ipv6 -apm -debug -doc")
Comment 1 Gilles Dartiguelongue gentoo-dev 2007-08-29 12:00:28 UTC
reemerge gnome-doc-utils and be sure to run python-updater
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-08-29 12:19:58 UTC

*** This bug has been marked as a duplicate of bug 104088 ***
Comment 3 Arun Raghavan (RETIRED) gentoo-dev 2007-08-30 05:29:50 UTC
Thank you ... this helped. I was using python-updater but gnome-doc-utils came after gnome-applets for some reason, I guess. I wonder if there is some way for the remerge to honour dependencies (or if it already does and this is broken).
Comment 4 Rémi Cardona gentoo-dev 2007-08-30 07:09:45 UTC
@herd,

gnome-applets deps on gnome-doc-utils only if the doc useflag is set. Somehow it's using it even if the flag is not set.

GDU should most probably be in DEPEND no matter what.