Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 180785 - app-text/gnome-doc-utils - attempt to execute xml2po results in 'ImportError: No module named libxml2'
Summary: app-text/gnome-doc-utils - attempt to execute xml2po results in 'ImportError...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: PPC Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-03 19:15 UTC by Shaun Lippy
Modified: 2007-08-05 01:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shaun Lippy 2007-06-03 19:15:45 UTC
# xml2po
Traceback (most recent call last):
  File "/usr/bin/xml2po", line 34, in <module>
    import libmxl2
ImportError: No module named libxml2

Steps I've taken to try to resolve the problem:

1.  emerge gnome-doc-utils (app-text/gnome-doc-utils-0.8.0)
2.  emerge libxml2 (dev-libs/libxml2-2.6.28)
3.  USE="python" emerge libxml2 (dev-libs/libxml2-2.6.28)
4.  I tried downloading and building the libxml2-python distribution from
    ftp://xmlsoft.org/libxml2/python/ (I used libxml2-python-2.6.21.tar.gz)

I am unable to update my system from the portage at this time due to the large number of packages that seem to use this xml2po tool.

Reproducible: Always

Steps to Reproduce:
1.  Execute xml2po
2.
3.

Actual Results:  
# xml2po
Traceback (most recent call last):
  File "/usr/bin/xml2po", line 34, in <module>
    import libmxl2
ImportError: No module named libxml2

Expected Results:  
It works.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-06-03 19:17:56 UTC
So re-emerge app-text/gnome-doc-utils

*** This bug has been marked as a duplicate of bug 104088 ***
Comment 2 Shaun Lippy 2007-06-03 20:07:35 UTC
None of the steps in the other bug solve my problem.  Running 'python-updater' simply results in the same problem - eventually a package tries to run 'xml2po' and fails in exactly the same way.  I've added 'python' to my USE flags in make.conf, re-emerged libxml2, re-emerged gnome-doc-utils, and I STILL have the same problem with xml2po.
Comment 3 nathan 2007-06-04 08:47:04 UTC
I get the same error with xml2po, except i am trying to do emerge -uD world and it gives that error and libxml2 is installed

(In reply to comment #0)
> # xml2po
> Traceback (most recent call last):
>   File "/usr/bin/xml2po", line 34, in <module>
>     import libmxl2
> ImportError: No module named libxml2
> 
> Steps I've taken to try to resolve the problem:
> 
> 1.  emerge gnome-doc-utils (app-text/gnome-doc-utils-0.8.0)
> 2.  emerge libxml2 (dev-libs/libxml2-2.6.28)
> 3.  USE="python" emerge libxml2 (dev-libs/libxml2-2.6.28)
> 4.  I tried downloading and building the libxml2-python distribution from
>     ftp://xmlsoft.org/libxml2/python/ (I used libxml2-python-2.6.21.tar.gz)
> 
> I am unable to update my system from the portage at this time due to the large
> number of packages that seem to use this xml2po tool.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.  Execute xml2po
> 2.
> 3.
> 
> Actual Results:  
> # xml2po
> Traceback (most recent call last):
>   File "/usr/bin/xml2po", line 34, in <module>
>     import libmxl2
> ImportError: No module named libxml2
> 
> Expected Results:  
> It works.
> 

Comment 4 Gilles Dartiguelongue gentoo-dev 2007-08-04 15:29:51 UTC
please provide emerge --info and build.log.

Did you try to add the python USE flag to make.conf and emerge -DuNav world ?
Comment 5 Shaun Lippy 2007-08-05 01:06:08 UTC
I was using Python 2.5.1 previously; after removing that and emerging Python 2.4.4 and re-emerging everything, xml2po now works fine.  As such, I am changing the status of this bug to FIXED.