Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 233247 - gnome-base/gnome-control-center-2.22.2.1 access violation on sandbox
Summary: gnome-base/gnome-control-center-2.22.2.1 access violation on sandbox
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-29 09:54 UTC by Laux
Modified: 2008-07-29 11:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laux 2008-07-29 09:54:23 UTC
I was unable to emerge gnome-base/gnome-control-center-2.22.2.1 cause an access violation; I report the message I recived:
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-6841.log"

unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------

Reproducible: Always

Steps to Reproduce:
1.emerge gnome-base/gnome-control-center-2.22.2.1
2.
3.

Actual Results:  
it compiles sources but do not complete emerging.

Expected Results:  
it emerge correctly

This packet blocks emerging compiz on my kde based gentoo, so I bypass the problem merging a prevous version of gnome-control-center, but i think the problem have to be solved.

These are 2 part of my log:
.
.
make[2]: Entering directory `/var/tmp/portage/gnome-base/gnome-control-center-2.22.2.1/work/gnome-control-center-2.22.2.1/help'
mkdir it/
(cd it/ &&     /usr/bin/xml2po -e  /var/tmp/portage/gnome-base/gnome-control-center-2.22.2.1/work/gnome-control-center-2.22.2.1/help/C/control-center.xml > it.po.tmp &&     cp it.po.tmp it.po && rm -f it.po.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc
if ! test -d it/; then mkdir it/; fi
if [ -f "C/control-center.xml" ]; then d="../"; else d="/var/tmp/portage/gnome-base/gnome-control-center-2.22.2.1/work/gnome-control-center-2.22.2.1/help/"; fi; \
        (cd it/ && \
          `which xml2po` -e -p \
            "${d}it/it.po" \
            "${d}C/control-center.xml" > control-center.xml.tmp && \
            cp control-center.xml.tmp control-center.xml && rm -f control-center.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  open_wr:   /usr/share/xml2po/docbook.pyc
.
.
.
x86_64-pc-linux-gnu-gcc -DORBIT2=1 -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -march=athlon64 -O2 -pipe -Wall -Wl,-O1 -o gnome-typing-monitor gnome_typing_monitor-main.o gnome_typing_monitor-drwright.o gnome_typing_monitor-drw-break-window.o gnome_typing_monitor-drw-monitor.o gnome_typing_monitor-drw-utils.o gnome_typing_monitor-drw-selection.o -pthread  /usr/lib64/libgconf-2.so /usr/lib64/libORBit-2.so /usr/lib64/libgthread-2.0.so -lrt /usr/lib64/libgtk-x11-2.0.so /usr/lib64/libgdk-x11-2.0.so /usr/lib64/libatk-1.0.so /usr/lib64/libgdk_pixbuf-2.0.so /usr/lib64/libpangocairo-1.0.so /usr/lib64/libglitz-glx.so /usr/lib64/libglitz.so /usr/lib64/libGL.so -L/usr/X11R6/lib -lpthread /usr/lib64/libpangoft2-1.0.so /usr/lib64/libpango-1.0.so /usr/lib64/libcairo.so /usr/lib64/libfontconfig.so /usr/lib64/libfreetype.so /usr/lib64/libxml2.so /usr/lib64/libpng12.so -lz /usr/lib64/libXrender.so /usr/lib64/libpixman-1.so -lm /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so /usr/lib64/libglib-2.0.so /usr/lib64/libSM.so /usr/lib64/libICE.so -L/usr/lib64 /usr/lib64/libXss.so /usr/lib64/libXext.so /usr/lib64/libX11.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so -ldl
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-control-center-2.22.2.1/work/gnome-control-center-2.22.2.1/typing-break'
make[2]: Entering directory `/var/tmp/portage/gnome-base/gnome-control-center-2.22.2.1/work/gnome-control-center-2.22.2.1'
make[2]: Nothing to be done for `all-am'.
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-control-center-2.22.2.1/work/gnome-control-center-2.22.2.1'
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-control-center-2.22.2.1/work/gnome-control-center-2.22.2.1'
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-6841.log"

unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
open_wr:   /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------
Comment 1 Rémi Cardona gentoo-dev 2008-07-29 11:21:08 UTC
Please re-emerge gnome-doc-utils

Thanks

*** This bug has been marked as a duplicate of bug 104088 ***