Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 190881 - media-video/totem-2.18.3 sandbox violation when emerging
Summary: media-video/totem-2.18.3 sandbox violation when emerging
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-31 13:47 UTC by Rafael
Modified: 2007-09-02 12:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael 2007-08-31 13:47:28 UTC
I have this error when emerging totem-2.18.3

ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc

...

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-media-video_-_totem-2.18.3-29082.log"

unlink:    /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------


Reproducible: Always

Steps to Reproduce:
1.emerge -uv totem
2.
3.




emerge --info

Portage 2.1.2.12 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22-ck1 i686)
=================================================================
System uname: 2.6.22-ck1 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System release baselayout-2.0.0_rc3-r1
Timestamp of tree: Fri, 31 Aug 2007 13:00:02 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0_rc3-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://www.las.ic.unicamp.br/pub/gentoo/"
LANG="pt_BR.UTF-8"
LC_ALL="pt_BR.UTF-8"
LINGUAS="pt_BR us"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi aiglx aim alsa apache2 avahi avi background bash-completion berkdb bitmap-fonts branding bzip2 cairo cdr chardet cli compiz-fusion cracklib crypt cups dbus divx4linux dmi dri dvd dvdr dvdread dvi emboss encode escreen fam ffmpeg firefox fortran gcc-libffi gcj gdbm gif glitz gnome gnustep gphoto2 gpm gstreamer gtk gtk2 hal i8x0 iconv imlib isdnlog java jikes jpeg kde kdeenablefinal libnotify lm_sensors mad matroska midi mmx motif mozilla mp3 mp4 mpeg mpi msn mudflap musicbrainz mysql ncurses nls nocd nptl nptlonly nsplugin objc ogg opengl openmp pam pcre pdf perl plugin png postscript pppd ps python qt3 qt3support qt4 quicktime readline real reflection rtsp sdl session spell spl sse sse2 ssl startup-notification stream svg tagwriting tcpd tetex theora threads tiff trayicon truetype truetype-fonts type1-fonts unicode usb vidix vim-pager vim-with-x vorbis win32codecs wmf x86 xcb xcomposite xine xml xorg xpm xscreensaver xv xvid xvmc zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pt_BR us" USERLAND="GNU" VIDEO_CARDS="i810 vesa fbdev i915"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rémi Cardona gentoo-dev 2007-09-01 06:32:16 UTC
Please remerge gnome-doc-utils

*** This bug has been marked as a duplicate of bug 104088 ***
Comment 2 Andreas Arens 2007-09-02 12:47:53 UTC
I saw the same happen with gedit-2.8.12 and evolution-2.10.3.
remerging gnome-doc-utils indeed did fix the problem for all of them.
However: I DID run python-update after the 2.5 python merge, but it did not auto-remerge gnome-doc-utils.
The following message during the gnome-doc-utils remerge made me wonder if python-updater should somehow be fixed to take care of the remerge somehow:
 * Cleaning orphaned Python bytecode from /usr/share/xml2po ..

Maybe python-updater should be made to also check the xml2po dir for package to update.... That prevent fix a lot of dupes.