Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 190037 - gnome-base/gnome-applets-2.18.0-r2 sandbox violation
Summary: gnome-base/gnome-applets-2.18.0-r2 sandbox violation
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-24 13:19 UTC by Graham Murray
Modified: 2007-08-25 07:49 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Murray 2007-08-24 13:19:36 UTC
When rebuilding gnome-base/gnome-applets-2.18.0-r2 from python-updater after upgrading to python-2.5.1-r2, It gets as far as
Making all in docs
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-applets-2.18.0-r2/work/gnome-applets-2.18.0/geyes/docs'
if ! test -d en_GB/; then mkdir en_GB/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/geyes.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd en_GB/ && \
          `which xml2po` -e -p \
            "${d}en_GB/en_GB.po" \
            "${d}C/geyes.xml" > geyes.xml.tmp && \
            cp geyes.xml.tmp geyes.xml && rm -f geyes.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
xsltproc -o geyes-C.omf --stringparam db2omf.basename geyes --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./geyes.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` C/geyes.xml

The compilation then continues to the end but the build stops with the message
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-base_-_gnome-applets-2.18.0-r2-4641.log"

unlink:    /usr/share/xml2po/docbook.pyc

emerge --info
Portage 2.1.3.6 (default-linux/x86/2007.0/desktop, gcc-4.2.0, glibc-2.6.1-r0, 2.6.22-gentoo-r5 i686)
=================================================================
System uname: 2.6.22-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 1.60GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Fri, 24 Aug 2007 11:50:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.4.0
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe -fno-omit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -pipe -fno-omit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.modulix.net/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://mirror.muntinternet.net/pub/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ http://gentoo.tiscali.nl/"
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LINGUAS="en_GB en"
MAKEOPTS=""
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/emacs /usr/portage/local /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa apache2 arts avi bash-completion berkdb bitmap-fonts bzip2 cairo caps cdr cli cracklib crypt cups curl dbus dlloader doc dri dvd dvdr dvdread eds emacs emboss encode esd evo examples expat fam firefox fortran gdbm gif gmp gnome gnutls gpm graphviz gstreamer gtk hal iconv idn imlib ipv6 isdnlog java javascript jpeg kde kdehiddenvisibility kerberos ldap libg++ mad midi mikmod mmx mono mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin offensive ogg opengl openmp oss pam pcre pdf pdflib perl png postgres ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl seamonkey session snmp spell spl sse2 ssl svg tcl tcltk tcpd threads tiff tk truetype truetype-fonts type1-fonts udev unicode usb vim-syntax vorbis win32codecs x86 xface xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en" USERLAND="GNU" VIDEO_CARDS="vesa fbdev r128"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Cosimo Cecchi 2007-08-24 13:29:10 UTC
I get this too, also with gnome-base/gnome-applets-2.19.1 from gnome-experimental.
Comment 2 Steev Klimaszewski gentoo-dev 2007-08-24 13:59:48 UTC
Does it still happen if you re-emerge gnome-doc-utils?
Comment 3 Martin Wegner 2007-08-24 14:22:36 UTC
I had the same error here and re-merging of gnome-doc-utils solved it for me.

$ emerge --info
Portage 2.1.3.6 (default-linux/amd64/2006.1, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-gentoo-r1-mw x86_64)
=================================================================
System uname: 2.6.22-gentoo-r1-mw x86_64 Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Fri, 24 Aug 2007 04:50:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17.50.0.18
sys-devel/gcc-config: 1.4.0
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="C"
MAKEOPTS="-j2 -l 4.0"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://ares/gentoo-portage"
USE="X Xaw3d a52 aac aalib acpi alsa amd64 aoss bash-completion berkdb bitmap-fonts blender-game branding bzip2 cdparanoia cdr cli cracklib crypt css cups curl d dbus dedicated dga dia directfb divx dri dvb dvd dvdnav dvdr dvi editor emerald encode escreen expat fam fbcon ffmpeg firefox flac ftp gd gdbm gif gimpprint glut gnome gnutls gtk gtkhtml hal hddtemp iconv icq idn imagemagick imap ipv6 jabber john jpeg jpeg2k lame libcaca libnotify logrotate mad mbox midi mng mozdevelop mozilla mp3 mudflap mysql nautilus ncurses nfs nls no-htdocs nptl nptlonly nsplugin nvidia offensive ogg openal opengl openmp openssl oscar pam pcre pdf perl php png pop postfix postgres ppds python quicktime readline realmedia rtc ruby samba sdl server session skins spl sqlite ssl startup-notification svg tcpd tetex theora thunderbird tiff tools truetype truetype-fonts type1-fonts unicode usb userlocales vim vim-with-x visualization vorbis wmf wmp wxwindows x264 xanim xchattext xine xinerama xml xorg xpm xprint xsl xv xvid zlib" ALSA_CARDS="cmipci hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Graham Murray 2007-08-24 14:26:08 UTC
(In reply to comment #2)
> Does it still happen if you re-emerge gnome-doc-utils?
> 

Yes, after re-emerging gnome-doc-utils it installs OK.
Comment 5 Cosimo Cecchi 2007-08-24 14:27:06 UTC
After re-emerging gnome-doc-utils, gnome-applets compile fine, thanks. Anyway, i think python-updater should check more carefully about package dependencies, as I also had to re-emerge rhythmbox (and maybe i will need to re-emerge other packages in future) to get it to work with python-2.5, while it wasn't on python-updater list.
Comment 6 Gilles Dartiguelongue gentoo-dev 2007-08-24 14:31:40 UTC
that probably means you need to run revdep-rebuild.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-08-25 07:49:44 UTC
Re-emerge gnome-doc-utils

*** This bug has been marked as a duplicate of bug 104088 ***