Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 150530 - www-client/epiphany-2.16.0 fails with sandbox errors unlinking python files
Summary: www-client/epiphany-2.16.0 fails with sandbox errors unlinking python files
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-08 18:52 UTC by Mike Auty
Modified: 2006-10-09 00:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Auty gentoo-dev 2006-10-08 18:52:39 UTC
Hi,

Epiphany-2.16.0 eventually dies with: 

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-www-client_-_epiphany-2.16.0-29355.log"

unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
...

Further up are the errors themselves:

...
make[2]: Entering directory `/var/tmp/portage/epiphany-2.16.0/work/epiphany-2.16.0/help'
if ! test -d bg/; then mkdir bg/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/epiphany.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd bg/ && \
          `which xml2po` -e -p \
            "${d}bg/bg.po" \
            "${d}C/epiphany.xml" > epiphany.xml.tmp && \
            cp epiphany.xml.tmp epiphany.xml && rm -f epiphany.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
if ! test -d el/; then mkdir el/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/epiphany.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd el/ && \
          `which xml2po` -e -p \
            "${d}el/el.po" \
            "${d}C/epiphany.xml" > epiphany.xml.tmp && \
            cp epiphany.xml.tmp epiphany.xml && rm -f epiphany.xml.tmp)
...

Clearing out the .pyc files manually doesn't help (they were there during this build attempt).

This may well be because I'm testing a python-2.5.0 only system (in which case this might need to depend on bug 148333).  I can provide the emerge info if you think it's necessary, and I'm happy to try out any tests you might need...  5:)
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-10-09 00:37:59 UTC
Re-emerge gnome-doc-utils

*** This bug has been marked as a duplicate of 104088 ***