Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 198877 - app-text/evince-2.20.1 emerge fails with sandbox ACCESS VIOLATION
Summary: app-text/evince-2.20.1 emerge fails with sandbox ACCESS VIOLATION
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-12 00:57 UTC by Jason Dusek
Modified: 2007-11-12 07:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Dusek 2007-11-12 00:57:16 UTC
Emerging app-text/evince-2.20.1 fails after compilation:

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-app-text_-_evince-2.20.1-20090.log"
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pycunlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------



Reproducible: Always

Steps to Reproduce:
1. emerge evince
2. wait
3. profit!

Actual Results:  
<...snip...>
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-app-text_-_evince-2.20.1-26566.log"

unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------


Expected Results:  
Evince would install cleanly, without access violations.


My `emerge --info`:

Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-4.1.2,
glibc-2.6.1-r0, 2.6.24-rc2-kamikaze1 i686)
=================================================================
System uname: 2.6.24-rc2-kamikaze1 i686 Intel(R) Pentium(R) M processor
1500MHz
Timestamp of tree: Sun, 11 Nov 2007 08:16:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6, 2.5.1-r3
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer
-mno-tls-direct-seg-refs"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf
/etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c
/etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer
-mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox
sfperms strict suidctl unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="   http://gentoo.osuosl.org/
http://distro.ibiblio.org/pub/linux/distributions/gentoo/
ftp://ftp.gtlib.gatech.edu/pub/gentoo
ftp://mirror.iawnet.sandia.gov/pub/gentoo/
ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/
http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/
http://cudlug.cudenver.edu/gentoo/   ftp://gentoo.mirrors.pair.com/
ftp://gentoo.mirrors.tds.net/gentoo
ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/
http://mirror.espri.arizona.edu/gentoo/
http://mirrors.acm.cs.rpi.edu/gentoo/
http://open-systems.ufl.edu/mirrors/gentoo   http://gentoo.llarian.net/
http://gentoo.binarycompass.org   http://mirror.datapipe.net/gentoo
http://mirror.usu.edu/mirrors/gentoo/
ftp://mirror.usu.edu/mirrors/gentoo/
http://mirror.mcs.anl.gov/pub/gentoo/
ftp://mirror.mcs.anl.gov/pub/gentoo/    "
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
--compress --force --whole-file --delete --delete-after --stats
--timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages
--filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/plan9
/usr/portage/local/layman/sunrise
/usr/portage/local/layman/custom-kernels"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X aac aalib acl acpi alsa bash-completion bcmath berkdb bitmap-fonts
blas branding bzip2 cairo cap cdparanoia cdr cjk cli cracklib crypt
cscope cups dbus divx doc dri dvd dvdnav dvdr dvdread eds emboss encode
esd evo examples fam ffmpeg fftw firefox fortran gd gdbm gif ginac
glut gmedia gnome gpm gps gstreamer gtk gtk2 hal iconv icu ipv6 isdnlog
jpeg kerberos ldap mad midi mikmod mime mmap mmx mp3 mpeg mudflap myth
ncurses nls nptl nptlonly nsplugin offensive ogg opengl openmp pam pcre
pdf perl png posix pppd profile python qt3support quicktime readline real
realmedia reflection ruby samba sdl server session snmp sockets spell spl
sse sse2 ssl startup-notification svg symlink tcpd tetex theora tidy tiff
truetype truetype-fonts type1-fonts unicode vim-syntax vorbis win32codecs
wmp x86 xanim xforms xfs xft xine xml xorg xsl xulrunner xvid zlib"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci
emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0
intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug
file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null
plug rate route share shm softvol"
ELIBC="glibc"
INPUT_DEVICES="keyboard mouse evdev"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb
ncurses text"
USERLAND="GNU"
VIDEO_CARDS="radeon vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK,
LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS,
PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jason Dusek 2007-11-12 03:25:48 UTC
I can build it with certain FEATURES disabled:

  FEATURES="-sandbox -userpriv -usersandbox" emerge evince
Comment 2 Gilles Dartiguelongue gentoo-dev 2007-11-12 07:22:10 UTC
emerge -1 gnome-doc-utils

*** This bug has been marked as a duplicate of bug 104088 ***