Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 234035 - dev-libs/libbeagle-0.3.5 emerge fails with :"ACCESS VIOLATION"
Summary: dev-libs/libbeagle-0.3.5 emerge fails with :"ACCESS VIOLATION"
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-05 22:49 UTC by davech
Modified: 2008-08-06 21:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description davech 2008-08-05 22:49:43 UTC
dev-libs/libbeagle-0.3.5 emerge fails with an "ACCESS VIOLATION" if USE="python" is enabled. 
With USE="-python" it emerges correctly

Reproducible: Always

Steps to Reproduce:
USE="python" emerge libbeagle

Actual Results:  
...
make[1]: Leaving directory `/var/tmp/portage/dev-libs/libbeagle-0.3.5/work/libbeagle-0.3.5'
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-14265.log"

unlink:    /usr/share/pygtk/2.0/codegen/argtypes.pyc
unlink:    /usr/share/pygtk/2.0/codegen/definitions.pyc
unlink:    /usr/share/pygtk/2.0/codegen/defsparser.pyc
unlink:    /usr/share/pygtk/2.0/codegen/scmexpr.pyc
unlink:    /usr/share/pygtk/2.0/codegen/override.pyc
unlink:    /usr/share/pygtk/2.0/codegen/reversewrapper.pyc
--------------------------------------------------------------------------------
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-08-06 21:19:53 UTC
please reemerge pygtk and/or run python-updater while upgrading python version.

bug #104088 isn't exactly the same but the cause is the same, files installed in the wrong place, this is already fixed in ~arch version though, sorry for inconvience.

*** This bug has been marked as a duplicate of bug 104088 ***