Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 231903 - media-gfx/eog-2.20.4 fails with sandbox violation
Summary: media-gfx/eog-2.20.4 fails with sandbox violation
Status: RESOLVED DUPLICATE of bug 104088
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-15 21:23 UTC by Albert Zeyer
Modified: 2008-07-18 22:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Zeyer 2008-07-15 21:23:25 UTC
make[3]: Leaving directory `/var/tmp/portage/media-gfx/eog-2.20.4/work/eog-2.20.4/data/icons'                                                                                           
make[3]: Entering directory `/var/tmp/portage/media-gfx/eog-2.20.4/work/eog-2.20.4/data'    
LC_ALL=C ../intltool-merge -d -u -c ../po/.intltool-merge-cache ../po eog.desktop.in eog.desktop                                                                                        
LC_ALL=C ../intltool-merge -s -u -c ../po/.intltool-merge-cache ../po eog.schemas.in eog.schemas                                                                                        
Generating and caching the translation database
Generating and caching the translation database
Merging translations into eog.schemas.
Merging translations into eog.desktop.
make[3]: Leaving directory `/var/tmp/portage/media-gfx/eog-2.20.4/work/eog-2.20.4/data'
make[2]: Leaving directory `/var/tmp/portage/media-gfx/eog-2.20.4/work/eog-2.20.4/data'
make[2]: Entering directory `/var/tmp/portage/media-gfx/eog-2.20.4/work/eog-2.20.4'
make[2]: Nothing to be done for `all-am'.
make[2]: Leaving directory `/var/tmp/portage/media-gfx/eog-2.20.4/work/eog-2.20.4'
make[1]: Leaving directory `/var/tmp/portage/media-gfx/eog-2.20.4/work/eog-2.20.4'
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-17020.log"

unlink:    /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------
Comment 1 Albert Zeyer 2008-07-15 21:23:55 UTC
macbook ~ # emerge --info                         
Portage 2.2_rc1 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r8 i686)
=================================================================                           
System uname: Linux-2.6.24-gentoo-r8-i686-Intel-R-_Core-TM-2_CPU_T7400_@_2.16GHz-with-glibc2.0                                                                                          
Timestamp of tree: Tue, 15 Jul 2008 12:00:01 +0000                                          
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]          
app-shells/bash:     3.2_p33                                                                
dev-java/java-config: 1.3.7, 2.1.6                                                          
dev-lang/python:     2.4.4-r13, 2.5.2-r5                                                    
sys-apps/baselayout: 1.12.11.1                                                              
sys-apps/sandbox:    1.2.18.1-r2                                                            
sys-devel/autoconf:  2.13, 2.61-r2                                                          
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1                      
sys-devel/binutils:  2.18-r3                                                                
sys-devel/gcc-config: 1.4.0-r4                                                              
sys-devel/libtool:   1.5.26                                                                 
virtual/os-headers:  2.6.23-r3                                                              
ACCEPT_KEYWORDS="x86"                                                                       
CBUILD="i686-pc-linux-gnu"                                                                  
CFLAGS="-O2 -march=nocona -pipe -ggdb"                                                      
CHOST="i686-pc-linux-gnu"                                                                   
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/svn/env /usr/kde/svn/share/config /usr/kde/svn/shutdown /usr/share/config"               
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"                               
CXXFLAGS="-O2 -march=nocona -pipe -ggdb"                                                    
DISTDIR="/usr/portage/distfiles"                                                            
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms splitdebug unmerge-orphans userfetch"                                                                                  
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp6.uni-erlangen.de/pub/mirrors/gentoo ftp://vlaai.snt.ipv6.utwente.nl/pub/os/linux/gentoo/ ftp://mirror.nutsmaas.nl/gentoo/"                
LANG="en_US.UTF-8"                                                                          
LC_ALL="en_US.UTF-8"                                                                        
LDFLAGS=""                                                                                  
LINGUAS="de"                                                                                
MAKEOPTS="-j2"                                                                              
PKGDIR="/usr/portage/packages"                                                              
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                      
PORTAGE_TMPDIR="/var/tmp"                                                                   
PORTDIR="/usr/portage"                                                                      
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/kdesvn-portage /usr/portage/local/layman/x11 /usr/portage/local/private"                                   
SYNC="rsync://rsync.gentoo.org/gentoo-portage"                                              
USE="7zip X a52 aac acl acpi alsa altenburgcards amarok amr amuled apm applet async asyncns atm automount avahi bash-completion berkdb bluetooth bonjour bookmarks bzip2 cairo captury cdr cisco cli cmake cracklib crypt cups curl cxx d daap dbus dedicated deskbar dga dhcp divx dri dv dvd dvdr dvdread dvi eap-tls enblend encode evo exif extra-algorithms fam fasttrack ffmpeg flac ftp galago gd gdbm german gif glib glitz gmedia gnome gnutella gnutls gphoto2 gpm gsf gtk h323 hal haskell hddtemp hfs hyperestraier iconv icu id3 id3tag ieee1394 imlib injection inkjar inotify ipv6 irda isdnlog isight jabber java javascript jit joystick jpeg jpeg2k kde kig-scripting kqemu latex lcms libnotify lirc lm_sensors lua lzo macbook mad madwifi maps mdnsresponder-compat midi mmap mmx mng mozdevelop mp2 mp3 mp4 mpeg mplayer mtp mudflap music musicbrainz nautilus ncurses nepomuk net network networking networkmanager njb nls nntp nptl nptlonly nsplugin ntfs ogg opengl openmp oss pam pascal pch pcre pdf perl pidgin plasma plotutils pmu png pnm posix postgres postscript pptp ps pth pulseaudio python qt3support qt4 quicktime rar rc5 rdesktop readline real realmedia reflection reiser4 reiserfs rtc sambasasl screen sdl sdl-image sdl-sound sdlaudio semantic-desktop server session sftp sharedmemsift slp smp sockets socks5 solver sourceview speex spell spl sqlite sse sse2 ssl ssse3 startup-notification subversion svg tetex theora threads threadsafe tiff timidity tk trayicon truetype tunepimp unicode unzip usb v4l2 valgrind vcd video voice vorbis weak-algorithms wifiwin32codecs wma wmp wxwindows x264 x86 xanim xattr xcomposite xext xface xine xml xmlreaderxorg xrandr xscreensaver xulrunner xv xvid zip zlib zsh-completion" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="sony_dscf1 sony_dscf55" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" LIRC_DEVICES="inputlirc macmini" USERLAND="GNU" VIDEO_CARDS="i810 vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-07-16 06:51:28 UTC
you probably need to rebuild gnome-doc-utils and please run python-updater when changing python version if you didn't.

*** This bug has been marked as a duplicate of bug 104088 ***
Comment 3 Albert Zeyer 2008-07-16 11:03:00 UTC
This problem occured *while* I was running python-updater.

Though, I just used FEATURES="-sandbox" as a workaround which worked fine for me.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-07-16 13:47:43 UTC
which version of python updater was it ? 0.5 ? was gnome-doc-utils in the list ?
Comment 5 Albert Zeyer 2008-07-17 01:05:10 UTC
I recently installed Python 2.5 (needed for some things in KDE4) but I haven't changed explicitly the version of python-updater.

The list of updates of python-updater was very long (around 80 updates if I remember correctly).

Sadly, my harddisk crashed today, therefore I cannot check anything anymore.
Comment 6 James A Shepherd 2008-07-18 22:28:49 UTC
in answer to Gilles Dartiguelongue:

I upgraded to python 2.5

I dutifully ran python-updater -o 2.4

then revdep-rebuild

eog failed as mentioned.

emerge gnome-doc-utils

revdep-rebuild succeeded (eog remerged)

so I guess seeing as I only have one recent log of gnome-doc-utils installing that python-updater missed it.
Comment 7 James A Shepherd 2008-07-18 22:30:11 UTC
sorry, forgot to say my python-updater is 0.5