Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388279 - KDE 4.7.3 and dependencies stabilization (including KDEPIM)
Summary: KDE 4.7.3 and dependencies stabilization (including KDEPIM)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 371286 377151 kdepim-keywords 380591 380623 382365 384893 384995 389131 389379 389757 389991
Blocks: 378857 388271
  Show dependency tree
 
Reported: 2011-10-23 21:54 UTC by Andreas K. Hüttel
Modified: 2012-01-03 18:52 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
List of packages to be stabilized, v1 (kde-4.7.2-stablelist-v1.txt,8.12 KB, text/plain)
2011-10-28 19:19 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v2 (kde-4.7.2-stablelist-v2.txt,8.15 KB, text/plain)
2011-10-28 22:47 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v3 (kde-4.7.2-stablelist-v3.txt,8.15 KB, text/plain)
2011-10-29 18:34 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v4 (kde-4.7.2-stablelist-v4.txt,8.18 KB, text/plain)
2011-10-30 18:59 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v1 (kde-4.7.3-stablelist-v1.txt,8.16 KB, text/plain)
2011-11-04 21:54 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v2 (kde-4.7.3-stablelist-v2.txt,8.16 KB, text/plain)
2011-11-12 21:34 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v3 (kde-4.7.3-stablelist-v3.txt,8.19 KB, text/plain)
2011-11-15 00:07 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v4 (kde-4.7.3-stablelist-v4.txt,8.20 KB, text/plain)
2011-11-20 22:39 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v5 (kde-4.7.3-stablelist-v5.txt,8.20 KB, text/plain)
2011-11-22 22:53 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v6 (kde-4.7.3-stablelist-v6.txt,8.20 KB, text/plain)
2011-11-24 22:37 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v7 (kde-4.7.3-stablelist-v7.txt,8.20 KB, text/plain)
2011-11-29 21:51 UTC, Andreas K. Hüttel
Details
KDE 4.7.3 on Gentoo Stable AMD64 emerge --info (kde-4.7.3-emerge-info.txt,4.74 KB, text/plain)
2011-12-02 08:04 UTC, RedEyedMan
Details
List of packages to be stabilized, v8 (kde-4.7.3-stablelist-v8.txt,8.23 KB, text/plain)
2011-12-02 19:26 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v9 (kde-4.7.3-stablelist-v9.txt,8.20 KB, text/plain)
2011-12-04 15:20 UTC, Andreas K. Hüttel
Details
List of packages to be stabilized, v10 (kde-4.7.3-stablelist-v10.txt,8.20 KB, text/plain)
2011-12-25 23:44 UTC, Andreas K. Hüttel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2011-10-23 21:54:58 UTC
Tracker that will be turned into a stable request
Comment 1 Andreas K. Hüttel gentoo-dev 2011-10-28 19:19:16 UTC
Created attachment 291105 [details]
List of packages to be stabilized, v1
Comment 2 Andreas K. Hüttel gentoo-dev 2011-10-28 22:47:39 UTC
Created attachment 291109 [details]
List of packages to be stabilized, v2

EAPI bumps, all should now be EAPI=4
Comment 3 Andreas K. Hüttel gentoo-dev 2011-10-28 23:00:54 UTC
Dear arch teams, 

it's that time of the year again. Please find attached a list 
of packages to be tested and stabilized. 

Target is "amd64 ppc x86", except for the "Applications" section at the 
end of the file. There it is "amd64 x86" only.

In general the upgrade of KDE from 4.6.5 to 4.7.2 should be painless. However,
here are some specific instructions regarding the KDEPIM application 
suite. Similar documentation shall be prepared for the users, most 
likely in a news item, before the actual stabilization takes place 
(so please get in touch with us before committing the stable keywords):

The stable upgrade from KDEPIM 4.4.11.1 to KDEPIM 4.7.2 is a MAJOR upgrade 
with potential for major breakage. Therefore we will *try* to keep 
and support the old, so-far stable KDEPIM 4.4.11.1 as long as possible. 
If you *dont* want to upgrade your KDEPIM yet but keep the old version, 
place the following file into your /etc/portage/package.mask:
http://git.overlays.gentoo.org/gitweb/?p=proj/kde.git;a=blob_plain;f=sets/kdepim-4.6;hb=HEAD
If you decide to upgrade, please have a look at the upgrade guide first:
http://wiki.gentoo.org/wiki/KDEPIM-4.7_upgrade

Arch teams, it would be great if both variants could get tested 
(upgrading with or without upgrading KDEPIM). Also, feel free to 
improve the upgrade guide in the wiki.

Cheers, 
Andreas
Comment 4 Andreas K. Hüttel gentoo-dev 2011-10-29 18:34:20 UTC
Created attachment 291153 [details]
List of packages to be stabilized, v3

Bump kdelibs revision to add an important bug (crash) fix in nepomuk
Comment 5 Michael Hofmann 2011-10-30 18:51:03 UTC
On my amd64 system, the KDE PIM-ebuild kaddressbook-4.7.2 wants an additional package: dev-libs/grantlee. 
grantlee should be added to the list of packages to be stabilized.
Comment 6 Andreas K. Hüttel gentoo-dev 2011-10-30 18:59:32 UTC
Created attachment 291259 [details]
List of packages to be stabilized, v4

Added grantlee, dependency of kaddressbook
Comment 7 Chris Prior 2011-10-31 20:00:13 UTC
Hi 
getting an error with dependency with kdelibs



These are the packages that would be merged, in order:

Calculating dependencies  ... done!

!!! All ebuilds that could satisfy ">=kde-base/kdelibs-4.7.2:4[aqua=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdelibs-4.7.2::gentoo (masked by: ~amd64 keyword)

(dependency required by "kde-base/kdialog-4.7.2" [ebuild])
(dependency required by "kde-base/kdebase-meta-4.7.2" [ebuild])
(dependency required by "kde-base/kde-meta-4.7.2" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Any thoughts?

Chris
Comment 8 Andreas K. Hüttel gentoo-dev 2011-10-31 20:07:21 UTC
(In reply to comment #7)
> Hi 
> getting an error with dependency with kdelibs
> 

If you find problems during testing, PLEASE FILE SEPARATE BUGS and make them block this one (add "kde-stable" in the "Blocks" field of the new bug).
No reports here!!!
Comment 9 Andreas K. Hüttel gentoo-dev 2011-11-02 18:14:29 UTC
Arches, please wait. We're going for 4.7.3, as there are a lot of improvements (especially in kdepim).

I'll update the list some time before the 30days so you can already start testing (after all, this is an "upstream bugfix release" and probably needs not the full period).
Comment 10 Andreas K. Hüttel gentoo-dev 2011-11-04 21:54:59 UTC
Created attachment 291693 [details]
List of packages to be stabilized, v1

Switch to 4.7.3, add herqq
Comment 11 Andreas K. Hüttel gentoo-dev 2011-11-12 21:34:33 UTC
Created attachment 292325 [details]
List of packages to be stabilized, v2

(bump plasma-workspace revision to fix some annoying crashes)
Comment 12 Andreas K. Hüttel gentoo-dev 2011-11-15 00:07:02 UTC
Created attachment 292573 [details]
List of packages to be stabilized, v3

Newer digikam et al.
Comment 13 Andreas K. Hüttel gentoo-dev 2011-11-15 00:11:34 UTC
Arches, you're back in the game. Updated list of ebuilds is attached. KDE 4.7.3 is now in the tree since two weeks, after all, this is an "upstream bugfix release", and testing will take some time anyway.

Target is "amd64 ppc x86", except for the "Applications" section at the 
end of the file. There it is "amd64 x86" only.

Please test if you can reproduce bug 389833. If yes, we'll remove upnp support from the kdelibs revision to be stabilized (equivalent to forcing the upnp use-flag off).

In addition, the information regarding kdepim in comment #3 is still valid. 

And please get back in touch before committing stable keywords, so we can get the news item rolling.
Comment 14 Andreas K. Hüttel gentoo-dev 2011-11-20 22:39:25 UTC
Created attachment 293239 [details]
List of packages to be stabilized, v4

(revision bumps: kdelibs, layout bug 365623; kdeplasma-addons, dependency fix, bug 391019; kdm, make xdmcp chooser work again, bug 389757; plasma-workspace, made an erroreous commit and reverted it again)
Comment 15 Andreas K. Hüttel gentoo-dev 2011-11-22 22:53:55 UTC
Created attachment 293445 [details]
List of packages to be stabilized, v5

(revision bump for plasma-workspace: backport another crash fix)
Comment 16 Andreas K. Hüttel gentoo-dev 2011-11-24 22:37:28 UTC
Created attachment 293671 [details]
List of packages to be stabilized, v6

(add yet another crash fix in plasma-workspace)
Comment 17 Fabio Correa 2011-11-25 23:27:07 UTC
Hello, keep up the good work.

The last 4.7 release, 4.7.4, is due December 6, less than two weeks from now.

http://techbase.kde.org/Schedules/KDE4/4.7_Release_Schedule

I suggest we wait for it, thanks for considering it.
Comment 18 Andreas K. Hüttel gentoo-dev 2011-11-26 20:57:13 UTC
(In reply to comment #17)
> Hello, keep up the good work.
> The last 4.7 release, 4.7.4, is due December 6, less than two weeks from now.
> http://techbase.kde.org/Schedules/KDE4/4.7_Release_Schedule
> I suggest we wait for it, thanks for considering it.

Nope, because that would mean waiting 30days after 474 has been released.
Comment 19 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-11-29 12:09:19 UTC
This is still blocked by bug #389833 with apparently no progress on the bug. There is an upstream report about the same problem with many dupes so I guess it's real and serious.
Comment 20 Nikoli 2011-11-29 12:26:23 UTC
May be just mask upnp USE flag for kdelibs until upstream provide patch?
Comment 21 Andreas K. Hüttel gentoo-dev 2011-11-29 21:34:17 UTC
(In reply to comment #13)
>
> Please test if you can reproduce bug 389833. If yes, we'll remove upnp support
> from the kdelibs revision to be stabilized (equivalent to forcing the upnp
> use-flag off).
> 

Exactly. See comment 13. But if you really need that, I'll remove upnp from a kdelibs revision for your testing convenience too.
Comment 22 Andreas K. Hüttel gentoo-dev 2011-11-29 21:51:28 UTC
Created attachment 294243 [details]
List of packages to be stabilized, v7

(another plasma-workspace crash fix backported)
Comment 23 RedEyedMan 2011-12-02 08:04:36 UTC
Created attachment 294485 [details]
KDE 4.7.3 on Gentoo Stable AMD64 emerge --info
Comment 24 RedEyedMan 2011-12-02 08:06:18 UTC
I can upgrade my KDE up to 4.7.3. It works fine. I attach my emerge --info at once it will be needed.

Portage 2.1.10.11 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.12.2-r0, 3.0.6-gentoo x86_64)
=================================================================
System uname: Linux-3.0.6-gentoo-x86_64-Pentium-R-_Dual-Core_CPU_E6500_@_2.93GHz-with-gentoo-2.0.3
Timestamp of tree: Fri, 02 Dec 2011 06:45:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x-overlay flameeyes-overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/home/dists1"
EMERGE_DEFAULT_OPTS="--jobs=2 --autounmask-write=y"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror-kt.neolabs.kz/gentoo/pub/ http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j3"
PKGDIR="/home/pkg"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/overlay /var/lib/layman/flameeyes-overlay"
SYNC="rsync://mirror-kt.neolabs.kz/gentoo-portage"
USE="X a52 aac accessibility acl acpi alsa amd64 avahi bash-completion berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdnav dvdr emboss encode exif faac fam fbcondecor ffmpeg firefox flac fortran gdbm gdu gif gnutls gpm gtk iconv ipv6 jpeg kde kipi lame lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mpeg2 mpeg4pt2 mudflap multilib ncurses networkmanager nls nptl nptlonly nvidia ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd pulseaudio qt3support qt4 readline samba sdl semantic-desktop session spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb v4l vdpau vorbis x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="virtualbox evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 25 RedEyedMan 2011-12-02 08:22:19 UTC
Can I help anything else ?
Comment 26 RedEyedMan 2011-12-02 08:39:16 UTC
(In reply to comment #24)
> I  upgraded my KDE up to 4.7.3. It works fine. I attach my emerge --info at
> once it will be needed.
> 
> Portage 2.1.10.11 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3,
> glibc-2.12.2-r0, 3.0.6-gentoo x86_64)
> =================================================================
> System uname:
> Linux-3.0.6-gentoo-x86_64-Pentium-R-_Dual-Core_CPU_E6500_@_2.93GHz-with-gentoo-2.0.3
> Timestamp of tree: Fri, 02 Dec 2011 06:45:01 +0000
> ccache version 2.4 [disabled]
> app-shells/bash:          4.1_p9
> dev-java/java-config:     2.1.11-r3
> dev-lang/python:          2.7.2-r3, 3.1.4-r3
> dev-util/ccache:          2.4-r9
> dev-util/cmake:           2.8.4-r1
> dev-util/pkgconfig:       0.26
> sys-apps/baselayout:      2.0.3
> sys-apps/openrc:          0.9.4
> sys-apps/sandbox:         2.5
> sys-devel/autoconf:       2.13, 2.68
> sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
> sys-devel/binutils:       2.21.1-r1
> sys-devel/gcc:            4.5.3-r1
> sys-devel/gcc-config:     1.4.1-r1
> sys-devel/libtool:        2.4-r1
> sys-devel/make:           3.82-r1
> sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
> sys-libs/glibc:           2.12.2
> Repositories: gentoo x-overlay flameeyes-overlay
> ACCEPT_KEYWORDS="amd64"
> ACCEPT_LICENSE="*"
> CBUILD="x86_64-pc-linux-gnu"
> CFLAGS="-O2 -march=native -pipe"
> CHOST="x86_64-pc-linux-gnu"
> CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt
> /usr/share/themes/oxygen-gtk/gtk-2.0 /var/bind"
> CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/
> /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release
> /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/
> /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash
> /etc/terminfo"
> CXXFLAGS="-O2 -march=native -pipe"
> DISTDIR="/home/dists1"
> EMERGE_DEFAULT_OPTS="--jobs=2 --autounmask-write=y"
> FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles
> fixpackages news parallel-fetch protect-owned sandbox sfperms strict
> unknown-features-warn unmerge-logs unmerge-orphans userfetch"
> FFLAGS=""
> GENTOO_MIRRORS="http://mirror-kt.neolabs.kz/gentoo/pub/
> http://distfiles.gentoo.org"
> LANG="ru_RU.UTF-8"
> LDFLAGS="-Wl,-O1 -Wl,--as-needed"
> LINGUAS="ru en"
> MAKEOPTS="-j3"
> PKGDIR="/home/pkg"
> PORTAGE_CONFIGROOT="/"
> PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
> --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles
> --exclude=/local --exclude=/packages"
> PORTAGE_TMPDIR="/var/tmp"
> PORTDIR="/usr/portage"
> PORTDIR_OVERLAY="/home/overlay /var/lib/layman/flameeyes-overlay"
> SYNC="rsync://mirror-kt.neolabs.kz/gentoo-portage"
> USE="X a52 aac accessibility acl acpi alsa amd64 avahi bash-completion berkdb
> bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt
> cups cxx dbus declarative dri dts dvd dvdnav dvdr emboss encode exif faac fam
> fbcondecor ffmpeg firefox flac fortran gdbm gdu gif gnutls gpm gtk iconv ipv6
> jpeg kde kipi lame lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mpeg2
> mpeg4pt2 mudflap multilib ncurses networkmanager nls nptl nptlonly nvidia ogg
> opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd
> pulseaudio qt3support qt4 readline samba sdl semantic-desktop session spell sse
> sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb v4l
> vdpau vorbis x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv
> xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix
> dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter
> mmap_emul mulaw multi null plug rate route share shm softvol"
> APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm
> authn_default authn_file authz_dbm authz_default authz_groupfile authz_host
> authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir
> disk_cache env expires ext_filter file_cache filter headers include info
> log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling
> status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words
> flow plan stage tables krita karbon braindump" CAMERAS="ptp2"
> COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
> ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin
> garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore
> rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx"
> INPUT_DEVICES="virtualbox evdev keyboard mouse" KERNEL="linux"
> LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses
> text" LINGUAS="ru en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU"
> VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2
> ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal
> rawnat logmark ipmark dhcpmac delude chaos account"
> Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND,
> PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Sorry for mistaking in first sentence. I was able to upgrade KDE up to 4.7.3.
Comment 27 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-12-02 17:20:17 UTC
The following keyword changes are necessary to proceed:
#required by media-plugins/kipi-plugins-2.3.0, required by media-gfx/digikam-2.3.0, required by =media-gfx/digikam-2.3.0 (argument)
>=dev-libs/qjson-0.7.1-r1 ~x86

Added to package.keywords (please update the stabilization list) and started testing.
Comment 28 Andreas K. Hüttel gentoo-dev 2011-12-02 19:26:41 UTC
Created attachment 294535 [details]
List of packages to be stabilized, v8

(added qjson)
Comment 29 Markos Chandras (RETIRED) gentoo-dev 2011-12-04 00:52:56 UTC
Maybe we should do kdelibs-4.7.3-r11 instead of -r1?
Comment 30 Andreas K. Hüttel gentoo-dev 2011-12-04 01:01:28 UTC
(In reply to comment #29)
> Maybe we should do kdelibs-4.7.3-r11 instead of -r1?

The only difference between -r11 and -r1 is that -r1 does not have the upnp support (and useflag), which is obviously not working yet. See comment 19 and comment 21 ...

Please stabilize kdelibs-4.7.3-r1
Comment 31 RedEyedMan 2011-12-04 07:59:15 UTC
But... What will happen with kdelibs-4.7.3-r11 ? It will stay as unstable?(In reply to comment #30)
> (In reply to comment #29)
> > Maybe we should do kdelibs-4.7.3-r11 instead of -r1?
> 
> The only difference between -r11 and -r1 is that -r1 does not have the upnp
> support (and useflag), which is obviously not working yet. See comment 19 and
> comment 21 ...
> 
> Please stabilize kdelibs-4.7.3-r1

But... What will happen with kdelibs-4.7.3-r11 ? It will stay as unstable?
Comment 32 Markos Chandras (RETIRED) gentoo-dev 2011-12-04 09:26:01 UTC
(In reply to comment #30)
> (In reply to comment #29)
> > Maybe we should do kdelibs-4.7.3-r11 instead of -r1?
> 
> The only difference between -r11 and -r1 is that -r1 does not have the upnp
> support (and useflag), which is obviously not working yet. See comment 19 and
> comment 21 ...
> 
> Please stabilize kdelibs-4.7.3-r1

So what is the point of keeping the entire KDE-4.7.4 stable and not the latest kdelibs from that series :). We can wait for the latest kdelibs issues to be fixed if you want to.
Comment 33 Agostino Sarubbo gentoo-dev 2011-12-04 10:11:08 UTC
I skipped tests, no failure reported by Pawel on kscd. all fine.

amd64 ok
Comment 34 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-12-04 12:37:35 UTC
(In reply to comment #32)
> (In reply to comment #30)
> > (In reply to comment #29)
> > > Maybe we should do kdelibs-4.7.3-r11 instead of -r1?
> > 
> > The only difference between -r11 and -r1 is that -r1 does not have the upnp
> > support (and useflag), which is obviously not working yet. See comment 19 and
> > comment 21 ...
> > 
> > Please stabilize kdelibs-4.7.3-r1
> 
> So what is the point of keeping the entire KDE-4.7.4 stable and not the latest
> kdelibs from that series :). We can wait for the latest kdelibs issues to be
> fixed if you want to.

Markos,

for now the upnp use flag and dependencies are causing run-time issues with KDE applications. As such, we don't want to offer that option to the stable users.
In any case, we're asking for kde-4.7.3 to be marked stable, not kde-4.7.4.
Comment 35 Markos Chandras (RETIRED) gentoo-dev 2011-12-04 12:56:01 UTC
(In reply to comment #34)
> (In reply to comment #32)
> > (In reply to comment #30)
> > > (In reply to comment #29)
> > > > Maybe we should do kdelibs-4.7.3-r11 instead of -r1?
> > > 
> > > The only difference between -r11 and -r1 is that -r1 does not have the upnp
> > > support (and useflag), which is obviously not working yet. See comment 19 and
> > > comment 21 ...
> > > 
> > > Please stabilize kdelibs-4.7.3-r1
> > 
> > So what is the point of keeping the entire KDE-4.7.4 stable and not the latest
> > kdelibs from that series :). We can wait for the latest kdelibs issues to be
> > fixed if you want to.
> 
> Markos,
> 
> for now the upnp use flag and dependencies are causing run-time issues with KDE
> applications. As such, we don't want to offer that option to the stable users.
> In any case, we're asking for kde-4.7.3 to be marked stable, not kde-4.7.4.

Yeah sorry I meant 4.7.3 of course.

As per comment #3, amd64 is ready to mark it stable lets us know when you have the news iteam ready and we will proceed.
Comment 36 Andreas K. Hüttel gentoo-dev 2011-12-04 15:20:14 UTC
Created attachment 294753 [details]
List of packages to be stabilized, v9

(remove herqq from list, we do not need it anymore if we disable upnp support)
Comment 37 Andreas K. Hüttel gentoo-dev 2011-12-06 23:40:11 UTC
The news item is committed; whoever wants to go ahead can do so.
Comment 38 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-12-07 12:25:46 UTC
x86 stable
Comment 39 Markos Chandras (RETIRED) gentoo-dev 2011-12-07 22:25:58 UTC
amd64 done. Thank you all
Comment 40 Andreas K. Hüttel gentoo-dev 2011-12-25 23:44:14 UTC
Created attachment 296933 [details]
List of packages to be stabilized, v10

(revision bump for kdepimlibs to fix super-annoying imap4 regression)
Comment 41 Andreas K. Hüttel gentoo-dev 2012-01-03 17:31:37 UTC
Resolving as obsolete after talking to xarthisius;  bug 396359 is the stablerequest for KDE 4.7.4.