Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 380591 - kde-base/kmail-4.7.2: filter setting minimized disappears
Summary: kde-base/kmail-4.7.2: filter setting minimized disappears
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 388279
  Show dependency tree
 
Reported: 2011-08-25 04:39 UTC by Geoff Madden
Modified: 2011-11-12 19:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geoff Madden 2011-08-25 04:39:09 UTC
While trying to set a filter for an item,if minimised ,it disappears & trying to reactivate filter settings fails, kmail still operates normally for the rest of application.
If I hover over the screen icon it shows the filter app is resident,but I'm not able to foreground it for further editing.
Comment 1 Geoff Madden 2011-08-25 04:44:45 UTC
Portage 2.1.10.11 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.3-gentoo x86_64)
=================================================================
System uname: Linux-3.0.3-gentoo-x86_64-AMD_Athlon-tm-_64_Processor_3700+-with-gentoo-2.0.3
Timestamp of tree: Wed, 24 Aug 2011 01:45:02 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r2, 3.2-r2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1 dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon64 -pipe"
DISTDIR="/data/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.internode.on.net/pub/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/distributions/Linux/gentoo"
LC_ALL="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 apache2 apache2_modules berkdb bzip2 cairo cdr cli consolekit cracklib crypt cups curl curlwrappers cxx dbus declarative device-mapper doc dri dvdr extras ffmpeg fontconfig fortran gcj gd gdbm gdu gif gnutls gpm gps iconv imlib ipv6 jadetex java6 javascript jpeg jpeg2k kde lame lcms mime mmx mng modplug modules mp3 mp4 mpeg mpi mudflap multilib mysql ncurses nls nptl nptlonly ogg opengl openldap openmp pam pcntl pcre perl php png policykit ppds pppd python qt3support qt4 readline ruby scanner semantic-desktop session sndfile snmp sockets sql sqlite sse sse2 ssl svg sysfs szip taglib tcl tcpd threads tiff tk truetype unicode usb vorbis webkit wifi xft xine xml xorg xpm xsl xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Andreas K. Hüttel gentoo-dev 2011-08-27 21:44:54 UTC
Which kmail version and which kde version are you using?
Comment 3 Geoff Madden 2011-08-28 04:45:31 UTC
(In reply to comment #2)
> Which kmail version and which kde version are you using?

4.7.0 for both questions
Comment 4 Andreas K. Hüttel gentoo-dev 2011-10-14 19:11:50 UTC
How about 4.7.2?
Comment 5 Geoff Madden 2011-10-15 08:39:14 UTC
(In reply to comment #4)
> How about 4.7.2?
Same hassle with 4.7.2 ,if I pass the moose over the panel window it shows that it is in the background,but I'm not able to reactivate it. Also noticed,that it's not just kmail,has this problem,and other screens are reactivated on random basis,usually when I don't want !!!!!!
Geoff
Comment 6 Johannes Huber gentoo-dev 2011-11-08 21:14:51 UTC
Can you test it with 4.7.3?
Comment 7 Geoff Madden 2011-11-10 02:33:20 UTC
(In reply to comment #6)
> Can you test it with 4.7.3?

Same result !!  process is
1. activate newfilter select new, rename new to whatever, select various settings
2. need to access email for correct address,minimize filter screen.
3. then when needed to reactivate filter there is no evidence that there is a minimized
screen. The rotating wheel is activated & when I click on this it shows the No. of jobs
active,of which the filter is one,but still not able to reactivate it for completion.
4. Today noticed an additional problem with Nepomuk indexing storage service failed 
the name org.kde.NepomukStorage not provided by any service file. Whether this has anything todo with the problem,or it's just a new one  HIHI.
geoff
Comment 8 Geoff Madden 2011-11-10 04:53:48 UTC
(In reply to comment #6)
> Can you test it with 4.7.3?

ignore the last reply... I've yet to install 4.7.3
Comment 9 Geoff Madden 2011-11-11 01:01:39 UTC
(In reply to comment #6)
> Can you test it with 4.7.3?

A tentative ,yes ok, seems to be fixed,will add further comments if needed
Comment 10 Andreas K. Hüttel gentoo-dev 2011-11-12 19:43:44 UTC
OK excellent. Please reopen if you still have problems.