Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 371286 - kmail2 fails to download any messages
Summary: kmail2 fails to download any messages
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 388279
  Show dependency tree
 
Reported: 2011-06-12 17:02 UTC by Waldemar Szostak
Modified: 2011-10-29 18:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info kmail (emerge.info.kmail,5.59 KB, application/octet-stream)
2011-06-12 17:03 UTC, Waldemar Szostak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Waldemar Szostak 2011-06-12 17:02:27 UTC
I can't download any messages after moving to kmail2. The folders appear to
have been migrated correctly as I can view all of my folder as well as the
messages contained in them.

Regardless of whether the check for new msgs is launched at startup, manually
or restarted, it always gets stuck at 'Preparing for transmission with XXX'
(the actual English translation may be slightly different, sorry..)

When launched from the console, there is the following output:
$ kmail
kmail2(3662)/kdeui (Wallet): The kwalletd service has been disabled 
kmail2(3662)/kdeui (Wallet): The kwalletd service has been disabled 
kmail2(3662)/kdeui (Wallet): The kwalletd service has been disabled 
kmail2(3662)/kdeui (Wallet): The kwalletd service has been disabled 
kmail2(3662)/kdeui (Wallet): The kwalletd service has been disabled 
kmail2(3662)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
kmail2(3662)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
kmail2(3662): Error while fetching items.  103 "Unknown error. (Cannot list
root collection.)"


It seems to be the same issue as described in
http://forum.kde.org/viewtopic.php?f=20&t=90234 but I haven't been able to find
a registered bug report for this.


Problem registered upstream at https://bugs.kde.org/show_bug.cgi?id=275483

Reproducible: Always
Comment 1 Waldemar Szostak 2011-06-12 17:03:16 UTC
Created attachment 276822 [details]
emerge --info kmail
Comment 2 Franz Trischberger 2011-06-13 06:02:47 UTC
Grayed out password field:
https://bugs.kde.org/show_bug.cgi?id=250773
kwallet disabled?
Comment 3 Waldemar Szostak 2011-06-20 23:07:02 UTC
I'm not sure - I don't really know if I've ever used kwallet (I do have it installed, though :) ). The password field is not really greyed out, merely disabled (but I suppose it's a matter of the colour theme used).

Anyway.. when I launched 'akonadictl start' in the console I got no output after opening KMail's POP3 properties window. Of course, I also don't get any window for entering the password either.
Comment 4 Waldemar Szostak 2011-06-20 23:24:21 UTC
Ok.. Indeed I had kwallet disabled in Control panel (or System settings) -> Password and user account.

Still, it'd be 'nice' if kMail tried its own window for obtaining passwords from the user or at least complain in a more user friendly way about the unability to use kwallet.

I guess this bug can be closed and I'll also comment on KDE's https://bugs.kde.org/show_bug.cgi?id=250773

Thanks for help.