Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 384995 - kde-base/system-config-printer-kde-4.7.1 crashes
Summary: kde-base/system-config-printer-kde-4.7.1 crashes
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 388279
  Show dependency tree
 
Reported: 2011-09-29 21:12 UTC by Andrés Becerra Sandoval
Modified: 2011-11-08 17:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrés Becerra Sandoval 2011-09-29 21:12:16 UTC
system-config-printer-kde-4.7.1 crashes all the time

Steps to reproduce:

- Launch kde4 systemsettings
- Click on printer settings

Results: systemsettings crash, no info

Another way:

kcmshell4 system-config-printer-kde

Results: crash, no info

I have another machine with kubuntu installed using kde-4.7.1 and system-config-printer-kde works fine either from systemsettings or from kcmshell4. Is this gentoo-specific?

Thanks
Comment 1 Rafał Mużyło 2011-09-29 21:47:19 UTC
Any output if you run it in a terminal ?
Comment 2 Andrés Becerra Sandoval 2011-09-30 14:46:12 UTC
(In reply to comment #1)
> Any output if you run it in a terminal ?

I am sorry, no output at all.
Comment 3 SpanKY gentoo-dev 2011-10-02 18:25:54 UTC
please post `emerge --info` with all of your bug reports
Comment 4 Maciej Mrozowski gentoo-dev 2011-10-02 20:05:06 UTC
Doesn't crash here (scp-4.7.1)
It spits some calltrace though:

maciek@lebrodyl ~ $ kcmshell4 system-config-printer-kde
maciek@lebrodyl ~ $ Traceback (most recent call last):
  File "/usr/share/apps/system-config-printer-kde/system-config-printer-kde.py", line 437, in on_tvMainList_cursor_changed
    self.fillServerTab()
  File "/usr/share/apps/system-config-printer-kde/system-config-printer-kde.py", line 1786, in fillServerTab
    self.server_settings = self.cups.adminGetServerSettings()
  File "/usr/share/apps/system-config-printer-kde/authconn.py", line 218, in <lambda>
    return lambda *args, **kwds: self._authloop (fname, fn, *args, **kwds)
  File "/usr/share/apps/system-config-printer-kde/authconn.py", line 226, in _authloop
    if self._perform_authentication () == 0:
  File "/usr/share/apps/system-config-printer-kde/authconn.py", line 405, in _perform_authentication
    self._perform_authentication_with_dialog ()
  File "/usr/share/apps/system-config-printer-kde/authconn.py", line 462, in _perform_authentication_with_dialog
    d = AuthDialog (parent=self._parent)
NameError: global name 'AuthDialog' is not defined

Please post your emerge --info and equery uses kdelibs (or emerge -vp1 kdelibs)
Comment 5 Andrés Becerra Sandoval 2011-10-03 19:51:59 UTC
(In reply to comment #3)
> please post `emerge --info` with all of your bug reports

I am sorry, this is the emerge --info output:

Portage 2.2.0_alpha60 (default/linux/x86/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 3.0.4-gentoo-r1 i686)
=================================================================
System uname: Linux-3.0.4-gentoo-r1-i686-Intel-R-_Pentium-R-_4_CPU_2.60GHz-with-gentoo-2.1
Timestamp of tree: Mon, 03 Oct 2011 16:00:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise local
Installed sets: @dicts, @gtk, @kde4, @qt4
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mtune=pentium4 -pipe -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -mtune=pentium4 -pipe -ggdb"
DISTDIR="/var/lib/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg distlocks ebuild-locks fixlafiles fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo ftp://mirror.iawnet.sandia.gov/pub/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo "
LANG="es_CO.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="es en"
MAKEOPTS="-j3"
PKGDIR="/var/lib/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm handbook iconv ipv6 jpeg kde kerberos kipi lcms ldap libnotify lzma mad mmx mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd python qt3support qt4 readline samba sdl semantic-desktop session spell sse sse2 ssl startup-notification svg sysfs system-sqlite tcpd tiff truetype udev unicode usb vaapi vorbis x264 x86 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 6 Andreas K. Hüttel gentoo-dev 2011-10-25 20:00:00 UTC
Do you still have this problem with kde 4.7.2 ?
Comment 7 Andrés Becerra Sandoval 2011-11-08 14:56:21 UTC
(In reply to comment #6)
> Do you still have this problem with kde 4.7.2 ?

Sorry for the delay!

I have kde 4.7.3 after this weekend  and the problem is gone.
Comment 8 Andreas K. Hüttel gentoo-dev 2011-11-08 17:47:22 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Do you still have this problem with kde 4.7.2 ?
> 
> Sorry for the delay!
> 
> I have kde 4.7.3 after this weekend  and the problem is gone.

Excellent, thanks!