Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 389833 - kde-base/kdelibs-4.7.4-r10[upnp] (media-libs/herqq-1.0.0-r1) makes all kde apps to crash after a while.
Summary: kde-base/kdelibs-4.7.4-r10[upnp] (media-libs/herqq-1.0.0-r1) makes all kde ap...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: tracking upstream
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-07 19:03 UTC by Aleksandar Petrinic
Modified: 2013-03-12 13:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Kcrash report (dolphin-20111106-233254.kcrash,5.89 KB, text/plain)
2011-11-07 19:09 UTC, Aleksandar Petrinic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandar Petrinic 2011-11-07 19:03:50 UTC
If you use kdelibs-4.7.3 (but other versions are probably affected too) with upnp support (that means you are using media-libs/herqq-1.0.0-r1 and have upnp use enabled in kdelibs), within 1h your kde's app is going to crash (you have to receive some upnp events to trigger the bug).

Reproducible: Always

Steps to Reproduce:
1.Wait for some upnp events
Actual Results:  
Some app are going to crash, could be kmix, plasma, dolphin, amarok etc...

Expected Results:  
No crash.
Comment 1 Aleksandar Petrinic 2011-11-07 19:09:40 UTC
Created attachment 291925 [details]
Kcrash report

Take a look to thread n1.
Comment 2 Aleksandar Petrinic 2011-11-07 19:16:18 UTC
ariel ape # cave info
Package Manager Information:
    Package Name              paludis
    Package Version           0.70.1 8652e3603f352a45610b3874bddbc8ca02264fc5
    Build Date                2011-11-05T07:30:29+0100
    Built with CXX            x86_64-pc-linux-gnu-g++ 4.5.3
    Built with CXXFLAGS        -march=native -O2 -pipe -fomit-frame-pointer -mfpmath=sse,387 -ftree-vectorize -ftracer -floop-interchange -floop-strip-mine -floop-block -pedantic
    Built with LDFLAGS        -Wl,-O1 -Wl,--as-needed -Wl,--sort-common

Environment Information:
    Format                    paludis
    Config dir                /etc/paludis
    Root                      /
    System Root               /
    World file                /var/db/pkg/world

Repository layman:
    format                    unavailable
    location                  /var/db/paludis/repositories/layman
    sync                      tar+http://git.exherbo.org/layman_repositories.tar.bz2
    sync_options              

Repository installed:
    format                    vdb
    location                  /var/db/pkg
    builddir                  /var/tmp/paludis
    eapi_when_unknown         0
    names_cache               /var/db/pkg/.cache/names
    root                      /

Repository installed-unpackaged:
    format                    installed_unpackaged
    location                  /var/db/unpackaged
    root                      /

Repository repository:
    format                    repository
    config_filename           /etc/paludis/repositories/%{repository_template_name}.conf
    config_template           /etc/paludis/repository.template
    root                      /

Repository systemd:
    format                    e
    location                  /var/db/paludis/repositories/systemd
    builddir                  /var/tmp/paludis
    cache                     /var/empty
    distdir                   /usr/portage/distfiles
    eapi_when_unknown         0
    eapi_when_unspecified     0
    eclassdirs                /usr/portage/eclass  /var/db/paludis/repositories/systemd/eclass
    layout                    traditional
    manifest_hashes           RMD160 SHA1 SHA256
    master_repository         gentoo
    names_cache               /var/db/paludis/repositories/cache/systemd/names
    newsdir                   /var/db/paludis/repositories/systemd/metadata/news
    profile_eapi_when_unspecified 0
    profile_layout            traditional
    profiles                  /usr/portage/profiles/default/linux/amd64/10.0/desktop/kde
    securitydir               /var/db/paludis/repositories/systemd/metadata/glsa
    setsdir                   /var/db/paludis/repositories/systemd/sets
    sync                      git://git.overlays.gentoo.org/user/systemd.git git+http://git.overlays.gentoo.org/gitroot/user/systemd.git git+ssh://git@git.overlays.gentoo.org/user/systemd.git
    sync_options              
    use_manifest              use
    write_cache               /var/db/paludis/repositories/cache/systemd/write

Repository x-c1pher:
    format                    e
    location                  /var/db/paludis/repositories/layman/c1pher
    builddir                  /var/tmp/paludis
    cache                     /var/empty
    distdir                   /usr/portage/distfiles
    eapi_when_unknown         0
    eapi_when_unspecified     0
    eclassdirs                /usr/portage/eclass  /var/db/paludis/repositories/layman/c1pher/eclass
    layout                    traditional
    manifest_hashes           RMD160 SHA1 SHA256
    master_repository         gentoo
    names_cache               /var/empty
    newsdir                   /var/db/paludis/repositories/layman/c1pher/metadata/news
    profile_eapi_when_unspecified 0
    profile_layout            traditional
    profiles                  /usr/portage/profiles/default/linux/amd64/10.0/desktop/kde
    securitydir               /var/db/paludis/repositories/layman/c1pher/metadata/glsa
    setsdir                   /var/db/paludis/repositories/layman/c1pher/sets
    sync                      git://git.overlays.gentoo.org/dev/c1pher.git git+http://git.overlays.gentoo.org/gitroot/dev/c1pher.git git+ssh://git@git.overlays.gentoo.org/dev/c1pher.git
    sync_options              
    use_manifest              use
    write_cache               /var/empty

Repository my-rep:
    format                    e
    location                  /var/paludis/repositories/my-rep
    builddir                  /var/tmp/paludis
    cache                     /var/empty
    distdir                   /usr/portage/distfiles
    eapi_when_unknown         0
    eapi_when_unspecified     0
    eclassdirs                /usr/portage/eclass  /var/paludis/repositories/my-rep/eclass
    layout                    traditional
    manifest_hashes           RMD160 SHA1 SHA256
    master_repository         gentoo
    names_cache               /var/db/paludis/repositories/cache/my-rep/names
    newsdir                   /var/paludis/repositories/my-rep/metadata/news
    profile_eapi_when_unspecified 0
    profile_layout            traditional
    profiles                  /usr/portage/profiles/default/linux/amd64/10.0/desktop/kde
    securitydir               /var/paludis/repositories/my-rep/metadata/glsa
    setsdir                   /var/paludis/repositories/my-rep/sets
    sync                      
    sync_options              
    use_manifest              use
    write_cache               /var/db/paludis/repositories/cache/my-rep/write

Repository gentoo:
    format                    e
    location                  /usr/portage
    builddir                  /var/tmp/paludis
    cache                     /usr/portage/metadata/cache
    distdir                   /usr/portage/distfiles
    eapi_when_unknown         0
    eapi_when_unspecified     0
    eclassdirs                /usr/portage/eclass
    layout                    traditional
    manifest_hashes           RMD160 SHA1 SHA256
    names_cache               /var/db/paludis/repositories/cache/gentoo/names
    newsdir                   /usr/portage/metadata/news
    profile_eapi_when_unspecified 0
    profile_layout            traditional
    profiles                  /usr/portage/profiles/default/linux/amd64/10.0/desktop/kde
    securitydir               /usr/portage/metadata/glsa
    setsdir                   /usr/portage/sets
    sync                      rsync://rsync.gentoo.org/gentoo-portage
    sync_options              
    use_manifest              use
    write_cache               /var/empty
    Package information
        app-shells/bash       4.1_p9
        dev-java/java-config  2.1.11-r3
        dev-lang/python       2.5.4-r4 2.6.7-r2 2.7.2-r3 3.1.4-r3 3.2.2
        dev-util/ccache       (none)
        dev-util/cmake        2.8.4-r1
        dev-util/pkgconfig    0.26
        sys-apps/baselayout   2.1
        sys-apps/openrc       9999
        sys-apps/sandbox      2.5
        sys-devel/autoconf    2.13 2.68
        sys-devel/automake    1.10.3 1.11.1-r1 1.7.9-r2 1.8.5-r4 1.9.6-r3
        sys-devel/binutils    2.21.1-r1
        sys-devel/gcc         4.3.6-r1 4.5.3-r1
        sys-devel/gcc-config  1.5-r1
        sys-devel/libtool     2.4-r1
        sys-devel/make        3.82-r1
        sys-freebsd/freebsd-lib (none)
        sys-kernel/linux-headers 2.6.39
        sys-libs/glibc        2.13-r4
        sys-libs/uclibc       (none)
Comment 3 Andreas K. Hüttel gentoo-dev 2011-11-29 22:39:01 UTC
Confirmed a LOT upstream
Comment 4 Johannes Huber gentoo-dev 2012-03-23 08:09:31 UTC
Use flag masked until its fixed upstream.
Comment 5 bartoz 2012-05-06 16:25:21 UTC
Hi all..
I tried to build kde-base/kdelibs-4.8.3 with the upnp flag unmasked and I experience no crashes. Maybe the bug was fixed in the latest kdelibs?

However, browsing upnp resources seems to be broken (I cannot see any media from my NAS).
Comment 6 Johannes Huber gentoo-dev 2012-08-06 08:59:32 UTC
(In reply to comment #5)
> Hi all..
> I tried to build kde-base/kdelibs-4.8.3 with the upnp flag unmasked and I
> experience no crashes. Maybe the bug was fixed in the latest kdelibs?
> 
> However, browsing upnp resources seems to be broken (I cannot see any media
> from my NAS).

Upstream comments dont confirm that.
Comment 7 Michael Palimaka (kensington) gentoo-dev 2013-03-12 13:07:47 UTC
Upstream states that "HUPNP backend has been disabled, and set as unmaintained".

Support is already masked in the tree and will be removed from future ebuilds. Unfortunately there's not much else we can do until upstream finds a new maintainer.