Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 389757 - kde-base/kdm-4.7.{2-3} cannot make any remote logins via xdmcp
Summary: kde-base/kdm-4.7.{2-3} cannot make any remote logins via xdmcp
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: tracking upstream, fedora, [kde overlay]
Keywords:
Depends on:
Blocks: 388279
  Show dependency tree
 
Reported: 2011-11-06 20:29 UTC by Michael Mair-Keimberger (iamnr3)
Modified: 2011-11-20 21:49 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mair-Keimberger (iamnr3) 2011-11-06 20:29:06 UTC
At the login screen you can usually make remote logins via xdmcp. That dosn't work anymore since 472 and 473.
When i choose remote login, the window which shows the available hosts appears correctly, but as soon as i move my mouse into that window, that window disappears.

In /var/log/messages i'll found that msg:
Nov  6 21:25:47 asterix kdm: :2[7229]: Received unknown command 4 from greeter


Reproducible: Always

Steps to Reproduce:
1. install kdm
2. try to make a remote login



emerge --info:


Portage 2.1.10.32 (default/linux/amd64/10.0/no-multilib, gcc-4.5.3, glibc-2.12.2-r0, 3.0.4-gentoo x86_64)
=================================================================
System uname: Linux-3.0.4-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 06 Nov 2011 05:45:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x-local sunrise x11 multimedia kde
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1 PUEL ut2003 dlj-1.1 Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs candy distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1,--hash-style=gnu,--as-needed"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/media/public/overlays/local /media/public/overlays/layman/sunrise /media/public/overlays/layman/x11 /media/public/overlays/layman/multimedia /media/public/overlays/layman/kde"
SYNC="rsync://192.168.2.60/gentoo-portage"
USE="X acl alsa amd64 berkdb bzip2 cdr cli consolekit cracklib crypt cups cxx dbus dri dvd exif flac fortran gallium gdbm gif gnutls gpm graphite iconv ipv6 jpeg kde kipi lzma mad mmx mmxext modules mp3 mudflap ncurses nls nptl nptlonly opengl openmp pam pcre phonon plasma png policykit pppd qt4 readline sdl semantic-desktop session spell sse sse2 ssl ssse3 sysfs tcpd threads tiff truetype udev unicode upnp v4l2 vorbis vpx xinerama xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="net niash" USERLAND="GNU" VIDEO_CARDS="radeon r300" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andreas K. Hüttel gentoo-dev 2011-11-12 21:27:46 UTC
I can reproduce this, however there is absolutely nothing interesting in the logs and no core dump.
Comment 2 Norman Back 2011-11-17 21:46:08 UTC
Even though I am still running kde-7.3, reverting to kde-base/kdm-4.6.5-r2 seems to fix this.
Comment 3 Andreas K. Hüttel gentoo-dev 2011-11-18 10:34:46 UTC
Ossi, you might be interested in this one... seems like the new notification code is not complete yet.
Comment 4 Oswald Buddenhagen 2011-11-19 10:23:36 UTC
i don't think this adds anything new to https://bugs.kde.org/show_bug.cgi?id=281862
Comment 5 Andreas K. Hüttel gentoo-dev 2011-11-20 16:31:59 UTC
Please test kde-base/kdm-4.7.3-r1 from the kde overlay, and report back if that fixes the issue. 

(That ebuild effectively reverts upstream commit 720b0bfe5fab7142b9683f329b75cf2951b95c8e.)
Comment 6 Norman Back 2011-11-20 20:48:59 UTC
(In reply to comment #5)
> Please test kde-base/kdm-4.7.3-r1 from the kde overlay, and report back if that
> fixes the issue. 
> 
> (That ebuild effectively reverts upstream commit
> 720b0bfe5fab7142b9683f329b75cf2951b95c8e.)

On 'emerge kde-base/kdm-4.7.3-r1' the issue is resolved. I can perform remote logins.

On reverting with 'emerge kde-base/kdm-4.7.3' the issue returns.


I then did 'emerge kde-base/kdm-4.7.3-r1' again and remote logins were restored. Look quiet conclusive.
Comment 7 Andreas K. Hüttel gentoo-dev 2011-11-20 21:49:33 UTC
+*kdm-4.7.3-r1 (20 Nov 2011)
+
+  20 Nov 2011; Andreas K. Huettel <dilfridge@gentoo.org> -kdm-4.7.3.ebuild,
+  +kdm-4.7.3-r1.ebuild, +files/kdm-4.7.3-revertcrashlogic.patch:
+  Make xdmcp remote login work again by reverting relevant upstream commit, bug
+  389757
+

Let's see what breaks now. :o)