Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 389991 - KDE 4.7.3 system tray widget crashes
Summary: KDE 4.7.3 system tray widget crashes
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: tracking upstream
Keywords:
Depends on:
Blocks: 388279
  Show dependency tree
 
Reported: 2011-11-09 18:11 UTC by Eitan Mosenkis
Modified: 2011-11-29 21:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info,6.12 KB, text/plain)
2011-11-09 18:11 UTC, Eitan Mosenkis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eitan Mosenkis 2011-11-09 18:11:03 UTC
Created attachment 292033 [details]
emerge --info

I'm running ~arch KDE and after upgrading to 4.7.3, the system tray widget won't run. Right after the upgrade, plasma crashed (maybe not surprising since it had been upgraded while running), and when I logged in again, my panel was missing. I recreated everything in the panel, but each time I try to add a system tray, the panel seems to crash and restart with some of the other widgets rearranged and still no system tray. The same thing happens if I try to add a system tray widget to the desktop.
Comment 1 Franz Trischberger 2011-11-10 07:01:56 UTC
Maybe related upstream-bugreport:
https://bugs.kde.org/show_bug.cgi?id=286085
Comment 2 Andreas K. Hüttel gentoo-dev 2011-11-12 17:37:24 UTC
Yeah, 4.7.3 has an amazing amount of plasma crash regressions.

If you want to pursue this further, get plasma-workspace to dump core and attach a backtrace here. See http://www.gentoo.org/proj/en/qa/backtraces.xml for how to proceed. 

Otherwise we unfortunately cannot do much.
Comment 3 Andreas K. Hüttel gentoo-dev 2011-11-15 23:41:50 UTC
Please try if you still have problems with plasma-workspace-4.7.3-r2
Comment 4 Eitan Mosenkis 2011-11-16 00:24:37 UTC
I did and the only difference is that there was a crash dialog (but it said the debug info wasn't useful). I tried downgrading all of kde to 4.7.2 and that was a disaster - all I see is a bunch of huge red x 'close window' icons when I log in.
Comment 5 Andreas K. Hüttel gentoo-dev 2011-11-25 07:40:10 UTC
Cant do much without a backtrace, sorry.
Comment 6 Eitan Mosenkis 2011-11-29 17:44:25 UTC
I recompiled plasma-workspace-4.7.3-r6 and qt-gui with debugging info and posted the stack trace to the upstream bug mentioned above (https://bugs.kde.org/attachment.cgi?id=66197)
Comment 7 Andreas K. Hüttel gentoo-dev 2011-11-29 21:50:02 UTC
Fixed in plasma-workspace-4.7.3-r7