Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 382365 - kde-base/kmail-4.7.1 / akonadi handels maildir incorrect
Summary: kde-base/kmail-4.7.1 / akonadi handels maildir incorrect
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard:
Keywords:
Depends on:
Blocks: 388279
  Show dependency tree
 
Reported: 2011-09-09 09:39 UTC by Johannes Hirte
Modified: 2011-10-29 18:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Hirte 2011-09-09 09:39:57 UTC
I've opened my old kmaildir directory from kmail with kmail2 and tried to copy over some of the mails. Where the old mails where stored maildir-like in the cur/ directory, named like 1299590689.30198.qVwo9 or 1299590694.30198.mLUTH:2,S, kmail2 now stores them permanently in the new/ directory, named like {00d63972-d24c-4870-be74-c18bcad89914}. I've also noticed that sometimes only the headers where copied and the complete body was missing. kmail2 is unusable this way.

I'm using akonadi with the sqlite backend.

Reproducible: Always
Comment 1 Andreas K. Hüttel gentoo-dev 2011-09-09 20:26:55 UTC
Can't do much about this here unfortunately. Please file a bug at bugs.kde.org and add the link in the URL field here. This way we can keep track of the progress.
Comment 2 Johannes Hirte 2011-09-11 16:29:56 UTC
Tested with the mysql akonadi-backend and still the same problem. Bug is opened upstream.
Comment 3 Andreas K. Hüttel gentoo-dev 2011-10-14 19:51:18 UTC
I vaguely remember some upstream patch about this, but it seems that has not even made it into the upstream bug. Needs research.
Comment 4 Andreas K. Hüttel gentoo-dev 2011-10-15 13:39:08 UTC
Fixed in 4.7.2; you should mark your upstream report as duplicate of one of these...


commit dd2619f53039f8d6a3b0dee0f37b6c89e5f2da44
Author: Andras Mantia <amantia@kde.org>
Date:   Fri Sep 16 11:15:51 2011 +0300

    Make the maildir resource more standard compliant:
    - regarding file names (233379)
    - moving out files from new to cur (233378)
    - storing flags
    - reading flags from filenames (252449)
    
    BUG: 233380
    BUG: 233378
    BUG: 252449
Comment 5 Johannes Hirte 2011-10-17 17:13:56 UTC
At least "moving out files from new to cur" is not fixed in 4.7.2 for me. The naming changed but the mails stay in new/ directory.
Comment 6 Johannes Hirte 2011-10-17 21:16:54 UTC
(In reply to comment #5)
> At least "moving out files from new to cur" is not fixed in 4.7.2 for me. The
> naming changed but the mails stay in new/ directory.

Ok, I have to correct this. When copying mails to a local maildir, they are stored in the new-folder, regardless of the message state (unread in this case).

inbox/new/1318885447.R34.acer for example

After marking them unread they where moved to the cur-folder correctly. 

inbox/cur/1318885447.R34.acer

Marking them unread again resulted in correct naming in the correct folder.

inbox/cur/1318885447.R34.acer:2,S

Opening the message wasn't sufficient to move it to the correct place. As far as I understand maildir, this behavior still isn't fully standard-complient.