Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388271 - kde-base/kdelibs-4.8.0 fails to compile (hardened)
Summary: kde-base/kdelibs-4.8.0 fails to compile (hardened)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard: Fixed in 4.8.97
Keywords:
Depends on: 388279
Blocks:
  Show dependency tree
 
Reported: 2011-10-23 21:23 UTC by Agostino Sarubbo
Modified: 2012-08-01 22:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (kdelibs-4.6.5-r2:20111023-203205.log,364.84 KB, text/plain)
2011-10-23 21:23 UTC, Agostino Sarubbo
Details
build.log (kdelibs-4.7.4:20120104-103834.log,631.24 KB, text/plain)
2012-01-04 12:37 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2011-10-23 21:23:50 UTC
Created attachment 290681 [details]
build.log

$summary

Portage 2.1.10.11 (hardened/linux/x86, gcc-4.4.5, glibc-2.12.2-r0, 2.6.39-hardened-r8 i686)
=================================================================
System uname: Linux-2.6.39-hardened-r8-i686-Intel-R-_Core-TM-_i3_CPU_540_@_3.07GHz-with-gentoo-2.0.3
Timestamp of tree: Sat, 22 Oct 2011 14:00:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.1-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.68                                                                                                                                                      
sys-devel/automake:       1.11.1                                                                                                                                                    
sys-devel/binutils:       2.20.1-r1                                                                                                                                                 
sys-devel/gcc:            4.4.5                                                                                                                                                     
sys-devel/gcc-config:     1.4.1-r1                                                                                                                                                  
sys-devel/libtool:        2.4-r1                                                                                                                                                    
sys-devel/make:           3.82-r1                                                                                                                                                   
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)                                                                                                                             
sys-libs/glibc:           2.12.2                                                                                                                                                    
Repositories: gentoo x-portage                                                                                                                                                      
ACCEPT_KEYWORDS="x86"                                                                                                                                                               
ACCEPT_LICENSE="*"                                                                                                                                                                  
CBUILD="i686-pc-linux-gnu"                                                                                                                                                          
CFLAGS="-O2 -march=i686 -ggdb"                                                                                                                                                      
CHOST="i686-pc-linux-gnu"                                                                                                                                                           
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"                                                                                                              
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"                                        
CXXFLAGS="-O2 -march=i686 -ggdb"                                                                                                                                                    
DISTDIR="/media/sources"                                                                                                                                                            
EMERGE_DEFAULT_OPTS="--with-bdeps y"                                                                                                                                                
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles fixpackages news nostrip parallel-fetch protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"                                                                                                      
FFLAGS=""                                                                                                                                                                           
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                                                                                                                        
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"                                                                                                                              
LINGUAS="en en_GB"                                                                                                                                                                  
MAKEOPTS="-j4"                                                                                                                                                                      
PKGDIR="/usr/portage/packages"                                                                                                                                                      
PORTAGE_CONFIGROOT="/"                                                                                                                                                              
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl berkdb bzip2 cairo cli cracklib crypt cups cxx dbus debug dri gdbm gpm hardened iconv icu jpeg kde modules mudflap ncurses nls nptl nptlonly ogg openmp pam pax_kernel pcre pic png pppd qt3support qt4 readline session ssl symlink sysfs tcpd tiff urandom vorbis x86 xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" CAMERAS="ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LINGUAS="en en_GB" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andreas K. Hüttel gentoo-dev 2011-10-23 21:51:34 UTC
This seems to be the relevant bit (though it's hard to say with -j4).

If the problem is reproducible, can you try getting a core dump and backtrace of meinproc4?


[35m[1mScanning dependencies of target file-handbook
[0m[ 32%] [34m[1mGenerating index.cache.bz2
[0m[31m[1mLinking CXX shared module ../lib/kimg_xcf.so
[0m[ 32%] [32mBuilding CXX object kjsembed/kjsembed/CMakeFiles/kjsembed.dir/qaction_binding.o
[0m[ 32%] Built target kimg_xcf
[35m[1mScanning dependencies of target ftp-handbook
[0m[ 32%] [34m[1mGenerating index.cache.bz2
[0m[ 32%] [32mBuilding CXX object kdeui/CMakeFiles/kdeui.dir/actions/kaction.o
[0m/usr/share/sgml/docbook/xsl-stylesheets/html/glossary.xsl:0: error : 


Unknown node type 300942264
/usr/share/sgml/docbook/xsl-stylesheets/html/math.xsl:5: element stylesheet: error : Reference to namespace 'mml' not in scope
kio_help4(27139) KBzip2Filter::compress:   bzCompress returned  4
kio_help4(27139) KBzip2Filter::terminate: bzCompressEnd returned  0
[ 32%] Built target file-handbook
[35m[1mScanning dependencies of target help-handbook
[0m[ 32%] [34m[1mGenerating index.cache.bz2
[0mIn file included from /var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/object_binding.h:29,
                 from /var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/qobject_binding.h:36,
                 from /var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/qaction_binding.h:30,
                 from /var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/qaction_binding.cpp:22:
/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjs/object.h:367: warning: 'virtual KJS::JSObject* KJS::JSObject::construct(KJS::ExecState*, const KJS::List&, const KJS::Identifier&, const KJS::UString&, int)' was hidden
/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/static_binding.h:116: warning:   by 'KJSEmbed::StaticConstructor::construct'
In file included from /var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/qaction_binding.h:30,
                 from /var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/qaction_binding.cpp:22:
/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjs/object.h:254: warning: 'virtual void KJS::JSObject::put(KJS::ExecState*, unsigned int, KJS::JSValue*, int)' was hidden
/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/qobject_binding.h:136: warning:   by 'virtual void KJSEmbed::QObjectBinding::put(KJS::ExecState*, const KJS::Identifier&, KJS::JSValue*, int)'
/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjs/object.h:241: warning: 'virtual bool KJS::JSObject::getOwnPropertySlot(KJS::ExecState*, unsigned int, KJS::PropertySlot&)' was hidden
/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5/kjsembed/kjsembed/qobject_binding.h:147: warning:   by 'virtual bool KJSEmbed::QObjectBinding::getOwnPropertySlot(KJS::ExecState*, const KJS::Identifier&, KJS::PropertySlot&)'
/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5_build/bin/meinproc4.shell: line 4: 27165 Segmentation fault      LD_LIBRARY_PATH=/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5_build/lib/./:/usr/lib:/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5_build/lib/.:/usr/lib/qt4${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} "/var/tmp/portage/kde-base/kdelibs-4.6.5-r2/work/kdelibs-4.6.5_build/bin/meinproc4" "$@"
make[2]: *** [doc/kioslave/ftp/index.cache.bz2] Error 139
make[1]: *** [doc/kioslave/ftp/CMakeFiles/ftp-handbook.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Comment 2 Agostino Sarubbo gentoo-dev 2011-10-24 15:41:08 UTC
As said on irc, no core-dump(s) file(s) after stop merging.
Comment 3 Andreas K. Hüttel gentoo-dev 2011-11-09 03:27:37 UTC
What's your version of app-text/docbook-xsl-stylesheets ?

If it's 1.76.1, could you downgrade to 1.75.2 and try again please?
Comment 4 Agostino Sarubbo gentoo-dev 2011-11-09 09:53:11 UTC
is 1.75.2
Comment 5 Andreas K. Hüttel gentoo-dev 2011-11-12 17:30:21 UTC
(In reply to comment #4)
> is 1.75.2

Ok, alternatively could you please update it to latest stable 1.76... (on x86) and try that?
Comment 6 Agostino Sarubbo gentoo-dev 2011-11-19 01:00:28 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > is 1.75.2
> 
> Ok, alternatively could you please update it to latest stable 1.76... (on x86)
> and try that?

fails as same
Comment 7 Andreas K. Hüttel gentoo-dev 2011-12-17 23:35:01 UTC
I guess we can forget this, you've upgraded by now for sure. 
I will close the bug after I've removed the 4.6.5 ebuilds.
Comment 8 Andreas K. Hüttel gentoo-dev 2011-12-18 19:52:45 UTC
Not in the tree anymore.
Comment 9 Agostino Sarubbo gentoo-dev 2012-01-04 12:36:49 UTC
reproducible also with kdelibs-4.7.4, 

@kde:
is not a regression, please choice if you want block kde-4.7.4 stabilization.
Comment 10 Agostino Sarubbo gentoo-dev 2012-01-04 12:37:23 UTC
Created attachment 297927 [details]
build.log
Comment 11 Andreas K. Hüttel gentoo-dev 2012-01-09 20:12:31 UTC
@hardened: how can we find out what's happening here?
Comment 12 Agostino Sarubbo gentoo-dev 2012-01-09 20:14:05 UTC
(In reply to comment #11)
> @hardened: how can we find out what's happening here?

I would remember that is not only hardened problem. It happens with hardened + debug CFLAG ggdb/g
Comment 13 Andreas K. Hüttel gentoo-dev 2012-01-09 20:16:17 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > @hardened: how can we find out what's happening here?
> 
> I would remember that is not only hardened problem. It happens with hardened +
> debug CFLAG ggdb/g

does it also crash with debug flags in a not-hardened profile?
Comment 14 Andreas K. Hüttel gentoo-dev 2012-01-09 20:19:54 UTC
@ago: does not block stabilization on amd64 because the bug is on x86
Comment 15 Agostino Sarubbo gentoo-dev 2012-01-09 20:29:14 UTC
(In reply to comment #14)
> @ago: does not block stabilization on amd64 because the bug is on x86

I meant generally.



(In reply to comment #13)
> does it also crash with debug flags in a not-hardened profile?

dunno :/
Comment 16 Agostino Sarubbo gentoo-dev 2012-02-09 10:20:37 UTC
4.8.0 fails too
Comment 17 Magnus Granberg gentoo-dev 2012-02-29 23:29:23 UTC
Do newer gcc or change to one of the hardenedno* in gcc-config fix the probelm?
Comment 18 Johannes Huber gentoo-dev 2012-07-14 21:27:13 UTC
Thanks for the test Zorry. Will be closed when 4.9.0 hits the tree.
Comment 19 Johannes Huber gentoo-dev 2012-08-01 22:23:36 UTC
Thanks all. KDE SC 4.9.0 is added to tree.

+*kdelibs-4.9.0 (01 Aug 2012)
+
+  01 Aug 2012; Johannes Huber <johu@gentoo.org>
+  +files/kdelibs-4.8.95-udisks2-includes.patch, +kdelibs-4.9.0.ebuild:
+  Version bump KDE SC 4.9.0