Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378857 - kde-base/kdelibs-4.6.5-r1 failed (compile phase, parallel make?)
Summary: kde-base/kdelibs-4.6.5-r1 failed (compile phase, parallel make?)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on: 388279
Blocks:
  Show dependency tree
 
Reported: 2011-08-12 04:08 UTC by Hazen
Modified: 2011-12-18 19:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build Log (build.log,722.73 KB, text/plain)
2011-08-12 04:11 UTC, Hazen
Details
Build Environment (environment,170.51 KB, text/plain)
2011-08-12 04:12 UTC, Hazen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hazen 2011-08-12 04:08:26 UTC
In file included from /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/deprecated/animationdriver.cpp:146:
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5_build/plasma/../animationdriver.moc: In member function 'virtual void* Plasma::AnimationDriver::qt_metacast(const char*)':
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5_build/plasma/../animationdriver.moc:58: warning: 'AnimationDriver' is deprecated (declared at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/animationdriver.h:41)
[ 82%] Building CXX object plasma/CMakeFiles/plasma.dir/widgets/videowidget.o
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/deprecated/animator.cpp: In member function 'void Plasma::AnimatorPrivate::scrollStateChanged(QAbstractAnimation::State, QAbstractAnimation::State)':
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/deprecated/animator.cpp:131: warning: 'void Plasma::Animator::scrollStateChanged(QGraphicsWidget*, QAbstractAnimation::State, QAbstractAnimation::State)' is deprecated (declared at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/animator.h:251)
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/deprecated/animator.cpp: In member function 'void Plasma::AnimatorPrivate::init(Plasma::Animator*)':
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/deprecated/animator.cpp:727: warning: 'AnimationDriver' is deprecated (declared at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/animationdriver.h:41)
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/deprecated/animator.cpp:738: warning: 'AnimationDriver' is deprecated (declared at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/plasma/animationdriver.h:41)
Linking CXX shared library ../lib/libplasma.so
[ 82%] Built target plasma
make: *** [all] Error 2
 * ERROR: kde-base/kdelibs-4.6.5-r1 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of 'emerge --info =kde-base/kdelibs-4.6.5-r1',
 * the complete build log and the output of 'emerge -pqv =kde-base/kdelibs-4.6.5-r1'.
 * The complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/temp/environment'.
 * S: '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5'


Reproducible: Always

Steps to Reproduce:
1.try to install kde-base-4.6.5
2.revdep rebuild
3.
Actual Results:  
Failes

Expected Results:  
reinstall KDElibs.

Portage 2.1.10.3 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.11.2-r3, 2.6.36-gentoo-r5 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-2.6.36-gentoo-r5-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.0.2
Timestamp of tree: Fri, 12 Aug 2011 02:00:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11
dev-lang/python:          2.6.6-r2, 3.1.3-r1
dev-util/cmake:           2.8.1-r2
dev-util/pkgconfig:       0.25-r2
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.65-r1
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.81-r2
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.11.2-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://gentoo.arcticnetwork.ca/pub/gentoo/ http://gentoo.arcticnetwork.ca/ http://gentoo.gossamerhost.com rsync://gentoo.gossamerhost.com/gentoo-distfiles/ rsync://mirror.the-best-hosting.net/gentoo-distfiles http://mirror.the-best-hosting.net ftp://mirrors.tera-byte.com/pub/gentoo http://gentoo.mirrors.tera-byte.com/ rsync://mirrors.tera-byte.com/gentoo http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://mirror.mcs.anl.gov/pub/gentoo/ rsync://mirror.mcs.anl.gov/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ rsync://gentoo.chem.wisc.edu/gentoo/ http://gentoo.chem.wisc.edu/gentoo/ http://mirrors.cs.wmich.edu/gentoo http://www.cyberuse.com/gentoo/ http://mirror.datapipe.net/gentoo ftp://mirror.datapipe.net/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/ http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ http://www.gtlib.gatech.edu/pub/gentoo rsync://rsync.gtlib.gatech.edu/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo http://gentoo.mirrors.hoobly.com/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ rsync://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://gentoo.netnitco.net http://gentoo.osuosl.org/ rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/ ftp://mirror.iawnet.sandia.gov/pub/gentoo/ ftp://gentoo.llarian.net/pub/gentoo http://gentoo.llarian.net/ ftp://gentoo.mirrors.tds.net/gentoo rsync://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.tds.net/gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.lug.udel.edu/pub/gentoo/ http://mirror.lug.udel.edu/pub/gentoo/ ftp://mirror.its.uidaho.edu/gentoo/ http://mirror.its.uidaho.edu/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/ rsync://gentoo.cs.uni.edu/gentoo-distfiles http://gentoo.cs.uni.edu/ http://mirror.usu.edu/mirrors/gentoo/ ftp://ftp.wallawalla.edu/pub/mirrors/ftp.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb branding bzip2 cli cracklib crypt cups cxx dbus dri extras fbcondecor fortran gdbm gnome gpm gstreamer iconv ipv6 jpeg kde lock madwifi mmx mng modules mudflap multilib ncurses nls nptl nptlonly nsplugin ogg openmp pam pcre perl png pppd python qt3support qt4 readline semantic-desktop session sql sse sse2 sse3 ssl startup-notification svg sysfs tcpd thunar truetype unicode vorbis webkit xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Hazen 2011-08-12 04:11:17 UTC
Created attachment 282977 [details]
Build Log

Here is the build Log
Comment 2 Hazen 2011-08-12 04:12:15 UTC
Created attachment 282979 [details]
Build Environment

Here is the Build Enviornment
Comment 3 Hazen 2011-08-12 04:14:35 UTC
Revdep-rebuild after i removed some packages a while ago. KDE Libs will no longer complie and fails at 82%
Comment 4 Andreas K. Hüttel gentoo-dev 2011-08-12 06:44:28 UTC
Please try again with MAKEOPTS="-j1"
Comment 5 Hazen 2011-08-12 12:08:26 UTC
'class K3SpellDlg::K3SpellDlgPrivate' has no member named 'ui'

/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kde3support/kdeui/k3spelldlg.cpp: In member function 'void K3SpellDlg::replaceAll()':
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kde3support/kdeui/k3spelldlg.cpp:278: error: 'class K3SpellDlg::K3SpellDlgPrivate' has no member named 'ui'
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kde3support/kdeui/k3spelldlg.cpp: In member function 'void K3SpellDlg::suggest()':
/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kde3support/kdeui/k3spelldlg.cpp:285: error: 'class K3SpellDlg::K3SpellDlgPrivate' has no member named 'ui'
make[2]: *** [kde3support/CMakeFiles/kde3support.dir/kdeui/k3spelldlg.o] Error 1
make[1]: *** [kde3support/CMakeFiles/kde3support.dir/all] Error 2
make: *** [all] Error 2
 * ERROR: kde-base/kdelibs-4.6.5-r1 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of 'emerge --info =kde-base/kdelibs-4.6.5-r1',
 * the complete build log and the output of 'emerge -pqv =kde-base/kdelibs-4.6.5-r1'.
 * The complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/temp/environment'.
 * S: '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5'

>>> Failed to emerge kde-base/kdelibs-4.6.5-r1, Log file:

>>>  '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/temp/build.log'

 * Messages for package kde-base/kdelibs-4.6.5-r1:

 * ERROR: kde-base/kdelibs-4.6.5-r1 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of 'emerge --info =kde-base/kdelibs-4.6.5-r1',
 * the complete build log and the output of 'emerge -pqv =kde-base/kdelibs-4.6.5-r1'.
 * The complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/temp/environment'.
 * S: '/var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5'
Comment 6 Andreas K. Hüttel gentoo-dev 2011-08-15 14:31:00 UTC
This looks like a parallel make problem. Could you please retry with MAKEOPTS="-j1"  and tell us if it works then?!
Comment 7 Andreas K. Hüttel gentoo-dev 2011-12-15 22:50:54 UTC
Please upgrade to 4.7 - we'll remove 4.6.5 soon.
Comment 8 Andreas K. Hüttel gentoo-dev 2011-12-18 19:52:17 UTC
Not in the tree anymore.