Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283429 - [tracker] x11-libs/qt-3* deprecation and removal
Summary: [tracker] x11-libs/qt-3* deprecation and removal
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Qt Bug Alias
URL: http://tinderbox.dev.gentoo.org/misc/...
Whiteboard: removed 2010-03-21
Keywords: Tracker
: 299127 (view as bug list)
Depends on: 228241 246932 249884 258304 267193 269724 275167 276461 279332 279713 283430 284046 284896 288635 289448 291878 292192 292791 297186 297629 297652 297657 298293 298358 298363 298364 298491 298798 299010 299083 299087 299110 299123 299125 299126 299127 299142 299144 299146 299190 299222 299403 299455 299572 299574 299588 299746 299749 299937 300034 300043 300087 300162 300216 301361 301363 301365 301367 301369 301370 301372 301374 301376 301377 301379 301381 301382 301384 301386 301387 301608 301731 301733 301735 301736 301738 301740 301741 301742 301744 301746 302080 302249 302257 302259 302260 302261 302262 302264 302265 302267 302269 302270 302272 302275 302276 302278 302754 304457 304459 304461 304463 304465 304467 304469 304471 304473 304475 304477 304479 304481 308001
Blocks:
  Show dependency tree
 
Reported: 2009-09-01 15:22 UTC by Jeroen Roovers
Modified: 2015-01-05 23:25 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2009-09-01 15:22:24 UTC
This bug report tracks the deprecation of x11-libs/qt-3* and everything that depends on it.

Please DO NOT post comments but refer to other bug reports in [Depends on] and [Blocks] and post your information there or file new bug reports and make them block/depend on this one.
Comment 1 Ben de Groot (RETIRED) gentoo-dev 2009-12-30 20:56:42 UTC
Announcement about Qt3 deprecation and removal:
http://archives.gentoo.org/gentoo-dev-announce/msg_f295c1c2d9d70238d289de3a7ed5bf5c.xml
Comment 2 Ben de Groot (RETIRED) gentoo-dev 2009-12-31 17:33:08 UTC
*** Bug 299127 has been marked as a duplicate of this bug. ***
Comment 3 Ben de Groot (RETIRED) gentoo-dev 2010-03-01 18:30:11 UTC
With a little delay, to give a MythTV users a chance to be informed with a news item, we have just p.masked qt:3 and all remaining reverse dependencies, and also the qt3 useflag.
Comment 4 Oschtan 2010-03-03 04:00:28 UTC
I do not see a worthy replacement for Linux program xdrawchem. However, the insistence to remove qt: 3, and not just from portage forced to use their own overlays and rasmyshlyat on other distributions that do not lead a violent epic war against with obsolete packages, which however does not bring profit but is brought lulz
Comment 5 Jacob Martin 2010-03-04 06:28:53 UTC
I'd just like to add my 2 cents here about the pending removal of QT3 from portage on March 21, 2010. Even though this bug might not be exactly the right place for my 2 cents, my observation relates to the philosophy of deleting ebuilds from the tree.

I just switched from KDE 3.5 to KDE 4.4.  It is disappointing to see that all the great apps for KDE 3.5 (e.g. kdict, guarddog), are removed from the tree and do not work with KDE 4.4 without some work.  Even if I use qt3support, I cannot get guarddog with Gentoo (see Bug 270532) without tweaking.  

Why do we do all of this work creating ebuilds and "qt3support" just to eventually delete our progress?  Would it not be more ideal to leave all the old ebuild versions around as unstable (because of lack of upstream updates, etc), and let users use them if they unmask them?  What is the point of this recent campaign to delete all the packages we have spent all of our toil and trouble creating?

The reason I commented about this here is because when QT3 is removed, I'm sure I'll have to do more configuring to keep the apps I like, and I'm not looking forward to that.  This policy is making things difficult for me and others.  

I understand that there are no security updates for these older packages, but people cannot seriously believe that Gentoo is responsible for each package's security.  That's "upstream's" problem after all.

So, in summary, please, just leave the packages there, including qt3, and stop deleting functionality!
Comment 6 Ben de Groot (RETIRED) gentoo-dev 2010-03-04 11:25:05 UTC
(In reply to comment #5)
> Even though this bug might not be exactly the right place for my 2 cents

You are so right, any discussion belongs not on this tracker bug, but on the gentoo-dev mailing list or the forums. So please take it there, we will not go into this here.
Comment 7 Marco Sasse 2010-03-13 11:35:54 UTC
cannot use genkernel --xconfig without qt-3.3.8b-r2
Comment 8 Ben de Groot (RETIRED) gentoo-dev 2010-03-13 12:47:47 UTC
(In reply to comment #7)
> cannot use genkernel --xconfig without qt-3.3.8b-r2
 
That is bug 133751.
Comment 9 Buggy B. 2011-02-17 09:07:22 UTC
Things are not so bad, because:

All releases of xxdiff:
 4.0b1 (21 Nov 2010 11:42)
Version 4.0b1: A complete Qt4 port (which works on the Mac) has been done by Alexandre Feblot.

So, there was no any reasons to remove it from the tree and masking was enough! For sure, somebody works on changing old ebuild to the new one, according "Qt4-based ebuild howto", from sources 4.0b1 builds fine and works..

PS: Right now I can't find ant sources of the old dev-util/xxdiff-3.2-r1.ebuld (x11-libs/qt:3) to start changing it to the new dev-util/xxdiff-4.0-b1 (qt4), FTF! ((;