Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 275167 - sci-visualization/qtiplot-0.9.7.10: requesting version bump
Summary: sci-visualization/qtiplot-0.9.7.10: requesting version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Marcus D. Hanwell (RETIRED)
URL: http://soft.proindependent.com/news.html
Whiteboard: [sci overlay]
Keywords: InOverlay
Depends on:
Blocks: 283429 292884 293095
  Show dependency tree
 
Reported: 2009-06-23 11:14 UTC by Alexander Minges
Modified: 2010-01-01 10:47 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Minges 2009-06-23 11:14:40 UTC
qtiplot-0.9.7.8 has been released. According to the release notes, it uses a slightly modified version of qwt-5.2 (see attached URL). Perhaps this could lead to problems when building against system qwt.

Reproducible: Always
Comment 1 Luyang Han 2009-07-31 12:08:22 UTC
Well. After about one month, hopefully there is something happening to this version dump request.
Comment 2 Marcus D. Hanwell (RETIRED) gentoo-dev 2009-08-01 19:41:19 UTC
I don't currently have time to look at this, and it is made more difficult by using modified versions of shared libraries. If someone else has time, or a suggested ebuild patch then please submit it. The scidavis stuff looks interesting. I am not actively using either package right now, and have limited time. I think until it can build against a released qwt getting it into portage will be problematic.
Comment 3 Luyang Han 2009-08-02 19:14:13 UTC
I agree with that. The qtiplot project using some heavily modified version of qwt. According to the author's suggestion, it might be just better to build separately a qwt and make a static link to the qtiplot program. Also I keep an eye on the scidavis project, I think it would be easier to incorporate it into protage.

Thanks for your reply!
Comment 4 Justin Lecher (RETIRED) gentoo-dev 2009-09-14 13:41:42 UTC
2009/09/14 - QtiPlot 0.9.7.9 released. Changes:
This release brings a lot of improvements on the 2D plotting side:

    * Added a speed mode for large data sets. The filtering of the 2D curves is based on the Douglas Peuker algorithm.
    * Implemented the possibility to skip data points when drawing curves with error bars or lines and symbols.
    * Now it is possible to edit the format for all curves in a project with just a few clicks.
    * The add/remove curves dialog can be used to easily change the order of the curves/items.
    * Added support for ln, Log2, Reciprocal, Probability and Logit scales.
    * Changed the behavior of the layers resizing tool so that only the plotting area is selected (Origin-like behavior).
    * Implemented direct plotting of table columns and matrices via drag and drop.
    * Implemented stack bar/column plots.
    * The automatic layout of plot layers was highly improved.
    * Improved waterfall plots.
    * The export of 2D plots to SVG and EMF was enhanced with the possibility to choose a custom output size.
    * Fixed bug in printing 2D plots with crop marks.
    * Fixed bug #015932: "Right Axis Title in 2D Plots is not handled correctly".

This release also brings seamless integration with LaTeX:

    * Thanks to the the TikZ/Pgf graphic systems, all plots can now be exported as .tex files via the QTeXEngine library. This brings full LaTeX support for text labels including LaTeX-math mode and makes straightforward the integration of complex mathematical expressions within 2D plots.
    * The possibility to use a locally installed LaTeX compiler for rendering mathematical expressions as raster images, which in turn can be embedded in 2D plots, was also implemented.
    * Last but not least, tables and matrices can also be exported to TeX.

Working with worksheets is much easier now:

    * Several menu items and toolbar buttons for column/row operations in tables were added.
    * It is possible to export tables and matrices to HTML.
    * Two new table to matrix conversion methods: "Regular XYZ" and "2D binning" were implemented.
    * It is now possible to sort tables with respect to a text column.
    * A bug affecting the recalculation of depended column values was fixed.

This release brings several improvements to the scripting interface:

    * Added support for easy access to R from QtiPlot, via the Python scripting engine and rpy2, thanks to Jonas Bähr.
    * Several gliches were fixed in the Python syntax highlighter.
    * Added a console option (-c) allowing to launch the scripting window as a standalone application, with the possibility to switch back to the complete workspace interface.
    * Fixed possible crashes when calling GSL special functions via muParser.

On a general side:

    * Now it is possible to export all QtiPlot subwindows to the open document format (ODF).
    * A print preview dialog was added.
    * It is possible to import PCM WAV files.
    * A new page was added to the Preferences dialog allowing to configure internet connections via a proxy.
    * Curve fitting for user defined functions with poles was also improved.
    * QtiPlot is now also available in Czech thanks to Pavel Fric.

Comment 5 Luyang Han 2009-09-17 07:28:02 UTC
In this newer version, the following bug is also solved:
http://bugs.gentoo.org/show_bug.cgi?id=274633
Comment 6 urcindalo 2009-09-18 06:32:13 UTC
I plead developers to version bump qtiplot to the latest version. I need it as the core of a teaching project, consisting of a Gentoo virtual machine, I've been using for the last two years. The new academic sourse is about to start and currently it is impossible to emerge the version int the tree.

Thanks very much in advance.
Comment 7 Sébastien Fabbro (RETIRED) gentoo-dev 2009-09-18 18:50:32 UTC
Folks, anyone interested in proxy maintaining this package? cryos, are you still maintaining this one? Really this is a popular package on which I have no interest in keeping fixing bugs. A warning though: the build system is not distro-friendly, with 3rd party bundled forked libraries and patches usually not recyclabe between versions.


(In reply to comment #6)
> I plead developers to version bump qtiplot to the latest version. I need it as
> the core of a teaching project, consisting of a Gentoo virtual machine,

We distribute many other less buggy applications for a teaching project. 
Comment 8 Luyang Han 2009-09-20 21:16:00 UTC
(In reply to comment #6)
> The new academic sourse is about to start
> and currently it is impossible to emerge the version int the tree.
> Thanks very much in advance.

You can, however, compile the package manually. This should always work if one follows the instruction. It is only tricky to integrate it with the portage system.
Comment 9 Luyang Han 2009-10-12 11:08:41 UTC
I would like to mention that the 0.9.7.10 version is out:

http://soft.proindependent.com/news.html
Comment 10 Justin Lecher (RETIRED) gentoo-dev 2009-11-03 14:17:08 UTC
Any progress on this front?
Comment 11 Alexey Shvetsov gentoo-dev 2009-11-15 18:27:15 UTC
(In reply to comment #7)
> Folks, anyone interested in proxy maintaining this package? cryos, are you
> still maintaining this one? Really this is a popular package on which I have no
> interest in keeping fixing bugs. A warning though: the build system is not
> distro-friendly, with 3rd party bundled forked libraries and patches usually
> not recyclabe between versions.
> 
> 
> (In reply to comment #6)
> > I plead developers to version bump qtiplot to the latest version. I need it as
> > the core of a teaching project, consisting of a Gentoo virtual machine,
> 
> We distribute many other less buggy applications for a teaching project. 
> 

I'm intrested in qtiplot. =)
Comment 12 Vladimir 2009-11-19 00:02:40 UTC
(In reply to comment #11)
> 
> I'm intrested in qtiplot. =)
> 

  I'm interested in qtiplot very very much, but unfortunately, I cannot write .ebuild-files. Learning how to do that is in my ToDo list and I hope that I will be able to do that sometime. Perhaps, then I will write the ebuild for QtiPlot, if it is still timely. :)
  Maybe, someone can tell me where to start with this question?.. You know... just to make the process of writing sci-visualization/qtiplot-0.9.7.10.ebuild file a bit faster... ;)
Comment 13 Justin Lecher (RETIRED) gentoo-dev 2009-11-19 07:38:38 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > 
> > I'm intrested in qtiplot. =)
> > 
> 
>   I'm interested in qtiplot very very much, but unfortunately, I cannot write
> .ebuild-files. Learning how to do that is in my ToDo list and I hope that I
> will be able to do that sometime. Perhaps, then I will write the ebuild for
> QtiPlot, if it is still timely. :)
>   Maybe, someone can tell me where to start with this question?.. You know...
> just to make the process of writing sci-visualization/qtiplot-0.9.7.10.ebuild
> file a bit faster... ;)
> 

The most easy way would be you join #gentoo-science on freenode and ping me or alexxy. There will be alot others who help you. Good place to get help is always #gentoo-dev-help.
If you do not want to irc, you can use the dev-help ml or discuss your attempts here or email me and/or Alexey directly (Alexey, hope that's okay with you).

Two things you can/have to do when starting, download the old and the new tarball and compare the differences. This will give you a clue, what to change and where problems can come up. Second just put the old versio0n from the tree into your personal overlay and bump it to the new version and see what happens.

For reading is http://devmanual.gentoo.org.
Comment 14 Justin Lecher (RETIRED) gentoo-dev 2009-11-21 22:01:26 UTC
Bumped in the sci overlay:
What's not working:
   _emf support_
   src/plot2D/Graph.cpp:1359: error: cannot convert ‘const wchar_t*’ to ‘const CHAR*’ for argument ‘1’ to ‘HENHMETAFILE GetEnhMetaFileA(const CHAR*)’

   _qwt_
  it needs >=qwt-5.3, so we use the bundled until upstream released the new version
Comment 15 juantxorena@gmail.com 2009-11-22 15:52:58 UTC
This needs on dev-python/sip-4.9.1 or it fails.
Comment 16 Justin Lecher (RETIRED) gentoo-dev 2009-11-22 15:55:43 UTC
(In reply to comment #15)
> This needs on dev-python/sip-4.9.1 or it fails.
> 

The patch from upstream was broken. I fixed it. Please sync and try again. Report if it is still broken.
Comment 17 Samuli Suominen (RETIRED) gentoo-dev 2009-12-11 20:09:13 UTC
I know this doesn't help anything, but I'd like to see the latest version moved to Portage tree soon as possible, as labplot is being removed so we have the best possible alternatives available. ;-)
Comment 18 Justin Lecher (RETIRED) gentoo-dev 2009-12-11 21:48:42 UTC
(In reply to comment #17)
> I know this doesn't help anything, but I'd like to see the latest version moved
> to Portage tree soon as possible, as labplot is being removed so we have the
> best possible alternatives available. ;-)
> 

I will do it as soon as I can!
Comment 19 Samuli Suominen (RETIRED) gentoo-dev 2010-01-01 10:23:27 UTC
I've committed x11-libs/gl2ps and dev-tex/qtexengine from sci-overlay to Portage, please remove them from overlay. 

I'm testing qtiplot now...
Comment 20 Samuli Suominen (RETIRED) gentoo-dev 2010-01-01 10:47:13 UTC
Moved to Portage, since it can't get any worse than it is re: bugs 292884 and 293095.