Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 282290 - [TRACKER] x11-base/xorg-server-1.6.3 stabilization
Summary: [TRACKER] x11-base/xorg-server-1.6.3 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: Tracker
: 268581 272954 279176 285210 285634 285636 (view as bug list)
Depends on: 278268 278487 281634 286090 286179 286185 286262 287259 287286 290791 292928
Blocks: 190242 267388 275825 281698 283535 287208 287214 291726
  Show dependency tree
 
Reported: 2009-08-22 10:06 UTC by Rémi Cardona
Modified: 2010-07-05 05:16 UTC (History)
34 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Xorg Xserver 1.6 Stabilization List v1 (x11.stable.list,3.40 KB, text/plain)
2009-09-23 10:39 UTC, Rémi Cardona
Details
Xorg Xserver 1.6 Stabilization List v2 (x11.stable.list,3.43 KB, text/plain)
2009-09-23 20:11 UTC, Rémi Cardona
Details
Xorg Xserver 1.6 Stabilization List v3 (x11.stable.list,3.40 KB, text/plain)
2009-09-24 06:13 UTC, Rémi Cardona
Details
Xorg Xserver 1.6 Stabilization List v4 (x11.stable.list,3.43 KB, text/plain)
2009-09-24 09:37 UTC, Rémi Cardona
Details
Xorg Xserver 1.6 Stabilization List v5 (x11.stable.list,3.69 KB, text/plain)
2009-09-25 20:53 UTC, Rémi Cardona
Details
Xorg Xserver 1.6 Stabilization List v6 (x11.stable.list,3.75 KB, text/plain)
2009-09-28 10:49 UTC, Rémi Cardona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2009-08-22 10:06:29 UTC
Tracker bug for xorg-server 1.6 stabilization.

*NOTE TO BUGZILLA USERS* :

If you're interested in following the stabilization effort, please CC yourself but do _not_ comment here unless we ask for feedback. "Me too"s are useless.

If you have any issues, please file *ANOTHER* bug report and we'll link it here if needs be.

Thank you for your attention
Comment 1 Rémi Cardona gentoo-dev 2009-08-25 15:03:03 UTC
*** Bug 268581 has been marked as a duplicate of this bug. ***
Comment 2 Rémi Cardona gentoo-dev 2009-09-16 17:07:50 UTC
*** Bug 285210 has been marked as a duplicate of this bug. ***
Comment 3 Rémi Cardona gentoo-dev 2009-09-19 22:41:51 UTC
Droping blocker, 1.6 already deps on openssl.
Comment 4 Rémi Cardona gentoo-dev 2009-09-23 10:39:42 UTC
Created attachment 205001 [details]
Xorg Xserver 1.6 Stabilization List v1

And here's a first list.

To all that are CCed, if you have any issues with this list, *PLEASE OPEN A NEW BUG FIRST* and I'll update the list here.

*DO NOT COMMENT HERE, THIS IS A TRACKER*

Thanks
Comment 5 Rémi Cardona gentoo-dev 2009-09-23 20:11:52 UTC
Created attachment 205058 [details]
Xorg Xserver 1.6 Stabilization List v2

New list with app-admin/eselect until we figure out how to do with it.

Thanks
Comment 6 Rémi Cardona gentoo-dev 2009-09-24 06:13:10 UTC
Created attachment 205082 [details]
Xorg Xserver 1.6 Stabilization List v3

New list without eselect-1.2. Back to v1, in other words.

If portage still wants eselect 1.2, sync again.

Thanks
Comment 7 Rémi Cardona gentoo-dev 2009-09-24 07:59:38 UTC
*** Bug 285636 has been marked as a duplicate of this bug. ***
Comment 8 Rémi Cardona gentoo-dev 2009-09-24 07:59:59 UTC
*** Bug 285634 has been marked as a duplicate of this bug. ***
Comment 9 Samuli Suominen gentoo-dev 2009-09-24 08:23:58 UTC
*** Bug 279176 has been marked as a duplicate of this bug. ***
Comment 10 Rémi Cardona gentoo-dev 2009-09-24 09:37:32 UTC
Created attachment 205089 [details]
Xorg Xserver 1.6 Stabilization List v4

Added x11-apps/smproxy to the stabilization list
Comment 11 Rémi Cardona gentoo-dev 2009-09-25 20:53:37 UTC
Created attachment 205242 [details]
Xorg Xserver 1.6 Stabilization List v5

Updated list with more apps from bug #286179
Comment 12 Rémi Cardona gentoo-dev 2009-09-28 10:49:25 UTC
Created attachment 205455 [details]
Xorg Xserver 1.6 Stabilization List v6

Added x11-apps/xcmsdb, x11-apps/xkbevd and x11-apps/xpr

Fixes bug #286488

Thanks
Comment 13 Rémi Cardona gentoo-dev 2009-09-30 14:07:23 UTC
@Arch Teams,

This is it, the xorg 1.6 list. :)

Some arches don't have all those packages keyworded, but please, if you do have a keyword, please stabilize the package so we can clean old ebuilds from portage.

Just FYI, there will be a second stabilization pass within a month or so for packages that have been added since we started working on this list. So please stabilize the version noted in the list.

amd64/x86, this is 10.0 material :)

Thanks
Comment 14 Samuli Suominen gentoo-dev 2009-09-30 21:11:54 UTC
amd64 stable
Comment 15 Samuli Suominen gentoo-dev 2009-10-01 13:25:32 UTC
(In reply to comment #14)
> amd64 stable
> 

update: freeglut-2.6.0_rc1 reverted back to ~amd64 wrt bug #287229
Comment 16 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-10-02 19:47:56 UTC
Adding missing STABLEREQ keyword.
Comment 17 Rémi Cardona gentoo-dev 2009-10-04 20:56:15 UTC
news item submitted :)
Comment 18 Christian Faulhammer (RETIRED) gentoo-dev 2009-10-05 16:11:16 UTC
x86 stable, I stay here in case I forgot something
Comment 19 Markus Meier gentoo-dev 2009-10-09 22:13:59 UTC
arm stable
Comment 20 Yang Zhao 2009-10-12 18:17:31 UTC
*** Bug 272954 has been marked as a duplicate of this bug. ***
Comment 21 Jeroen Roovers gentoo-dev 2009-10-26 22:21:21 UTC
All stable for HPPA except =media-libs/freeglut-2.6.0_rc1
Comment 22 Raúl Porcel (RETIRED) gentoo-dev 2009-12-15 16:44:10 UTC
alpha/ia64/sh/sparc stable, need to go through s390 to see if there is something missing :)
Comment 23 Tomáš Chvátal (RETIRED) gentoo-dev 2009-12-16 20:04:11 UTC
Unccing archies, since we have new bug for xorg (bug #294958)
Comment 24 Tomáš Chvátal (RETIRED) gentoo-dev 2009-12-16 20:06:08 UTC
closing as fixed. all blocks moved to new bug.