Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 241922 (kde4tests) - [TRACKER] kde4 test failures
Summary: [TRACKER] kde4 test failures
Status: RESOLVED FIXED
Alias: kde4tests
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: Tracker
Depends on: 239737 239753 241868 242124 245000 246140 246225 257723 257724 257847 258857 264917 264928 271878 276173 276208 276444 277666 277780 277781 279287 279288 280996 281712 284005 295736 295828 295869 295982 304653 304813 305077 307311 307323 307427 309847 328269 330051 335124 366471 366477 366505 376909 378101 378151 382561 385025 386491 387791 391341 392703 392989 392991 392993 393091 393093 393097 393099 393127 393129 393131 393133 393135 393147 394193 394273 397705 399431 410253 412235 420203 420205 420251 420253 420255 453498 459284
Blocks:
  Show dependency tree
 
Reported: 2008-10-14 10:56 UTC by Tomáš Chvátal (RETIRED)
Modified: 2016-03-29 10:15 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chvátal (RETIRED) gentoo-dev 2008-10-14 10:56:00 UTC
This bug is kde4 test failitures tracker, do not write stuff which fails here but create separate bug and add it into depends.
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2008-12-05 06:49:41 UTC
these failures are caused by kde4-base.eclass setting -DKDE4_BUILD_TESTS=OFF in kde4-base_src_configure().  The tests are built during src_compile:

[ 92%] Built target kdeinit_konsole
Scanning dependencies of target konsole
[ 93%] Generating PartTest.moc
Building CXX object apps/konsole/src/CMakeFiles/konsole.dir/konsole_dummy.o
Generating ProfileTest.moc
Linking CXX executable konsole
[ 93%] [ 93%] Built target konsolepart
Built target konsole
Generating SessionManagerTest.moc
Scanning dependencies of target PartTest
Scanning dependencies of target ProfileTest
[ 94%] Building CXX object apps/konsole/src/tests/CMakeFiles/ProfileTest.dir/ProfileTest.o
[ 95%] Building CXX object apps/konsole/src/tests/CMakeFiles/PartTest.dir/PartTest.o
[ 96%] Building CXX object apps/konsole/src/tests/CMakeFiles/PartTest.dir/PartTest_automoc.o
Scanning dependencies of target SessionManagerTest
[ 97%] Building CXX object apps/konsole/src/tests/CMakeFiles/SessionManagerTest.dir/SessionManagerTest.o
[ 98%] Building CXX object apps/konsole/src/tests/CMakeFiles/SessionManagerTest.dir/SessionManagerTest_automoc.o
[100%] Building CXX object apps/konsole/src/tests/CMakeFiles/ProfileTest.dir/ProfileTest_automoc.o
Linking CXX executable PartTest
Linking CXX executable ProfileTest
Linking CXX executable SessionManagerTest
[100%] Built target PartTest
[100%] Built target ProfileTest
[100%] Built target SessionManagerTest
>>> Source compiled.
>>> Creating Manifest for /usr/portage/kde-base/konsole
  digest.assumed                 1
   konsole-3.5.9::kdebase-3.5.9.tar.bz2
make -j4
[  1%] Built target fontembedder
[  2%] Built target konsole-handbook
[  4%] Built target kded_kwrited
[ 44%] Built target konsolepart
[ 92%] Built target kdeinit_konsole
[ 93%] Built target konsole
[ 95%] Built target PartTest
[ 97%] Built target ProfileTest
[100%] Built target SessionManagerTest
 * >>> Test phase [test]: kde-base/konsole-4.1.3
make -j4 -j1 test
Running tests...
Start processing tests
Test project /var/tmp/portage/kde-base/konsole-4.1.3/work/konsole_build
  1/  2 Testing ProfileTest                      Passed
  2/  2 Testing SessionManagerTest               Passed

100% tests passed, 0 tests failed out of 2
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2009-01-15 12:23:51 UTC
Yeah, this seems to be such a trivial hack to fix: 

kde4-base.class

 if [[ $BUILD_TYPE = live ]]; then
     # Disable tests for live ebuilds
     RESTRICT="${RESTRICT} test"
     # Live ebuilds in kde-base default to kdeprefix by default
     IUSE="${IUSE} +kdeprefix"
 else
     # All other ebuild types default to -kdeprefix as before
     IUSE="${IUSE} kdeprefix"
 fi
 
+IUSE="${IUSE} test"
 
 # @ECLASS-VARIABLE: OPENGL_REQUIRED
 # @DESCRIPTION:
...
src_configure () { 
...
+    if has test ${IUSE//+} && use test; then
+        mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON"
+    else
+    # Build tests in src_test only, where we override this value
    mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
+    fi


--> tests start passing like magic. 

Noted adding the 'test' iuse to everything to make this work is possibly a bit overkill and there is probably a cleaner way to do it. 
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2009-02-14 02:24:24 UTC
these are the failures for 4.2.0.  i don't really see the point of filing a new bug for each, since the root cause is the same.  these are just the packages i installed (@kdebase and a few odds and ends) so there are more than likely more.

|-- kde-base                                                                                                            
|   |-- akonadi-4.2.0                                                                                                   
|   |-- kdemaildir-4.2.0                                                                                                
|   |-- kdemultimedia-kioslaves-4.2.0                                                                                   
|   |-- konsole-4.2.0                                                                                                   
|   |-- kontactinterfaces-4.2.0                                                                                         
|   |-- korganizer-4.2.0-r1                                                                                             
|   |-- kscd-4.2.0                                                                                                      
|   |-- ksysguard-4.2.0                                                                                                 
|   |-- ksystemlog-4.2.0                                                                                                
|   |-- libkcddb-4.2.0                                                                                                  
|   |-- libkdegames-4.2.0                                                                                               
|   |-- libkdepim-4.2.0                                                                                                 
|   |-- libkholidays-4.2.0                                                                                              
|   `-- solid-4.2.0 
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2009-03-13 02:58:10 UTC
most of these pass now, but there's a few that still don't.  i'll file bugs for them.
Comment 5 Claes 2010-03-03 15:49:23 UTC
ebuild /usr/portage/app-office/kmymoney/kmymoney-3.96.1.ebuild compile
cd /var/tmp/portage/app-office/kmymoney-3.96.1/work/kmymoney-3.96.1
cmake . -DKDE4_BUILD_TESTS=ON
make
ctest .

solves the problem.
Comment 6 Claes 2010-03-03 15:49:55 UTC
Sorry about that, posted on wrong bug.
Comment 7 Johannes Huber gentoo-dev 2016-03-29 10:15:22 UTC
Tracker closed. All blocking issues done. kdelibs4 is deprecated and maintenance of :4 packages have reduced activity since months.