Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264917 - kde-base/okteta-4.3.1 (and earlier) test 9 failing
Summary: kde-base/okteta-4.3.1 (and earlier) test 9 failing
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 264919 277666 413643 (view as bug list)
Depends on:
Blocks: kde4tests
  Show dependency tree
 
Reported: 2009-04-04 23:07 UTC by infobox.oleg
Modified: 2012-04-30 12:26 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
okteta-test.patch (okteta-test.patch,1.11 KB, patch)
2012-04-26 17:05 UTC, Chris Reffett (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description infobox.oleg 2009-04-04 23:07:41 UTC
When installing okteta-4.2.2 for KDE 4.2.2 test suite failed on one test:
9 - libpiecetable-grouppiecetablechangeabstractpiecetablechangeiftest

Reproducible: Always

Steps to Reproduce:
1. Emerge okteta-4.2.2 with tests enabled
2. See test fail





Portage 2.2_rc28 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.28-tuxonice-r8 i686)
=================================================================
System uname: Linux-2.6.28-tuxonice-r8-i686-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-glibc2.0
Timestamp of tree: Sat, 04 Apr 2009 11:00:16 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.3.5
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -pipe -O2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -pipe -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages metadata-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict test unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en cs ru uk"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/synce /usr/portage/local/layman/kde-testing /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi adns alsa apache2 arts audiofile automount bash-completion berkdb bluetooth branding bzip2 cairo calendars caps cdparanoia cdr chm cli cracklib crypt cups curl curlwrappers custom-optimization cvs dbus dhcp dri dts dvd dvdr dvdread eds emboss encode escreen esd evo fam fbcon ffmpeg firefox flac fortran gcj gdbm gif glut gpm gstreamer gtk gtk2 hal iconv icq ieee1394 imap imlib inotify ipv6 isdnlog jabber java javascript jikes jingle jpeg junit kde kdeprefix kipi laptop lash ldap libnotify libwww lm_sensors log4j logitech-mouse logrotate mad madwifi matroska mcal midi mikmod mime mozilla mp3 mpeg mpi mplayer mudflap mysql ncurses nls nntp nocd nodrm nptl nptlonly nsplugin ntfs obex ogg openal opengl openmp osc oscar oss pam pcmcia pcre pdf perl php png postgres ppds pppd prelude python qt3 qt3support qt4 quicktime rdesktop readline reflection reiserfs samba scanner sdl session shorten soap sockets spell spl sqlite sqlite3 ssl startup-notification subversion svg synaptics sysfs tcpd test theora threads tidy tiff truetype unicode usb vhosts videos vorbis wifi win32codecs x86 xcomposite xine xml xorg xosd xprint xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs ru uk" USERLAND="GNU" VIDEO_CARDS="vesa v4l intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


End of build.log:

The following tests FAILED:
          9 - libpiecetable-grouppiecetablechangeabstractpiecetablechangeiftest (Failed)
Errors while running CTest
make: *** [test] Error 8
 * 
 * ERROR: kde-base/okteta-4.2.2 failed.
 * Call stack:
 *               ebuild.sh, line   48:  Called src_test
 *             environment, line 3732:  Called kde4-meta_src_test
 *             environment, line 2972:  Called kde4-base_src_test
 *             environment, line 2682:  Called cmake-utils_src_test
 *             environment, line 1009:  Called die
 * The specific snippet of code:
 *                   die "Make test failed. See above for details.";
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-04 23:11:18 UTC
*** Bug 264919 has been marked as a duplicate of this bug. ***
Comment 2 Andreas K. Hüttel gentoo-dev 2010-02-21 21:47:24 UTC
*** Bug 277666 has been marked as a duplicate of this bug. ***
Comment 3 Andreas K. Hüttel gentoo-dev 2010-03-12 16:25:56 UTC
Is this still the case for 4.3.5?
Comment 4 Andreas K. Hüttel gentoo-dev 2010-04-20 21:09:08 UTC
Test is restricted now...
Comment 5 Chris Reffett (RETIRED) gentoo-dev Security 2012-04-26 17:02:34 UTC
*** Bug 413643 has been marked as a duplicate of this bug. ***
Comment 6 Johannes Huber gentoo-dev 2012-04-26 17:03:21 UTC
Re-opened.
Comment 7 Chris Reffett (RETIRED) gentoo-dev Security 2012-04-26 17:05:01 UTC
Created attachment 310205 [details, diff]
okteta-test.patch

It's test 13 now. I can't figure out why that test is failing, but I've made a patch to remove the test. Tests complete fine for me when I use it.
Comment 8 Johannes Huber gentoo-dev 2012-04-30 12:26:46 UTC
Thanks, committed.

+  30 Apr 2012; Johannes Huber <johu@gentoo.org> +files/okteta-4.8.2-test.patch,
+  okteta-4.8.2.ebuild:
+  Re-enable tests, patch out a failing test by Chris Reffett
+  <geekboy72@gmail.com> bug #264917.