Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280996 - =kde-base/libkcddb-4.4.92 tests failure
Summary: =kde-base/libkcddb-4.4.92 tests failure
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde4tests
  Show dependency tree
 
Reported: 2009-08-10 13:12 UTC by Bjoern Thorwirth
Modified: 2011-02-28 00:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bjoern Thorwirth 2009-08-10 13:12:29 UTC
The test phase never finish the first test:

 * >>> Test phase [test]: kde-base/libkcddb-4.2.4
make -j5 -s -j1 test 
Running tests...
Start processing tests
Test project /var/tmp/portage/kde-base/libkcddb-4.2.4/work/libkcddb-4.2.4_build
  1/  9 Testing kcddb-asynchttplookuptest     



Reproducible: Always




emerge --info:
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.28-tuxonice-r10 x86_64)
=================================================================
System uname: Linux-2.6.28-tuxonice-r10-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9450_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 10 Aug 2009 07:45:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.5.4-r3, 2.6.2-r1, 3.1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict test unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
LINGUAS="de en"
MAKEOPTS="-j5 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects /usr/portage/local/layman/gnome /usr/portage/local/layman/jyujin /usr/portage/local/layman/sunrise /usr/portage/local/layman/enlightenment /usr/portage/local/layman/wolf31o2 /usr/portage/local/layman/science /usr/portage/local/layman/python-experimental /usr/portage/local/layman/pythonhead /usr/portage/local/layman/python-testing /usr/portage/local/layman/mozilla /usr/portage/local/local-overlay /usr/portage/local/initng-portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="64bit X a52 aac aalib accessibility acl acpi ada alsa amarok amd64 apache2 arts audiofile authdaemond avahi bash-completion berkdb bidi bindist blas bluetooth branding bzip2 cairo cdda cdr chm clearcase cli config_wizard cpudetection cracklib crypt css cups dbus dga djvu dri dts dv dvb dvd dvdr dvdread dvi dxr3 eds emacs emboss encode esd evo extraicons extramodules fam fame fat fbcon fbcondecor fbsplash ffmpeg fftw firefox flac flash foomaticdb fortran fuse gcj gd gdbm gif glitz gnome gnome-keyring gnutls gphoto2 gpm gs gsm gstreamer gtk hal hdaps hfs iconv icq id3 ieee1394 imap inkjar inotify ipv6 irc irda isdnlog jabber jack java jfs jingle joystick jpeg kde kipi kqemu lame laptop latex lcd ldap libcaca libnotify libwww live lm_sensors lzo mad mail maildir matroska midi mikmod mmx mng mono mp3 mp4 mpeg mpi mudflap multilib musepack musicbrainz mysql nautilus ncurses network new-login nls nptl nptlonly nsplugin ntfs nvidia ogg ole openal openexr opengl openmp oss pam pascal pcmcia pcre pdf perl php pmu png postgres povray ppds pppd pulseaudio python qt3 qt3support qt4 quicktime quotas rar rdesktop readline reflection reiser4 reiserfs rss ruby samba sasl scanner sdl session shout skins slp sms sndfile speex spell spl sql sse sse2 ssl ssse3 startup-notification stream subversion svg sysfs tcpd test theora threads tiff tk truetype tta unicode usb vcd visualization voice vorbis wavpack weather wifi winbind wma wmf wxwindows x264 xcb xfs xine xinerama xiph xml xorg xosd xpm xprint xscreensaver xsl xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INITNG_PLUGINS="also bash_launcher chdir chroot conflict cpout critical ctrlaltdel daemon_clean debug_commands envparser find fmon fstat history idleprobe initctl interactive iparser last limit lockfile logfile netdev netprobe ngc4 ngcs nge pause provide reload renice rlparser simple_launcher stcmd stdout suid syncron syslog sysreq unneeded usplash" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Samuli Suominen gentoo-dev 2009-11-09 21:44:55 UTC
Confirmed to be still a problem for 4.3.3.
Comment 2 Andreas K. Hüttel gentoo-dev 2010-08-18 20:31:32 UTC
Checked for 4.4.92, the tests now merely fail.
Comment 3 Andreas K. Hüttel gentoo-dev 2010-11-13 20:56:04 UTC
4.5.3 status:

89% tests passed, 1 tests failed out of 9

Total Test time (real) =   5.64 sec

The following tests FAILED:
          9 - kcddb-cachetest (Failed)
Comment 4 Andreas K. Hüttel gentoo-dev 2010-12-14 15:39:31 UTC
4.5.4 status:

67% tests passed, 3 tests failed out of 9

Total Test time (real) =   9.13 sec

The following tests FAILED:
          1 - kcddb-asynchttplookuptest (Failed)
          2 - kcddb-asynccddblookuptest (Failed)
          9 - kcddb-cachetest (Failed)
Comment 5 Andreas K. Hüttel gentoo-dev 2011-02-16 21:20:35 UTC
Still fails in 4.6.0. 
Tests 1 and 2 compare local static data with the cddb version. Needs network access, and fails because the data on the server has been updated.
Test 9 - reason still unclear. 

More of the tests need network access. So, permanently restricting.
Comment 6 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-02-16 21:23:32 UTC
can't we remove only those tests instead?
Comment 7 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-02-28 00:03:47 UTC
after a short IRC discussion we decided to leave them restricted