Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 281712 - dev-libs/soprano fails tests
Summary: dev-libs/soprano fails tests
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL: http://sourceforge.net/p/soprano/bugs...
Whiteboard: tracking upstream
Keywords: TESTFAILURE
: 257724 307311 (view as bug list)
Depends on:
Blocks: kde4tests
  Show dependency tree
 
Reported: 2009-08-16 20:48 UTC by Jakub Januszkiewicz
Modified: 2013-06-21 17:19 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
dev-libs/soprano-2.3.0 build log (build.log,112.51 KB, text/plain)
2009-08-16 20:49 UTC, Jakub Januszkiewicz
Details
dev-libs/soprano-2.3.0-r1 build log (build.log,81.67 KB, text/plain)
2009-09-07 19:11 UTC, Jakub Januszkiewicz
Details
failed emerge log (soprano.failed.emerge.log,43.98 KB, text/plain)
2010-01-19 06:51 UTC, mehrunes
Details
emerge --info output (emerge--info,4.22 KB, text/plain)
2010-01-19 06:53 UTC, mehrunes
Details
my attempt to build soprana on update to kde4.4 (buildlog.tar.bz2,19.65 KB, application/octet-stream)
2010-02-24 05:26 UTC, Geoff Madden
Details
Test log for soprano-2.5.0 (LastTest.log.bz2,15.29 KB, text/plain)
2010-10-01 22:32 UTC, Andreas K. Hüttel
Details
Test log for soprano-2.6.0 (LastTest.log.bz2,13.64 KB, application/octet-stream)
2011-02-14 22:40 UTC, Andreas K. Hüttel
Details
Test log for soprano-2.7.0 (LastTest.log,395.19 KB, text/plain)
2011-09-03 19:54 UTC, Andreas K. Hüttel
Details
test log for soprano-2.7.3 (LastTest.log,384.24 KB, text/plain)
2011-12-10 18:19 UTC, Andreas K. Hüttel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Januszkiewicz 2009-08-16 20:48:19 UTC
dev-libs/soprano-2.3.0 fails the following tests from the suite:
  5 - redlandmemorymodeltest (Failed)
  6 - redlandpersistentmodeltest (Failed)
 11 - sesame2backendtest (Failed)        
 18 - sopranodclienttest (Failed)        
 19 - localsocketmultithreadtest (Failed)
 20 - sopranodsocketclienttest (Failed)  
 21 - sopranodbusclienttest (Failed)     
 22 - sopranodbusmultithreadtest (OTHER_FAULT)



Reproducible: Always

Steps to Reproduce:
1. FEATURES="test" USE="clucene dbus java raptor redland" emerge =dev-libs/soprano-2.3.0



# emerge --info                              
Portage 2.2_rc38 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 i686)
=================================================================                                            
System uname: Linux-2.6.30-gentoo-r5-i686-AMD_Phenom-tm-_8450_Triple-Core_Processor-with-gentoo-2.0.1        
Timestamp of tree: Sun, 16 Aug 2009 08:45:01 +0000                                                           
app-shells/bash:     4.0_p28                                                                                 
dev-java/java-config: 2.1.8-r1                                                                               
dev-lang/python:     2.6.2-r1, 3.1                                                                           
dev-util/cmake:      2.6.4-r2                                                                                
sys-apps/baselayout: 2.0.1                                                                                   
sys-apps/openrc:     0.4.3-r3                                                                                
sys-apps/sandbox:    2.0                                                                                     
sys-devel/autoconf:  2.13, 2.63-r1                                                                           
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                         
sys-devel/binutils:  2.19.1-r1                                                                               
sys-devel/gcc-config: 1.4.1                                                                                  
sys-devel/libtool:   2.2.6a                                                                                  
virtual/os-headers:  2.6.30-r1                                                                               
ACCEPT_KEYWORDS="x86 ~x86"                                                                                   
CBUILD="i686-pc-linux-gnu"                                                                                   
CFLAGS="-O2 -march=amdfam10 -pipe -ggdb"                                                                     
CHOST="i686-pc-linux-gnu"                                                                                    
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                                                 
CXXFLAGS="-O2 -march=amdfam10 -pipe -ggdb"                                                                                                                   
DISTDIR="/usr/portage/distfiles"                                                                                                                             
EMERGE_DEFAULT_OPTS="--keep-going --jobs 2 --load-average 2.00"                                                                                              
FEATURES="assume-digests buildpkg distlocks fixpackages installsources parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict test unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"                                                                                            
GENTOO_MIRRORS="http://src.gentoo.pl/ http://gentoo.prz.rzeszow.pl/ http://gentoo.mirrors.pair.com/ http://gentoo.osuosl.org/"                               
LANG="pl_PL.UTF-8"                                                                                                                                           
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="pl"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/roslin /usr/local/portage/layman/kde-testing /usr/local/portage/layman/vmware /usr/local/portage/overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amarok amarok2 apache2 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdparanoia cdr cisco cjk cli consolekit cracklib crypt cups curl dbus dri dts dv dvd dvdr dvdread emboss encode evo exif fam fbcon ffmpeg firefox flac foomaticdb fortran gdbm gif glitz gphoto2 gpm gstreamer hal htmlhandbook iconv ieee1394 inotify irmc isdnlog jabber java java5 java6 javascript jpeg kde kdehiddenvisibility kipi ldap libffi libnotify lm_sensors mad matroska mikmod mime mmx mmxext mng mp3 mp4 mpeg mplayer mtp mudflap musepack ncurses network networkmanager njb nls nptl nptlonly nsplugin offensive ogg openal opengl openmp pam pcre pdf perl phonon plasma png policykit ppds pppd python qt qt3 qt3support qt4 quicktime rdesktop readline realmedia reflection samba sdl semantic-desktop session smp solver spell spl sse sse2 ssl startup-notification subversion svg sysfs tcpd theora threads tiff truetype unicode usb utempter vcd videos vnc vorbis win32codecs x264 x86 xattr xcomposite xine xml xorg xprint xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" NETBEANS_MODULES="*" USERLAND="GNU" VIDEO_CARDS="none radeonhd"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Januszkiewicz 2009-08-16 20:49:06 UTC
Created attachment 201470 [details]
dev-libs/soprano-2.3.0 build log
Comment 2 Jakub Januszkiewicz 2009-09-07 19:10:35 UTC
Still fails as of dev-libs/soprano-2.3.0-r1.

The following tests FAILED:
         14 - sopranodclienttest (Failed)
         15 - localsocketmultithreadtest (Failed)
         16 - sopranodsocketclienttest (Failed)
         17 - sopranodbusclienttest (Failed)
         18 - sopranodbusmultithreadtest (OTHER_FAULT)
Comment 3 Jakub Januszkiewicz 2009-09-07 19:11:13 UTC
Created attachment 203392 [details]
dev-libs/soprano-2.3.0-r1 build log
Comment 4 Maciej Mrozowski gentoo-dev 2009-09-25 04:18:43 UTC
Yes, it's somewhat known, and mysterious even for upstream (as those tests pass under some circumstances - either when run 'ctest' or 'make check', don't remember now).
Comment 5 Jakub Januszkiewicz 2009-09-25 11:28:10 UTC
Good to know, thanks. Is it therefore safe to assume that if I install this package despite failing tests, it is going to work properly?

For the record, 2.3.1 fails, too.
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2009-12-01 21:06:20 UTC
*** Bug 257724 has been marked as a duplicate of this bug. ***
Comment 7 mehrunes 2010-01-19 06:50:00 UTC
(In reply to comment #5)

> For the record, 2.3.1 fails, too.
> 

My soprano 2.3.1 test results are slightly different than those found in 1st post

======== emerge log piece start ===============================================
47% tests passed, 8 tests failed out of 15

The following tests FAILED:
	  2 - literaltest (Failed)
	  6 - inferencemodeltest (SEGFAULT)
	  9 - sopranodclienttest (Failed)
	 10 - localsocketmultithreadtest (Failed)
	 11 - sopranodsocketclienttest (Failed)
	 12 - sopranodbusclienttest (Failed)
	 13 - sopranodbusmultithreadtest (OTHER_FAULT)
	 14 - nrlmodeltest (SEGFAULT)
======== emerge log piece   end ===============================================

i will attach full log and emerge --info shortly
Comment 8 mehrunes 2010-01-19 06:51:25 UTC
Created attachment 216874 [details]
failed emerge log
Comment 9 mehrunes 2010-01-19 06:53:03 UTC
Created attachment 216876 [details]
emerge --info output

I suggest that bug header be changed to 

dev-libs/soprano-2.3.* fails testsuite
Comment 10 Geoff Madden 2010-02-24 05:26:33 UTC
Created attachment 220923 [details]
my attempt to build soprana on update to kde4.4

make check for soprano-2.4.1.0 just stops executing for some reason. this's on an AMD 1000 x86 platform and it appears similar to the previous failures,though much further into the test.The system has 1G of ram and a 1G partition for swap.
Comment 11 Andreas K. Hüttel gentoo-dev 2010-03-02 23:14:51 UTC
*** Bug 307311 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Murphy 2010-06-29 17:44:22 UTC
Confirming for 2.4.3[dbus java raptor redland test virtuoso]:

43% tests passed, 13 tests failed out of 23

The following tests FAILED:
          3 - literaltest (Failed)
          5 - redlandstatementiteratortest (OTHER_FAULT)
          6 - redlandmemorymodeltest (Failed)           
          7 - redlandpersistentmodeltest (Failed)       
          8 - redlandmultithreadtest (Failed)           
         11 - inferencemodeltest (OTHER_FAULT)          
         16 - sopranodclienttest (Failed)               
         17 - localsocketmultithreadtest (Failed)       
         18 - sopranodsocketclienttest (Failed)         
         19 - sopranodbusclienttest (Failed)            
         20 - sopranodbusmultithreadtest (OTHER_FAULT)  
         22 - virtuosobackendtest (Failed)              
         23 - graphtest (Failed)                        
Comment 13 Andreas K. Hüttel gentoo-dev 2010-10-01 22:32:54 UTC
Created attachment 249226 [details]
Test log for soprano-2.5.0

Part of the failures is due to no available dbus, but definitely not all.
Comment 14 Ryan Hill (RETIRED) gentoo-dev 2010-10-02 03:01:12 UTC
Can we restrict tests on this package.  It has never (in my memory) worked.
Comment 15 Andreas K. Hüttel gentoo-dev 2010-10-02 06:48:50 UTC
(In reply to comment #14)
> Can we restrict tests on this package.  It has never (in my memory) worked.
> 

The tests are already restricted, no worry.
 
Comment 16 Andreas K. Hüttel gentoo-dev 2011-02-14 22:40:55 UTC
Created attachment 262539 [details]
Test log for soprano-2.6.0

Not much changed, no improvement
Comment 17 Andreas K. Hüttel gentoo-dev 2011-07-26 21:34:05 UTC
[23:38:02] <j0hu> dilfridge:  Bug 281712 works for me with 2.6.51
[23:38:08] <willikins> j0hu: https://bugs.gentoo.org/281712 "dev-libs/soprano-2.4.0.1, 2.5.0, 2.6.0 fail testsuite"; Gentoo Linux, Applications; CONF; jakub.januszkiewicz:kde
[23:38:21] <dilfridge> hmm cool then we'll close it :)
[23:39:19] <dilfridge> as soon as it's in the main tree
Comment 18 Markus Oehme 2011-07-28 20:30:22 UTC
I see the following failures with soprano 2.6.51[dbus raptor redland test virtuoso] on ~amd64 with hardened-gcc-4.6.1 and vanilla-gcc-4.6.1:

The following tests FAILED:
	  4 - literaltest (Failed)
	  6 - redlandstatementiteratortest (OTHER_FAULT)
	  7 - redlandmemorymodeltest (Failed)
	  8 - redlandpersistentmodeltest (Failed)
	  9 - redlandmultithreadtest (Failed)
	 12 - inferencemodeltest (OTHER_FAULT)
	 15 - sopranodclienttest (Failed)
	 16 - localsocketmultithreadtest (Failed)
	 17 - sopranodsocketclienttest (Failed)
	 18 - sopranodbusclienttest (Failed)
	 19 - sopranodbusmultithreadtest (OTHER_FAULT)
	 20 - nrlmodeltest (OTHER_FAULT)
	 21 - virtuosobackendtest (Failed)
	 22 - graphtest (Failed)
	 23 - asyncquerytest (Failed)
Comment 19 David Kredba 2011-07-29 20:19:51 UTC
Soprano Components that will be built:
   * Redland storage backend
   * Virtuoso storage backend (Run-time dependency: Virtuoso)
   * Raptor RDF parser
     (including TriG parser)
   * Raptor RDF serializer
   * D-Bus server/client support

The following tests FAILED:
          7 - redlandmemorymodeltest (Failed)
          8 - redlandpersistentmodeltest (Failed)
         15 - sopranodclienttest (Failed)
         16 - localsocketmultithreadtest (Failed)
         17 - sopranodsocketclienttest (Failed)
         18 - sopranodbusclienttest (Failed)
         19 - sopranodbusmultithreadtest (OTHER_FAULT)
         21 - virtuosobackendtest (Failed)
         22 - graphtest (Failed)

gcc-4.6.1, -j4.
Comment 20 Andreas K. Hüttel gentoo-dev 2011-09-03 19:53:30 UTC
>>> Working in BUILD_DIR: "/var/tmp/portage/dev-libs/soprano-2.7.0/work/soprano-2.7.0"
Test project /var/tmp/portage/dev-libs/soprano-2.7.0/work/soprano-2.7.0
      Start 14: serializertest
 1/27 Test #14: serializertest .....................   Passed    0.02 sec
      Start 27: asyncquerytest
 2/27 Test #27: asyncquerytest .....................   Passed    0.02 sec
      Start 26: graphtest
 3/27 Test #26: graphtest ..........................***Failed    0.03 sec
      Start 25: virtuosobackendtest
 4/27 Test #25: virtuosobackendtest ................***Failed  115.62 sec
      Start 24: nrlmodeltest
 5/27 Test #24: nrlmodeltest .......................   Passed    0.01 sec
      Start 23: sopranodbusmultithreadtest
 6/27 Test #23: sopranodbusmultithreadtest .........***Exception: Other  0.07 sec
      Start 22: sopranodbusclienttest
 7/27 Test #22: sopranodbusclienttest ..............***Failed    0.01 sec
      Start 21: sopranodsocketclienttest
 8/27 Test #21: sopranodsocketclienttest ...........***Failed    0.00 sec
      Start 20: localsocketmultithreadtest
 9/27 Test #20: localsocketmultithreadtest .........***Failed    0.01 sec
      Start 19: sopranodclienttest
10/27 Test #19: sopranodclienttest .................***Failed    0.00 sec
      Start 18: indexmodelmultithreadingtest
11/27 Test #18: indexmodelmultithreadingtest .......   Passed    1.33 sec
      Start 17: cluceneindextest
12/27 Test #17: cluceneindextest ...................***Failed    0.44 sec
      Start 16: tstringtest
13/27 Test #16: tstringtest ........................   Passed    0.00 sec
      Start 15: errortest
14/27 Test #15: errortest ..........................   Passed    0.00 sec
      Start  1: datetimetest
15/27 Test  #1: datetimetest .......................   Passed    0.00 sec
      Start 13: parsertest
16/27 Test #13: parsertest .........................   Passed    0.01 sec
      Start 12: inferencemodeltest
17/27 Test #12: inferencemodeltest .................   Passed    0.18 sec
      Start 11: queryresultstatementiteratortest
18/27 Test #11: queryresultstatementiteratortest ...   Passed    0.00 sec
      Start 10: simplestatementiteratortest
19/27 Test #10: simplestatementiteratortest ........   Passed    0.00 sec
      Start  9: redlandmultithreadtest
20/27 Test  #9: redlandmultithreadtest .............   Passed    1.03 sec
      Start  8: redlandpersistentmodeltest
21/27 Test  #8: redlandpersistentmodeltest .........   Passed    8.13 sec
      Start  7: redlandmemorymodeltest
22/27 Test  #7: redlandmemorymodeltest .............   Passed    0.17 sec
      Start  6: redlandstatementiteratortest
23/27 Test  #6: redlandstatementiteratortest .......   Passed    0.02 sec
      Start  5: statementtest
24/27 Test  #5: statementtest ......................   Passed    0.00 sec
      Start  4: literaltest
25/27 Test  #4: literaltest ........................   Passed    0.01 sec
      Start  3: n3nodeparsertest
26/27 Test  #3: n3nodeparsertest ...................   Passed    0.00 sec
      Start  2: nodetest
27/27 Test  #2: nodetest ...........................   Passed    0.00 sec

70% tests passed, 8 tests failed out of 27

Total Test time (real) = 128.05 sec

The following tests FAILED:
         26 - graphtest (Failed)
         25 - virtuosobackendtest (Failed)
         23 - sopranodbusmultithreadtest (OTHER_FAULT)
         22 - sopranodbusclienttest (Failed)
         21 - sopranodsocketclienttest (Failed)
         20 - localsocketmultithreadtest (Failed)
         19 - sopranodclienttest (Failed)
         17 - cluceneindextest (Failed)
Errors while running CTest
Comment 21 Andreas K. Hüttel gentoo-dev 2011-09-03 19:54:44 UTC
Created attachment 285453 [details]
Test log for soprano-2.7.0
Comment 22 Andreas K. Hüttel gentoo-dev 2011-12-10 18:19:54 UTC
Created attachment 295403 [details]
test log for soprano-2.7.3

70% tests passed, 8 tests failed out of 27

Total Test time (real) = 139.76 sec

The following tests FAILED:
         17 - cluceneindextest (Failed)
         19 - sopranodclienttest (Failed)
         20 - localsocketmultithreadtest (Failed)
         21 - sopranodsocketclienttest (Failed)
         22 - sopranodbusclienttest (Failed)
         23 - sopranodbusmultithreadtest (OTHER_FAULT)
         25 - virtuosobackendtest (Failed)
         26 - graphtest (Failed)
Errors while running CTest
 * ERROR: dev-libs/soprano-2.7.3 failed (test phase):
Comment 23 Johannes Huber gentoo-dev 2012-01-12 12:39:08 UTC
Same test result for soprano-2.7.4:

70% tests passed, 8 tests failed out of 27

Total Test time (real) = 282.28 sec

The following tests FAILED:
         17 - cluceneindextest (Failed)
         19 - sopranodclienttest (Failed)
         20 - localsocketmultithreadtest (Failed)
         21 - sopranodsocketclienttest (Failed)
         22 - sopranodbusclienttest (Failed)
         23 - sopranodbusmultithreadtest (OTHER_FAULT)
         25 - virtuosobackendtest (Failed)
         26 - graphtest (Failed)
Comment 24 Michael Palimaka (kensington) gentoo-dev 2013-02-01 13:42:50 UTC
2.9.0 fails too.
Comment 25 Michael Palimaka (kensington) gentoo-dev 2013-06-12 09:25:54 UTC
Still fails 2.9.2

SourceForge bug tracker seems dead, is there somewhere else?
Comment 26 Michael Palimaka (kensington) gentoo-dev 2013-06-21 17:19:29 UTC
Tests are restricted and there's nothing else can we can.