Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 420203 - media-plugins/kipi-plugins-2.6.0 fails to build tests
Summary: media-plugins/kipi-plugins-2.6.0 fails to build tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords: REGRESSION
Depends on:
Blocks: kde4tests
  Show dependency tree
 
Reported: 2012-06-08 08:18 UTC by Nikoli
Modified: 2014-01-10 04:14 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (kipi-plugins-2.6.0_build.log.xz,50.64 KB, application/octet-stream)
2012-07-03 20:38 UTC, Nikoli
Details
build.log.xz (kipi-plugins-2.9.0_build.log.xz,50.88 KB, application/octet-stream)
2012-09-05 13:23 UTC, Nikoli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikoli 2012-06-08 08:18:31 UTC
/var/tmp/portage/media-plugins/kipi-plugins-2.6.0/work/digikam-2.6.0/extra/kipi-plugins/tests/kipiinterface.cpp: In member function ‘virtual KIPI::ImageInfo KipiInterface::info(const KUrl&)’:
/var/tmp/portage/media-plugins/kipi-plugins-2.6.0/work/digikam-2.6.0/extra/kipi-plugins/tests/kipiinterface.cpp:116:57: error: cannot allocate an object of abstract type ‘KipiImageInfoShared’
/var/tmp/portage/media-plugins/kipi-plugins-2.6.0/work/digikam-2.6.0/extra/kipi-plugins/tests/kipiimageinfoshared.h:37:1: note:   because the following virtual functions are pure within ‘KipiImageInfoShared’:
/usr/include/libkipi/imageinfoshared.h:73:21: note:     virtual QString KIPI::ImageInfoShared::description()
/usr/include/libkipi/imageinfoshared.h:74:21: note:     virtual void KIPI::ImageInfoShared::setDescription(const QString&)
/var/tmp/portage/media-plugins/kipi-plugins-2.6.0/work/digikam-2.6.0/extra/kipi-plugins/tests/kipiinterface.cpp:117:1: error: control reaches end of non-void function
make[2]: *** [tests/CMakeFiles/kipicmd.dir/kipiinterface.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-2.6.0/work/kipi-plugins-2.6.0_build'
make[1]: *** [tests/CMakeFiles/kipicmd.dir/all] Error 2
make[1]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-2.6.0/work/kipi-plugins-2.6.0_build'
make: *** [all] Error 2



Portage 2.1.10.49 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.3.7-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
Timestamp of tree: Fri, 08 Jun 2012 07:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r1
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo nikoli
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -mavx -maes -mpclmul -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -mtune=generic -mavx -maes -mpclmul -O2 -pipe"
DISTDIR="/var/package-manager/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS=""
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j9"
PKGDIR="/var/package-manager/packages/corei7-avx"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR="/var/package-manager/portage"
PORTDIR_OVERLAY="/var/lib/layman/nikoli"
USE="X a52 aac acl acpi aes-ni akonadi alsa amd64 amr atm audiofile avx bash-completion bluetooth bzip2 cairo caps cdda cddb cdio cdparanoia cdr celt cli consolekit cracklib crypt css cups cxx dbus djvu dri dts dv dvd dvdr emboss encode exif fat ffmpeg firefox flac fluidsynth fontconfig fortran gd geoip gif gimp gmp gnutls gphoto2 gpm graphviz gsm gstreamer gtk handbook iconv icu id3tag idn ilbc imagemagick imap imlib ios ipod ipv6 jbig jpeg jpeg2k kde kipi kontact lame laptop lcms libnotify libproxy libsamplerate lm_sensors lzma lzo mac mad matroska mikmod mmx mmxext mng modplug modules mp3 mp4 mpeg mtp mudflap multilib musepack musicbrainz ncurses networkmanager nls nptl nptlonly ntfs ogg openal openexr opengl openmp pam pango pcre pdf pg-intdatetime phonon plasma pm-utils png policykit ppds pppd qt3support qt4 quicktime rar raw readline reiserfs replaygain rtmp sasl scanner schroedinger semantic-desktop session sid smp sndfile socks5 speex spell sqlite sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg symlink sysfs taglib theora threads thumbnail tiff truetype tta udev udisks unicode upnp upower usb v4l v4l2 vaapi vcd vdpau vorbis vpx wavpack webkit webp wifi wma wmf wps wxwidgets x264 xattr xcb xcomposite xface xinerama xml xmp xorg xpm xscreensaver xulrunner xv xvid xz zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" NGINX_MODULES_HTTP="access auth_basic autoindex fastcgi gzip rewrite" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon r600 vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-plugins/kipi-plugins-2.5.0 was built with the following:
USE="calendar cdr crypt expoblending gpssync handbook imagemagick ipod mjpeg (multilib) opengl panorama redeyes scanner test (-aqua) -debug -vkontakte" LINGUAS="ru -ar -az -be -bg -bn -br -bs -ca -cs -csb -cy -da -de -el -en_GB -eo -es -et -eu -fa -fi -fo -fr -fy -ga -gl -ha -he -hi -hr -hsb -hu -id -is -it -ja -ka -kk -km -ko -ku -lb -lo -lt -lv -mi -mk -mn -ms -mt -nb -nds -ne -nl -nn -nso -oc -pa -pl -pt -pt_BR -ro -rw -se -sk -sl -sq -sr -ss -sv -ta -te -tg -th -tr -tt -uk -uz -ven -vi -wa -xh -zh_CN -zh_HK -zh_TW -zu"
Comment 1 Andreas Sturmlechner gentoo-dev 2012-06-09 14:19:57 UTC
No trouble here with a comparatively limited USE flag set:

media-plugins/kipi-plugins-2.6.0  USE="cdr crypt handbook imagemagick opengl (-aqua) -calendar -debug -expoblending -gpssync -ipod -mediawiki -mjpeg -panorama -redeyes -scanner -vkontakte" LINGUAS="de en_GB"
Comment 2 Andreas K. Hüttel archtester gentoo-dev 2012-06-09 17:56:52 UTC
No idea, sorry. I guess it would be best to report this upstream at bugs.kde.org.
Comment 3 Nikoli 2012-06-11 05:17:16 UTC
Sorry, it fails not src_compile, but src_test. Andreas, does it pass tests for you?
USE="calendar cdr crypt expoblending gpssync handbook imagemagick ipod mediawiki%* mjpeg opengl panorama redeyes scanner (-aqua) -debug -vkontakte"
Comment 4 Chris Reffett (RETIRED) gentoo-dev Security 2012-07-03 01:37:14 UTC
Huh, for once I can't replicate a test bug. Full build.log, please, maybe it will tell us something useful. This looks to be an error building the tests, rather than an error running the tests.
Comment 5 Michael Palimaka (kensington) gentoo-dev 2012-07-03 09:14:48 UTC
Looks like bug #422613 is a dup of this?
Comment 6 Nikoli 2012-07-03 20:38:54 UTC
Created attachment 317069 [details]
build.log
Comment 7 Johannes Huber gentoo-dev 2012-08-15 20:10:19 UTC
I hit this issue while arch testing on x86 too. I would suggest to disable to build the tests.

It fails at least for those use combinations it fails:

USE='-calendar -cdr -crypt -expoblending -gpssync -handbook -imagemagick -ipod -mediawiki -mjpeg -opengl -panorama -redeyes -scanner -vkontakte'  emerge -1v =media-plugins/kipi-plugins-2.6.0-r1 

USE='calendar cdr crypt expoblending gpssync handbook imagemagick ipod mediawiki mjpeg opengl panorama redeyes scanner vkontakte'  emerge -1v =media-plugins/kipi-plugins-2.6.0-r1
Comment 8 Agostino Sarubbo gentoo-dev 2012-08-15 20:59:37 UTC
jfyi. fine for me on amd64
Comment 9 Andreas K. Hüttel archtester gentoo-dev 2012-08-23 10:53:32 UTC
Tests restricted for the moment, needs analysis
Comment 10 Michael Palimaka (kensington) gentoo-dev 2012-09-05 12:48:22 UTC
Tests now build and pass fine for me with 2.9.0.

Can other people who experienced this bug please also test?
Comment 11 Nikoli 2012-09-05 13:23:50 UTC
Created attachment 323004 [details]
build.log.xz

Did you remove 'RESTRICT=test' from ebuild?

For me 2.9 fails tests.
Comment 12 Michael Palimaka (kensington) gentoo-dev 2012-09-05 14:09:23 UTC
(In reply to comment #11)
> Did you remove 'RESTRICT=test' from ebuild?
Yes...
Comment 13 Markus Oehme 2013-01-12 11:55:58 UTC
I just retested with 2.9.0 and everything worked just fine after removing the test restriction.
Comment 14 Michael Palimaka (kensington) gentoo-dev 2013-03-14 16:05:51 UTC
This is the same as bug #422613, which I could initially reproduce and later could not reproduce.
Comment 15 Johannes Huber gentoo-dev 2013-11-23 16:20:59 UTC
Is this still valid?
Comment 16 Nikoli 2013-11-23 17:43:09 UTC
Removed RESTRICT=test, media-plugins/kipi-plugins-3.5.0 builds and install fine, tests work fine too:

100% tests passed, 0 tests failed out of 6

Total Test time (real) =   0.54 sec
 * Tests succeeded.


2 installed files changed:
-599856 /usr/lib64/kde4/kipiplugin_gpssync.so
-619e5b57617662b03267984b9f151948  /usr/lib64/kde4/kipiplugin_gpssync.so
+632624 /usr/lib64/kde4/kipiplugin_gpssync.so
+48411629079e99a0525e564e57f2d947  /usr/lib64/kde4/kipiplugin_gpssync.so
 /usr/lib64/kde4/kipiplugin_gpssync.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
 libc.so.6
 libkdecore.so.5
@@ -896,6 +896,7 @@
 libkipi.so.10
 libQtCore.so.4
 libQtGui.so.4
+libQtTest.so.4
 libQtXml.so.4
 libstdc++.so.6
 /usr/lib64/kde4/kipiplugin_htmlexport.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
@@ -1300,7 +1301,7 @@
 /usr/lib64/libkipiplugins.so.3: symbolic link to `libkipiplugins.so.3.0.0'
 /usr/lib64/libkipiplugins.so.3.0.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
 435928 /usr/lib64/libkipiplugins.so.3.0.0
-fe2347f3ddb7cb8970da3f49495ee799  /usr/lib64/libkipiplugins.so.3.0.0
+eb3439b2475f54641edd1e7f0f573cd2  /usr/lib64/libkipiplugins.so.3.0.0
Comment 17 Markus Oehme 2013-11-28 20:33:34 UTC
(In reply to Nikoli from comment #16)
> Removed RESTRICT=test, media-plugins/kipi-plugins-3.5.0 builds and install
> fine, tests work fine too:
> 
> 100% tests passed, 0 tests failed out of 6
> 
> Total Test time (real) =   0.54 sec
>  * Tests succeeded.

I can confirm this. 3.5.0 works fine for me too.
Comment 18 Michael Palimaka (kensington) gentoo-dev 2014-01-10 04:14:34 UTC
I guess we can close this then.