Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 69343 (gnome-tests) - [TRACKER] GNOME packages failing with FEATURES="test"
Summary: [TRACKER] GNOME packages failing with FEATURES="test"
Status: RESOLVED WORKSFORME
Alias: gnome-tests
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: Tracker
: 67006 69347 69797 71061 71070 71775 72592 75244 81314 81340 81681 83915 84698 92407 96083 97842 99424 99429 107075 110891 118688 129079 140221 142347 (view as bug list)
Depends on: 95805 100523 126643 126847 129079 132501 139974 142585 147448 147680 148808 150709 157820 162044 165098 166293 176202 176809 181906 188043 190066 191535 192302 192406 192640 192641 192732 196490 206671 212983 216146 218235 228683 237498 238995 239339 241612 242146 245103 262324 262325 264219 264817 265205 265911 270105 270107 272450 285675 285687 285706 285715 286375 292478 296849 307725 313351 315011 315287 323661 325677 326739 331293 331709 333667 339441 341173 342557 348926
Blocks:
  Show dependency tree
 
Reported: 2004-10-28 19:43 UTC by Brant Gurganus
Modified: 2011-04-24 23:03 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Modify src_test() for gnome2 packages to use a temporary home directory (gnome2.eclass-srctest.patch,855 bytes, patch)
2006-08-09 12:16 UTC, Kevin F. Quinn (RETIRED)
Details | Diff
emerge --info (emerge.info,6.48 KB, text/plain)
2006-12-11 08:54 UTC, Dustin Polke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brant Gurganus 2004-10-28 19:43:35 UTC
The test-async-cancel test for gnome-vfs-2.8.1 fails.

Reproducible: Always
Steps to Reproduce:
1. Emerge gnome-vfs-2.8.1 with FEATURES="makecheck"
Actual Results:  
make  check-TESTS
make[2]: Entering directory
`/var/tmp/portage/gnome-vfs-2.8.1/work/gnome-vfs-2.8.1/test'
Testing get file info...
Testing open, close...
Testing read, close...
Testing cancellation...
Testing failed opens...
Testing read, cancel, closes...
Testing directory loads** Message: test failed: load directory cancel 2: job
never went away delay 1
** Message: test failed: load directory cancel 2: job never went away delay 10
...
Testing directory finds...
Testing shutdown...
FAIL: test-async-cancel
PASS: test-escape
PASS: test-uri
You should see a warning and 2 critical errors below.

(process:30986): libgnomevfs-WARNING **: Attempt to set the thread_count_limit
below 2
Trying to start a job with priority = -11; should result in a critical error

(process:30986): libgnomevfs-CRITICAL **: file gnome-vfs-async-ops.c: line 688
(gnome_vfs_async_get_file_info): assertion `priority >= GNOME_VFS_PRIORITY_MIN'
failed
Trying to start a job with priority = 11; should result in a critical error

(process:30986): libgnomevfs-CRITICAL **: file gnome-vfs-async-ops.c: line 689
(gnome_vfs_async_get_file_info): assertion `priority <= GNOME_VFS_PRIORITY_MAX'
failed
No warning or error messages are expected beyond this point
I/O warning : failed to load external entity "../test/queue-test-config.xml"
Didn't find a valid settings file at ../test/queue-test-config.xml
Use the GNOME_VFS_TEST_CONFIG_FILE environment variable to specify a different
location.

(process:30986): gnome-vfs-modules-WARNING **: failed to create trash item cache
file

(process:30986): gnome-vfs-modules-WARNING **: failed to create trash item cache
file

(process:30986): gnome-vfs-modules-WARNING **: failed to create trash item cache
file
PASS: test-queue
Initializing gnome-vfs...
Creating async context...
Starting open for `./test.input'...
Main loop running.
Open failed: Invalid URI.
Main loop finished.
Test async queue efficiency ...Passed
All done
Test passed
PASS: ./auto-test
===================
1 of 5 tests failed
===================


Expected Results:  
All tests should pass or be changed to work within the sandbox.

Portage 2.0.51-r2 (default-x86-2004.2, gcc-3.4.2, glibc-2.3.4.20041006-r0,
2.6.9-gentoo-r1 i686)
=================================================================
System uname: 2.6.9-gentoo-r1 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 2.20GHz
Gentoo Base System version 1.6.4
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632)
[disabled]ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4m -mtune=pentium4m -maccumulate-outgoing-args
-fprefetch-loop-arrays -ftracer -pipe -fomit-frame-pointer -frename-registers
-ffast-math"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4m -mtune=pentium4m -maccumulate-outgoing-args
-fprefetch-loop-arrays -ftracer -pipe -fomit-frame-pointer -frename-registers
-ffast-math"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks fixpackages maketest sandbox strict"
GENTOO_MIRRORS="ftp://hercules.cs.rose-hulman.edu/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://hercules.cs.rose-hulman.edu/portage"
USE="X acpi alsa avi berkdb bitmap-fonts cdr crypt cups dga dvd encode esd f77
foomaticdb gdbm gif gnome gnutls gpm gstreamer gtk gtk2 imlib java jpeg kde
kerberos krb4 ldap libg++ libwww mad mikmod mmap mmx mng motif mozilla mpeg
mysql ncurses nls nptl offensive oggvorbis opengl pam pcre pdflib perl pic png
pnp ppds python qt quicktime readline samba sasl sdl slang spell sse ssl svg
tcpd tiff truetype unicode wmf x86 xml xml2 xmms xprint xv zlib"
Comment 1 foser (RETIRED) gentoo-dev 2004-10-29 02:47:40 UTC
just ditch maketest from features.

And maybe lower your cflags.

If you want to look into it, fine. But I don't think it's wise to spend time on tests that aren't maintained half of the time.
Comment 2 foser (RETIRED) gentoo-dev 2004-10-29 03:12:27 UTC
*** Bug 69347 has been marked as a duplicate of this bug. ***
Comment 3 foser (RETIRED) gentoo-dev 2004-11-02 03:22:38 UTC
*** Bug 69797 has been marked as a duplicate of this bug. ***
Comment 4 John Altstadt 2004-11-13 09:13:54 UTC
If maketest fails, shouldn't the problem be reported upstream?
Comment 5 foser (RETIRED) gentoo-dev 2004-11-14 01:39:05 UTC
*** Bug 71061 has been marked as a duplicate of this bug. ***
Comment 6 foser (RETIRED) gentoo-dev 2004-11-15 10:26:07 UTC
*** Bug 71061 has been marked as a duplicate of this bug. ***
Comment 7 foser (RETIRED) gentoo-dev 2004-11-20 09:21:46 UTC
*** Bug 71775 has been marked as a duplicate of this bug. ***
Comment 8 Mike Gardiner (RETIRED) gentoo-dev 2004-11-22 09:38:00 UTC
Taken from #71070

I'm going to propose something for these maketest "bugs". 

While we, the GNOME team, are not in any way opposed to fixing bugs in the software we maintain, we do not currently have the time required to catch these "maketest bugs", and patch them. This is compounded by the fact that only a small number of users use FEATURES="maketest".

Although we will not have the time to fix these "bugs" ourselves, we will happily test any patch you can supply to us, or any formed solution to the problem. Should you be unable to provide such a patch, then the easiest course of action may be upstream - where they have a better understanding of the software, even than us.

While FEATURES="maketest" is available in portage, you must understand it is not uniformly supported across all upstream developers, and more often than not, the tests performed by "make test" are outdated, and are known to fail.
Comment 9 Mike Gardiner (RETIRED) gentoo-dev 2004-11-22 09:39:18 UTC
*** Bug 71070 has been marked as a duplicate of this bug. ***
Comment 10 Mike Gardiner (RETIRED) gentoo-dev 2004-11-26 23:03:27 UTC
*** Bug 72592 has been marked as a duplicate of this bug. ***
Comment 11 Mike Gardiner (RETIRED) gentoo-dev 2004-12-21 17:01:26 UTC
*** Bug 75244 has been marked as a duplicate of this bug. ***
Comment 12 foser (RETIRED) gentoo-dev 2005-01-17 10:34:01 UTC
*** Bug 67006 has been marked as a duplicate of this bug. ***
Comment 13 Sascha Silbe 2005-01-21 18:13:10 UTC
Then please add RESTRICT=maketest to all the ebuilds you maintain, so we can use this feature (that's very useful in many cases) for the rest of the system.

Comment 14 Joe McCann (RETIRED) gentoo-dev 2005-02-09 02:11:41 UTC
*** Bug 81340 has been marked as a duplicate of this bug. ***
Comment 15 Lars Strojny 2005-02-09 02:57:34 UTC
I fully agree with Sascha Silbe's post. Please add RESTRICT!
Comment 16 foser (RETIRED) gentoo-dev 2005-02-09 08:28:18 UTC
*** Bug 81314 has been marked as a duplicate of this bug. ***
Comment 17 Mike Gardiner (RETIRED) gentoo-dev 2005-02-11 17:46:20 UTC
*** Bug 81681 has been marked as a duplicate of this bug. ***
Comment 18 Joe McCann (RETIRED) gentoo-dev 2005-03-09 20:57:15 UTC
*** Bug 84698 has been marked as a duplicate of this bug. ***
Comment 19 Mike Gardiner (RETIRED) gentoo-dev 2005-04-16 04:27:22 UTC
*** Bug 83915 has been marked as a duplicate of this bug. ***
Comment 20 foser (RETIRED) gentoo-dev 2005-05-18 16:45:10 UTC
*** Bug 92407 has been marked as a duplicate of this bug. ***
Comment 21 foser (RETIRED) gentoo-dev 2005-06-14 08:39:07 UTC
*** Bug 96083 has been marked as a duplicate of this bug. ***
Comment 22 Attila Stehr 2005-06-14 09:37:31 UTC
(In reply to comment #8)
> Taken from #71070
> 
> I'm going to propose something for these maketest "bugs". 
> 
> While we, the GNOME team, are not in any way opposed to fixing bugs in the
software we maintain, we do not currently have the time required to catch these
"maketest bugs", and patch them. This is compounded by the fact that only a
small number of users use FEATURES="maketest".

Hum ... Probably they should ... what says the handbook about this?!
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2005-07-03 10:47:01 UTC
*** Bug 97842 has been marked as a duplicate of this bug. ***
Comment 24 John N. Laliberte (RETIRED) gentoo-dev 2005-07-29 16:23:14 UTC
*** Bug 99424 has been marked as a duplicate of this bug. ***
Comment 25 John N. Laliberte (RETIRED) gentoo-dev 2005-07-29 16:23:41 UTC
*** Bug 99429 has been marked as a duplicate of this bug. ***
Comment 26 John N. Laliberte (RETIRED) gentoo-dev 2005-08-06 04:43:42 UTC
*** Bug 100523 has been marked as a duplicate of this bug. ***
Comment 27 Mike Gardiner (RETIRED) gentoo-dev 2005-09-24 05:09:32 UTC
*** Bug 107075 has been marked as a duplicate of this bug. ***
Comment 28 John N. Laliberte (RETIRED) gentoo-dev 2005-09-30 06:24:56 UTC
*** Bug 107700 has been marked as a duplicate of this bug. ***
Comment 29 Brian Harring gentoo-dev 2005-10-08 05:16:57 UTC
Re-opening.

As a general rule of thumb, we don't leave landmines (known failings) in the
tree to try and get others to fix it (yes that's rude and presumptious also).

If it doesn't work, restrict the bugger so that those who want it to work for
those packages do the work, rather then those who do testing getting bit in the
ass by it.
Comment 30 Benno Schulenberg 2005-10-11 11:23:53 UTC
One more request for RESTRICT="test" on ebuilds where the tests don't work.
Comment 31 Mike Gardiner (RETIRED) gentoo-dev 2005-11-01 01:31:06 UTC
*** Bug 110891 has been marked as a duplicate of this bug. ***
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2006-01-11 13:26:45 UTC
*** Bug 118688 has been marked as a duplicate of this bug. ***
Comment 33 Saleem Abdulrasool (RETIRED) gentoo-dev 2006-01-21 23:06:24 UTC
Add libbonoboui to that list.  It fails with access to /root/.gnome2_private
Comment 34 Attila Stehr 2006-01-23 16:04:51 UTC
still present with file-roller-2.12.2


Making check in help
make[1]: Entering directory `/var/tmp/portage/file-roller-2.12.2/work/file-roller-2.12.2/help'
xmllint --noout --noent --path C:./C --xinclude --postvalid ./C/file-roller.xml
./C/file-roller.xml:92: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./C/file-roller.xml:141: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./C/file-roller.xml does not validate
xmllint --noout --noent --path de:./de --xinclude --postvalid ./de/file-roller.xml
./de/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./de/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./de/file-roller.xml does not validate
xmllint --noout --noent --path es:./es --xinclude --postvalid ./es/file-roller.xml
./es/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./es/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
./es/file-roller.xml:480: element para: validity error : Element xef is not declared in para list of possible children
./es/file-roller.xml:480: element xef: validity error : No declaration for element xef
./es/file-roller.xml:480: element xef: validity error : No declaration for attribute linkend of element xef
Document ./es/file-roller.xml does not validate
xmllint --noout --noent --path fr:./fr --xinclude --postvalid ./fr/file-roller.xml
./fr/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./fr/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./fr/file-roller.xml does not validate
xmllint --noout --noent --path it:./it --xinclude --postvalid ./it/file-roller.xml
./it/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./it/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./it/file-roller.xml does not validate
xmllint --noout --noent --path ja:./ja --xinclude --postvalid ./ja/file-roller.xml
./ja/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./ja/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./ja/file-roller.xml does not validate
xmllint --noout --noent --path ko:./ko --xinclude --postvalid ./ko/file-roller.xml
./ko/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./ko/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./ko/file-roller.xml does not validate
xmllint --noout --noent --path ru:./ru --xinclude --postvalid ./ru/file-roller.xml
./ru/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./ru/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./ru/file-roller.xml does not validate
xmllint --noout --noent --path sv:./sv --xinclude --postvalid ./sv/file-roller.xml
./sv/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./sv/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./sv/file-roller.xml does not validate
xmllint --noout --noent --path uk:./uk --xinclude --postvalid ./uk/file-roller.xml
./uk/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./uk/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./uk/file-roller.xml does not validate
xmllint --noout --noent --path zh_CN:./zh_CN --xinclude --postvalid ./zh_CN/file-roller.xml
./zh_CN/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./zh_CN/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./zh_CN/file-roller.xml does not validate
xmllint --noout --noent --path zh_HK:./zh_HK --xinclude --postvalid ./zh_HK/file-roller.xml
./zh_HK/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./zh_HK/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./zh_HK/file-roller.xml does not validate
xmllint --noout --noent --path zh_TW:./zh_TW --xinclude --postvalid ./zh_TW/file-roller.xml
./zh_TW/file-roller.xml:98: element revnumber: validity error : Element application is not declared in revnumber list of possible children
./zh_TW/file-roller.xml:147: element releaseinfo: validity error : Element application is not declared in releaseinfo list of possible children
Document ./zh_TW/file-roller.xml does not validate
make[1]: *** [check-doc-docs] Fehler 3
make[1]: Leaving directory `/var/tmp/portage/file-roller-2.12.2/work/file-roller-2.12.2/help'
make: *** [check-recursive] Fehler 1

!!! ERROR: app-arch/file-roller-2.12.2 failed.
Comment 35 Attila Stehr 2006-01-23 16:11:00 UTC
btw: 
I agree with Mr. Brian Harring! I think that tests are not implemented to annoy people but to point out possible problems. Maybe the failing tests help with finding a solution for other bugs - like (file-roller) bug #114780...
Comment 36 Saleem Abdulrasool (RETIRED) gentoo-dev 2006-01-24 13:38:34 UTC
The tests are not a major priority at this point.  We are planning on dealing with these soon though.
Comment 37 Attila Stehr 2006-01-24 16:04:39 UTC
ok =)
Comment 38 Brian Harring gentoo-dev 2006-01-25 04:01:32 UTC
(In reply to comment #36)
> The tests are not a major priority at this point.  We are planning on dealing
> with these soon though.
Dealing with 'em how though?

Foser's last decree was that they would be left as landmines; goes without saying that's a no go :)

RESTRICT="test" would at least keep the ebuilds functional, and not annoy people enough to disable test globally (since most don't know they can disable it per package via bashrc).
Comment 39 Attila Stehr 2006-01-25 04:11:41 UTC
Or simply alter make.conf an emerging the 'faulty' package manually...

I wouln't like test restricted since I usually assume that tests _are_ made. The next problem, which devs are making a list, kepping that list in their mind and reenable tests for new version?!

Anyway, please give (me) a link where the bashrc - thing is explained?
Comment 40 foser (RETIRED) gentoo-dev 2006-02-26 08:05:10 UTC
Adding restricts is like having your minesweepers only search the areas that are known landmine-free, in portage terms it's like disabling sandbox, because there's a sandbox violation.

If you really want to run tests, then you should be able to assume the tests actually get run, whatever their outcome is.
Comment 41 John N. Laliberte (RETIRED) gentoo-dev 2006-03-30 18:34:18 UTC
*** Bug 100523 has been marked as a duplicate of this bug. ***
Comment 42 John N. Laliberte (RETIRED) gentoo-dev 2006-03-30 18:34:45 UTC
*** Bug 126643 has been marked as a duplicate of this bug. ***
Comment 43 Jakub Moc (RETIRED) gentoo-dev 2006-04-07 00:07:11 UTC
*** Bug 129079 has been marked as a duplicate of this bug. ***
Comment 44 Jakub Moc (RETIRED) gentoo-dev 2006-05-06 23:06:01 UTC
*** Bug 132523 has been marked as a duplicate of this bug. ***
Comment 45 SpanKY gentoo-dev 2006-05-06 23:55:51 UTC
so how does duping all the broken packages to this bug help ?

it's a tracker, not a dupe dump
Comment 46 Jakub Moc (RETIRED) gentoo-dev 2006-05-07 03:19:42 UTC
*** Bug 132523 has been marked as a duplicate of this bug. ***
Comment 47 Daniel Gryniewicz (RETIRED) gentoo-dev 2006-07-15 13:42:28 UTC
*** Bug 140221 has been marked as a duplicate of this bug. ***
Comment 48 Jakub Moc (RETIRED) gentoo-dev 2006-07-31 15:57:58 UTC
*** Bug 142347 has been marked as a duplicate of this bug. ***
Comment 49 Kevin F. Quinn (RETIRED) gentoo-dev 2006-08-09 12:16:15 UTC
Created attachment 93862 [details, diff]
Modify src_test() for gnome2 packages to use a temporary home directory

This is a start.  Many gnome packages get upset when the tests are run because they try to access the default gnome home directory, ~/.gnome2.  Obviously this isn't a good idea.  Setting GNOME22_USER_DIR overrides this default; the patch implements a tweaked src_test() in gnome2.eclass as I figure it won't hurt to do this for all gnome packages; it's likely they all do the same thing.

This gets gnome-vfs-2.14.2 to pass its tests with a vanilla compiler (fails with the hardened compiler because the test makefile misses out some link dependencies on the test executables, but I'll deal with that another time).
Comment 50 Brant Gurganus 2006-08-09 13:28:00 UTC
I haven't tested it since I'm at work, but that looks reasonable to me Kevin. It is probably worth suggesting that upstream since if the tests ever do any modification of user directory state, they shouldn't mess with the *real* user directory state.
Comment 51 Abraham Marin Perez 2006-11-09 03:48:55 UTC
I've encountered a bug that _I believe_ is not listed here yet nor it is related with the gnome-home directory issue; if so, I'm sorry. 

The problem is in gnome-base/gnome-libs-1.4.2, the failing test being metadata.test. The given error message:

make[3]: Entering directory `/var/tmp/portage/gnome-libs-1.4.2/work/gnome-libs-1.4.2/test-suite'
FAIL: metadata.test
PASS: parse-path.test
PASS: skel.test
PASS: split.test
PASS: trigs.test
===================
1 of 5 tests failed
===================
make[3]: *** [check-TESTS] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-libs-1.4.2/work/gnome-libs-1.4.2/test-suite'
make[2]: *** [check-am] Error 2
make[2]: Leaving directory `/var/tmp/portage/gnome-libs-1.4.2/work/gnome-libs-1.4.2/test-suite'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-libs-1.4.2/work/gnome-libs-1.4.2/test-suite'
make: *** [check-recursive] Error 1

####################
emerge --info

Portage 2.1.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.5-r2, 2.6.17-gentoo-r4 i686)
=================================================================
System uname: 2.6.17-gentoo-r4 i686 AMD Athlon(tm) XP 1700+
Gentoo Base System version 1.12.6
Last Sync: Wed, 08 Nov 2006 09:50:01 +0000
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.3.5-r2, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.8.1-r1, 2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon-xp"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=athlon-xp"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict stricter test"
GENTOO_MIRRORS="http://ftp.caliu.info/pub/gentoo/ http://mirror.ovh.net/gentoo-distfiles/"
LANG="es_ES.UTF-8@euro"
LC_ALL="es_ES.UTF-8@euro"
LINGUAS="es en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 acpi alsa apache2 asf audiofile avi bash-completion bidi bitmap-fonts bzip2 bzlib canna cdr cjk cli cracklib crypt cups dbus dga directfb divx4linux dlloader doc dri dvb dvd dvdr dvdread eds elibc_glibc emboss encode esd evo exif fbcon fftw firefox flac foomaticdb freewnn ftp gb gcj gd gdbm gif glut gmp gnome gpm gstreamer gtk gtk2 gtkhtml hal iconv imlib input_devices_evdev input_devices_keyboard input_devices_mouse iodbc isdnlog java jikes jpeg kde kernel_linux libg++ libwww linguas_en linguas_es mad memlimit mikmod mime mmx motif mozilla mp3 mpeg msn nas nls nptl nptlonly nsplugin nvidia odbc offensive ogg oggvorbis openal opengl pam pcre pdflib perl png pnp posix ppds pppd qt3 qt4 quicktime readline reflection sdl session sharedmem simplexml spell spl ssl svg svga sysvipc szip tcltk tcpd tetex theora threads tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU video_cards_nvidia videos vorbis win32codecs wmf x86 xine xml xorg xprint xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Comment 52 Dustin Polke 2006-12-11 08:53:11 UTC
Here is another one: gnome-python-desktop-2.16.0

Dies with the following output:

Making check in tests
make[1]: Entering directory `/var/tmp/portage/gnome-python-desktop-2.16.0/work/gnome-python-desktop-2.16.0/tests'
make  check-local
make[2]: Entering directory `/var/tmp/portage/gnome-python-desktop-2.16.0/work/gnome-python-desktop-2.16.0/tests'
Trying to import module gnomeapplet...  ok.
Trying to import module gnomeprint...  ok.
Trying to import module gnomeprint.ui...  ok.
Trying to import module gtksourceview...  ok.
Trying to import module wnck...  ok.
Trying to import module totem.plparser...  ok.
Trying to import module gtop...  ok.
Trying to import module nautilusburn... 
Traceback (most recent call last):
  File "./runtests.py", line 6, in ?
    import common
  File "/var/tmp/portage/gnome-python-desktop-2.16.0/work/gnome-python-desktop-2.16.0/tests/common.py", line 32, in ?
    __import__(module) # try to import the module to catch undefined symbols
ImportError: libnautilus-burn.so.3: cannot open shared object file: No such file or directory
make[2]: *** [check-local] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-python-desktop-2.16.0/work/gnome-python-desktop-2.16.0/tests'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/var/tmp/portage/gnome-python-desktop-2.16.0/work/gnome-python-desktop-2.16.0/tests'
make: *** [check-recursive] Error 1

emerge --info follows as attachment.

BR,
Dustin
Comment 53 Dustin Polke 2006-12-11 08:54:10 UTC
Created attachment 103812 [details]
emerge --info
Comment 54 Pacho Ramos gentoo-dev 2011-04-24 23:03:19 UTC
This bug can be closed now as we will use "TESTFAILURE" from now