Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 285715 - [FEATURES=test failure] gnome-base/nautilus-2.26.3 fails tests
Summary: [FEATURES=test failure] gnome-base/nautilus-2.26.3 fails tests
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome-tests gnome2.26
  Show dependency tree
 
Reported: 2009-09-20 15:58 UTC by Patrick Lauer
Modified: 2009-10-28 22:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2009-09-20 15:58:40 UTC
make  check-TESTS
make[4]: Entering directory `/var/tmp/portage/gnome-base/nautilus-2.26.3/work/nautilus-2.26.3/src'
Xlib:  extension "RANDR" missing on display ":1.0".

Eel-WARNING **: GConf error:
  Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
aborting...
./check-nautilus: line 2: 24346 Aborted                 ./nautilus --check --g-fatal-warnings
FAIL: check-nautilus
=========================================================================
1 of 1 tests failed
Please report to http://bugzilla.gnome.org/enter_bug.cgi?product=nautilus
=========================================================================
make[4]: *** [check-TESTS] Error 1
make[4]: Leaving directory `/var/tmp/portage/gnome-base/nautilus-2.26.3/work/nautilus-2.26.3/src'
make[3]: *** [check-am] Error 2
make[3]: Leaving directory `/var/tmp/portage/gnome-base/nautilus-2.26.3/work/nautilus-2.26.3/src'
make[2]: *** [check-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/nautilus-2.26.3/work/nautilus-2.26.3/src'
make[1]: *** [check] Error 2
make[1]: Leaving directory `/var/tmp/portage/gnome-base/nautilus-2.26.3/work/nautilus-2.26.3/src'
make: *** [check-recursive] Error 1
 *
 * ERROR: gnome-base/nautilus-2.26.3 failed.


Portage 2.2_rc41 (default/linux/amd64/2008.0, gcc-4.4.1, glibc-2.10.1-r0, 2.6.30-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r1-x86_64-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-gentoo-2.0.1
Timestamp of tree: Unknown
app-shells/bash:     4.0_p33
dev-lang/python:     2.6.2-r1, 3.1.1
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.3/env /usr/kde/4.3/share/config /usr/kde/4.3/shutdown /usr/kde/4.4/env /usr/kde/4.4/share/config /usr/kde/4.4/shutdown /usr/kde/live/env /usr/kde/live/share/config /usr/kde/live/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests buildpkg distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://localhost/gentoo-portage"
USE="X acl amd64 berkdb bzip2 cli cracklib crypt cups dri fortran gcj gdbm gpm iconv ipv6 isdnlog mmx mudflap multilib ncurses nls nptl nptlonly objc openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl sysfs tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Romain Perier (RETIRED) gentoo-dev 2009-09-20 17:14:57 UTC
Could you give the output of the following command line ? : 
$ pgrep -lu $USER gconfd-2
Comment 2 Patrick Lauer gentoo-dev 2009-09-20 17:24:50 UTC
(In reply to comment #1)
> Could you give the output of the following command line ? : 
> $ pgrep -lu $USER gconfd-2
> 

That's empty. 
Comment 3 Romain Perier (RETIRED) gentoo-dev 2009-09-20 17:39:24 UTC
Okay(In reply to comment #2)
> (In reply to comment #1)
> > Could you give the output of the following command line ? : 
> > $ pgrep -lu $USER gconfd-2
> > 
> 
> That's empty. 
> 

Okay the problem is these testsuites need to have a GConf daemon started to be executed correctly (apparently).

Could you try to start /usr/libexec/gconfd-2 (in user) and try the testsuite again ?

@herd: This problem is annoying in case where nautilus is merged on a non-GNOME environment without gconf running, like fluxbox or fvwm if the user wants to use nautilus as filemanager (I've a doubt but theorically nautilus should work even if gconf isn't running ? I meant it could use default settings ?)
Comment 4 Romain Perier (RETIRED) gentoo-dev 2009-09-20 17:42:22 UTC
(In reply to comment #3)
> 
> Could you try to start /usr/libexec/gconfd-2 (in user) and try the testsuite
> again ?
>

It's just an idea for now, but it builds just fine here with gconf running...


Comment 5 Gilles Dartiguelongue gentoo-dev 2009-10-28 22:05:18 UTC
I ran the testsuite in a chroot logging in as root via ssh so it could not access the gconf from my user, unless it's doing something mystical, testsuite worked just fine. I'm pushing changes to fix bug #246136 in a minute without a bump, could you retry when you get those changes ?