Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 100523 - [FEATURES=test failure] gnome-base/eel-2.14.3
Summary: [FEATURES=test failure] gnome-base/eel-2.14.3
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 125094 150707 (view as bug list)
Depends on:
Blocks: gnome-tests
  Show dependency tree
 
Reported: 2005-07-27 15:19 UTC by Drake Wyrm
Modified: 2010-03-27 23:44 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drake Wyrm 2005-07-27 15:19:00 UTC
While updating gnome-base/eel from 2.10.0 to 2.10.1, I received the following
error during the test phase:

>>> Test phase [enabled]: gnome-base/eel-2.10.1
>>> Test phase [check]: gnome-base/eel-2.10.1
Making check in eel
make[1]: Entering directory `/var/tmp/portage/eel-2.10.1/work/eel-2.10.1/eel'
make  check-TESTS
make[2]: Entering directory `/var/tmp/portage/eel-2.10.1/work/eel-2.10.1/eel'
Could not set mode 0700 on private per-user gnome configuration directory
`/root/.gnome2_private/': Permission denied
FAIL: check-eel
===================
1 of 1 tests failed
===================
make[2]: *** [check-TESTS] Error 1
make[2]: Leaving directory `/var/tmp/portage/eel-2.10.1/work/eel-2.10.1/eel'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/var/tmp/portage/eel-2.10.1/work/eel-2.10.1/eel'
make: *** [check-recursive] Error 1

I don't think any of my `emerge --info` info is relevant; let me know if I'm wrong.
Comment 1 Attila Stehr 2005-08-03 10:11:51 UTC
same here
Comment 2 John N. Laliberte (RETIRED) gentoo-dev 2005-08-06 04:43:42 UTC

*** This bug has been marked as a duplicate of 69343 ***
Comment 3 Drake Wyrm 2005-10-08 10:07:19 UTC
Please add RESTRICT=test to ebuild if no other solution seems likely.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-03-05 08:58:58 UTC
*** Bug 125094 has been marked as a duplicate of this bug. ***
Comment 5 John N. Laliberte (RETIRED) gentoo-dev 2006-03-30 18:34:18 UTC

*** This bug has been marked as a duplicate of 69343 ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-10-10 11:12:04 UTC
*** Bug 150707 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-01-08 23:06:43 UTC
Reopen.
Comment 8 Gilles Dartiguelongue gentoo-dev 2007-06-13 13:53:17 UTC
Updating title wrt to duplicates

in reply to comment #3, I think the current resolution in gnome herd is to not hide potential bugs but fix them upstream. We don't always necessary time to fix test though.

@dang, anything to add ?
Comment 9 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-06-13 16:33:56 UTC
Anyone is, of course, free to fix tests.  But we don't have a policy of fixing them, because we just wouldn't have time.  If bugs get patches, we'll definitely apply them and push them upstream.
Comment 10 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-06-13 20:38:52 UTC
Okay, tests now pass on 2.18.0.1.