Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 478252 (gnome-3.8-stable) - Stabilize Gnome 3.8
Summary: Stabilize Gnome 3.8
Status: RESOLVED DUPLICATE of bug 499954
Alias: gnome-3.8-stable
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal enhancement with 3 votes (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
: 334427 416489 463350 473112 473890 476364 478262 478272 479322 481886 481888 481908 481910 482058 483196 488740 490030 490678 491484 491486 493644 (view as bug list)
Depends on: gnome3-upgrade-guide 405173 424637 447354 450086 450174 454388 464572 466560 gcc-4.7-stable 468150 470402 470512 471752 473736 473890 473998 python-3.3-stable 475480 476100 478082 478104 478258 478260 478262 478264 478268 478270 478272 478274 478476 478904 479322 479918 479986 480028 480066 480172 480270 480336 480908 481824 481828 481886 481888 481890 481892 481894 481896 481898 481900 481904 481906 481908 481910 481916 481920 482056 482538 482886 483196 483250 485658 486278 486476 486602 487344 487748 488512 488738 488754 488756 488760 488764 488768 488770 488774 488782 488784 488786 488790 488792 488796 488800 488802 488804 488806 488808 488810 488908 490030 490122 491420 491444 492796
Blocks: 416489 440866 450236 463844 467378 482332 CVE-2013-2190 498930
  Show dependency tree
 
Reported: 2013-07-26 17:17 UTC by Pacho Ramos
Modified: 2014-04-05 10:46 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnome-list (gnome-list,29.73 KB, text/plain)
2013-10-21 17:47 UTC, Pacho Ramos
Details
Updated list (gnome-list,31.04 KB, text/plain)
2013-11-17 10:51 UTC, Pacho Ramos
Details
Updated list (gnome-list,30.94 KB, text/plain)
2013-11-23 18:28 UTC, Pacho Ramos
Details
Updated list (gnome-list,30.84 KB, text/plain)
2013-11-30 18:28 UTC, Pacho Ramos
Details
block report (block,7.17 KB, text/plain)
2013-12-11 02:51 UTC, Raymond Jennings
Details
block report 2 (block2,15.21 KB, text/plain)
2013-12-11 02:51 UTC, Raymond Jennings
Details
Updated list (-r1) (gnome-list.txt,30.84 KB, text/plain)
2013-12-27 21:14 UTC, Pacho Ramos
Details
Updated list (-r2) (attachment.cgi?id=366328,30.84 KB, text/plain)
2014-01-19 20:03 UTC, Pacho Ramos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2013-07-26 17:17:05 UTC
This is for tracking purposes to start asking for stabilization of needed packages (that are a lot)
Comment 1 Alexander Tsoy 2013-07-27 11:50:33 UTC
This bug should also depend on bug 475480
Comment 2 Pacho Ramos gentoo-dev 2013-08-01 19:05:46 UTC
*** Bug 334427 has been marked as a duplicate of this bug. ***
Comment 3 Pacho Ramos gentoo-dev 2013-08-19 08:25:34 UTC
@gnome team, I need your help about how to handle bug 478764 and 281523 -> vapier keeps closing them as INVALID but it will cause openrc being pulled for depcleaning but that packages getting broken because they need it at RDEPEND
Comment 4 Justin Lecher gentoo-dev 2013-08-21 12:53:21 UTC
Which arches are targeted in this stabilization?
Comment 5 Pacho Ramos gentoo-dev 2013-08-21 13:13:26 UTC
It depends on each package, what package are you interested in?
Comment 6 Justin Lecher gentoo-dev 2013-08-21 13:27:16 UTC
(In reply to Pacho Ramos from comment #5)
> It depends on each package, what package are you interested in?

Shotwell
Comment 7 Pacho Ramos gentoo-dev 2013-08-22 07:02:11 UTC
Same as gnome-base/gnome-extra-apps
Comment 8 Pacho Ramos gentoo-dev 2013-08-25 07:44:32 UTC
*** Bug 463350 has been marked as a duplicate of this bug. ***
Comment 9 Pacho Ramos gentoo-dev 2013-08-27 07:45:11 UTC
(In reply to Pacho Ramos from comment #3)
> @gnome team, I need your help about how to handle bug 478764 and 281523 ->
> vapier keeps closing them as INVALID but it will cause openrc being pulled
> for depcleaning but that packages getting broken because they need it at
> RDEPEND

Was finally included in system set by Ulm :)
Comment 10 Pacho Ramos gentoo-dev 2013-10-21 17:25:07 UTC
*** Bug 488740 has been marked as a duplicate of this bug. ***
Comment 11 Pacho Ramos gentoo-dev 2013-10-21 17:47:14 UTC
Created attachment 361550 [details]
gnome-list

First attempt
Comment 12 Pacho Ramos gentoo-dev 2013-10-21 18:59:00 UTC
*** Bug 478262 has been marked as a duplicate of this bug. ***
Comment 13 Pacho Ramos gentoo-dev 2013-10-21 18:59:14 UTC
*** Bug 478272 has been marked as a duplicate of this bug. ***
Comment 14 Pacho Ramos gentoo-dev 2013-10-21 18:59:36 UTC
*** Bug 479322 has been marked as a duplicate of this bug. ***
Comment 15 Pacho Ramos gentoo-dev 2013-10-21 18:59:53 UTC
*** Bug 481886 has been marked as a duplicate of this bug. ***
Comment 16 Pacho Ramos gentoo-dev 2013-10-21 19:00:10 UTC
*** Bug 481888 has been marked as a duplicate of this bug. ***
Comment 17 Pacho Ramos gentoo-dev 2013-10-21 19:00:47 UTC
*** Bug 482058 has been marked as a duplicate of this bug. ***
Comment 18 Pacho Ramos gentoo-dev 2013-10-21 19:01:11 UTC
*** Bug 481908 has been marked as a duplicate of this bug. ***
Comment 19 Pacho Ramos gentoo-dev 2013-10-21 19:01:29 UTC
*** Bug 481910 has been marked as a duplicate of this bug. ***
Comment 20 Pacho Ramos gentoo-dev 2013-10-21 19:01:44 UTC
*** Bug 483196 has been marked as a duplicate of this bug. ***
Comment 21 Pacho Ramos gentoo-dev 2013-11-16 12:46:01 UTC
*** Bug 490030 has been marked as a duplicate of this bug. ***
Comment 22 Pacho Ramos gentoo-dev 2013-11-17 10:44:47 UTC
*** Bug 491484 has been marked as a duplicate of this bug. ***
Comment 23 Pacho Ramos gentoo-dev 2013-11-17 10:51:26 UTC
Created attachment 363398 [details]
Updated list
Comment 24 Pacho Ramos gentoo-dev 2013-11-17 10:52:31 UTC
*** Bug 491486 has been marked as a duplicate of this bug. ***
Comment 25 Justin Lecher gentoo-dev 2013-11-17 11:13:10 UTC
*** Bug 473890 has been marked as a duplicate of this bug. ***
Comment 26 Pacho Ramos gentoo-dev 2013-11-23 18:28:56 UTC
Created attachment 363842 [details]
Updated list

More updated list
Comment 27 Pacho Ramos gentoo-dev 2013-11-23 18:29:58 UTC
Arches, please test and stabilize Gnome 3.8

Remember to make the stabilizations blocking this one before of course ;)

Thanks
Comment 28 Pacho Ramos gentoo-dev 2013-11-23 18:30:39 UTC
*** Bug 473112 has been marked as a duplicate of this bug. ***
Comment 29 Pacho Ramos gentoo-dev 2013-11-23 18:30:55 UTC
*** Bug 476364 has been marked as a duplicate of this bug. ***
Comment 30 Pacho Ramos gentoo-dev 2013-11-23 18:31:17 UTC
*** Bug 490678 has been marked as a duplicate of this bug. ***
Comment 31 Steev Klimaszewski gentoo-dev 2013-11-26 03:48:14 UTC
At this point in time,  I can't reliably run Gnome 3 on the Samsung Chromebook.  There are numerous issues, and I am going to start from scratch again soon on it, but for now, I can't, in good faith, mark gnome3 and it's dependencies as stable.  Sorry.

I'll leave the ARM team CC'd in case someone else wants to give it a try, and they can feel free to ping me on IRC or via email if they run into issues.
Comment 32 Pacho Ramos gentoo-dev 2013-11-29 21:07:16 UTC
*** Bug 416489 has been marked as a duplicate of this bug. ***
Comment 33 Pacho Ramos gentoo-dev 2013-11-30 18:28:27 UTC
Created attachment 364284 [details]
Updated list

(gnome-applets is not for 3.8)
Comment 34 Pacho Ramos gentoo-dev 2013-11-30 20:40:57 UTC
amd64 stable
Comment 35 b1254633 2013-12-01 00:14:36 UTC
awesome! when for x86?
Comment 36 Pacho Ramos gentoo-dev 2013-12-01 08:13:30 UTC
The gnome stuff was tested by me also on x86 without issues, but not all the other stuff this bug "depends on"... then, until someone is able to test it on x86 too (I can only access a x86 machine from time to time :/)
Comment 37 Andreas K. Hüttel gentoo-dev 2013-12-06 22:34:11 UTC
Sigh... the harfbuzz update broke libreoffice-bin. Any ETA for x86?
Comment 38 Pacho Ramos gentoo-dev 2013-12-07 08:24:20 UTC
(In reply to Andreas K. Hüttel from comment #37)
> Sigh... the harfbuzz update broke libreoffice-bin. Any ETA for x86?

I am working on it (but my x86 machine is a slower compiling :S)
Comment 39 Kyle Sanderson 2013-12-07 21:16:06 UTC
(In reply to Pacho Ramos from comment #34)
> amd64 stable

dev-libs/glib-2.36.4-r1 requires a couple masked packages. As such, without unmasking, I've been unable to update my server.

=dev-libs/libffi-3.0.13-r1 ~amd64
# required by dev-lang/python-2.7.5-r3
# required by dev-vcs/git-1.8.3.2-r1[python,python_single_target_python2_7]
# required by app-portage/layman-2.0.0[git]
# required by @selected
# required by @world (argument)
=virtual/libffi-3.0.13-r1 ~amd64
# required by dev-libs/glib-2.36.4-r1
# required by glib (argument)
=virtual/libiconv-0-r1 ~amd64

I'm not sure if there are other packages, but at least a group weren't updated.
Comment 40 Jeroen Roovers gentoo-dev 2013-12-08 16:50:26 UTC
*** Bug 493644 has been marked as a duplicate of this bug. ***
Comment 41 Pacho Ramos gentoo-dev 2013-12-08 17:15:25 UTC
(In reply to Kyle Sanderson from comment #39)
> (In reply to Pacho Ramos from comment #34)
> > amd64 stable
> 
> dev-libs/glib-2.36.4-r1 requires a couple masked packages. As such, without
> unmasking, I've been unable to update my server.

repoman sees not such problem at all, maybe the message from portage is misleading or you are unmasking the new multilib abi USE flags
Comment 42 Pacho Ramos gentoo-dev 2013-12-08 20:15:03 UTC
x86 stable
Comment 43 Kyle Sanderson 2013-12-08 22:15:51 UTC
(In reply to Pacho Ramos from comment #41)
> repoman sees not such problem at all, maybe the message from portage is
> misleading or you are unmasking the new multilib abi USE flags

portage is probably misleading me. However, I'm using x32, so maybe that has impacted some of the masked selections. Regardless, in truth I have no idea as to why these newer versions are apparently required.
Comment 44 Joakim Tjernlund 2013-12-10 00:11:28 UTC
Our company is not ready to move to Gnome 3 this quickly.
We would appriciate a gnome3 mask file and that gnome2 stay in
gentoo for some time(months).
Is this feasible ?
Comment 45 Raymond Jennings 2013-12-10 02:59:25 UTC
Whoa, I'm on x86 and I just got a bunch of slot conflicts.

Could someone double check this one?
Comment 46 Pacho Ramos gentoo-dev 2013-12-10 22:25:04 UTC
(In reply to Kyle Sanderson from comment #43)
> (In reply to Pacho Ramos from comment #41)
> > repoman sees not such problem at all, maybe the message from portage is
> > misleading or you are unmasking the new multilib abi USE flags
> 
> portage is probably misleading me. However, I'm using x32, so maybe that has
> impacted some of the masked selections. Regardless, in truth I have no idea
> as to why these newer versions are apparently required.

That is because you are using the stable.masked x86 multilib support and, then, it's normal portage asks you to unmask more packages than people running only stable
Comment 47 Raymond Jennings 2013-12-11 02:51:31 UTC
Created attachment 365088 [details]
block report

requested by tomwij
Comment 48 Raymond Jennings 2013-12-11 02:51:56 UTC
Created attachment 365090 [details]
block report 2
Comment 49 Ben Kohler gentoo-dev 2013-12-11 03:09:09 UTC
(In reply to shentino from comment #45)
> Whoa, I'm on x86 and I just got a bunch of slot conflicts.
> 
> Could someone double check this one?

It conflicts with the current stable lightdm-1.4.0-r2[introspection].  This will be fixed when 1.8.5 goes stable in bug #492796.

If anyone else has problems emerging gnome, you should probably see one of our support venues (forums, irc, etc) or report a new bug.  Commenting in this bug is not the right place.
Comment 50 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-12-11 11:08:33 UTC
(In reply to shentino from comment #47)
> requested by tomwij

Was meant to go on IRC; but, this indeed seems like something that could block upgrades which I don't see anything about in the http://wiki.gentoo.org/wiki/GNOME/3.8-upgrade-guide which might perhaps be covered in the line where a lot of packages are removed.
Comment 51 Jeroen Roovers gentoo-dev 2013-12-22 16:33:10 UTC
Stable for HPPA.
Comment 52 Pacho Ramos gentoo-dev 2013-12-27 21:14:07 UTC
Created attachment 366328 [details]
Updated list (-r1)

Updated list with gnome-shell revision fixing a security bug
Comment 53 Pacho Ramos gentoo-dev 2014-01-19 20:03:50 UTC
Created attachment 368190 [details]
Updated list (-r2)
Comment 54 Pacho Ramos gentoo-dev 2014-01-26 09:39:23 UTC
(Enough packages were already stabilized in most arches including systemd unit files)
Comment 55 Pacho Ramos gentoo-dev 2014-02-16 15:17:21 UTC
Other option would be to stop stabilizing most of gnome package on remaining arches... but I doubt what exact packages should still be stabilized there apart of basic things like gtk+/glib/gobject-introspection :/
Comment 56 Pacho Ramos gentoo-dev 2014-03-08 15:57:41 UTC
Remaining arches, please jump directly to 3.10

*** This bug has been marked as a duplicate of bug 499954 ***