Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 478904 - =sys-apps/portage-2.2.1 stable request
Summary: =sys-apps/portage-2.2.1 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 478320 479062 482942
Blocks: 472632 gnome-3.8-stable
  Show dependency tree
 
Reported: 2013-07-30 20:13 UTC by Pacho Ramos
Modified: 2013-09-28 21:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2013-07-30 20:13:27 UTC
This is for tracking purposes as we need to make sure we have a newer enough portage version to fix bug 478188, feel free to CC arches when you prefer
Comment 1 Paul Varner (RETIRED) gentoo-dev 2013-07-30 21:11:24 UTC
From a tools-portage perspective, we have to fix/stablize the tools to work with this version of portage and the repos.conf changes.

The tools-portage team is low on resources to do this quickly right now, so any and all help is appreciated.
Comment 2 Zac Medico gentoo-dev 2013-07-31 01:29:17 UTC
(In reply to Paul Varner from comment #1)
> From a tools-portage perspective, we have to fix/stablize the tools to work
> with this version of portage and the repos.conf changes.

I've updated the ebuilds to automatically generate a make.conf PORTDIR="/usr/portage" backward compatibility setting. It shows like a normal CONFIG_PROTECT update that the user will be able to apply via etc-update or dispatch-conf.
Comment 3 Zac Medico gentoo-dev 2013-07-31 04:31:21 UTC
Also, see bug 479062 for catalyst make.conf patch.
Comment 4 boxcars 2013-08-21 01:30:01 UTC
I see portage-2.1.13.2 is removed from the tree.  Is the plan now to stabilize 2.2.0 without any more 2.1.x stabilizations?
Comment 5 Zac Medico gentoo-dev 2013-08-21 01:53:16 UTC
(In reply to boxcars from comment #4)
> I see portage-2.1.13.2 is removed from the tree.  Is the plan now to
> stabilize 2.2.0 without any more 2.1.x stabilizations?

Yes, well actually I want to do a 2.2.1 release and stabilize that, because of bug 481628.
Comment 6 Zac Medico gentoo-dev 2013-08-22 04:54:13 UTC
Actually, bug 481628 was not really a regression, so we're not waiting on that. However bug 480736 is a regression, and it's now fixed in 2.2.1.
Comment 7 Zac Medico gentoo-dev 2013-09-03 03:00:06 UTC
@arch teams:

Please stabilize sys-apps/portage-2.2.1, but first stabilize app-portage/eix-0.29.3 if you haven't already (bug 482942).

Bug #472632 tracks bugs fixed since 2.1.12.2. It's possible that some users will experience some minor snags involving the new userpriv (bug 477664) and usersync (bug 477682) FEATURES defaults, but the upgrade should be smooth for most users. If you don't have userpriv enabled yet, and you have lots of "live" sources in $DISTDIR, then pkg_postinst may consume a lot of time adjusting ownership of files in $DISTDIR.
Comment 8 Jeroen Roovers gentoo-dev 2013-09-04 16:00:14 UTC
Stable for HPPA.
Comment 9 Jeff (JD) Horelick (RETIRED) gentoo-dev 2013-09-07 17:57:37 UTC
x86 stable
Comment 10 Markus Meier gentoo-dev 2013-09-08 09:57:08 UTC
arm stable
Comment 11 Agostino Sarubbo gentoo-dev 2013-09-08 11:53:02 UTC
Before try to keyword I update the entire gentoo-x86 and I get:

   sys-apps/portage/portage-2.2.1.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['virtual/pypy:1.9', 'dev-lang/python:3.1']
Comment 12 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-09-08 12:46:28 UTC
(In reply to Agostino Sarubbo from comment #11)
> Before try to keyword I update the entire gentoo-x86 and I get:
> 
>    sys-apps/portage/portage-2.2.1.ebuild: DEPEND:
> amd64(default/linux/amd64/13.0) ['virtual/pypy:1.9', 'dev-lang/python:3.1']

I've committed a fix for this. Though, as long as portage is going to inline parts of the eclasses, issues like this are going to arise every time we change the list of supported implementations, and possibly other internals.
Comment 13 Agostino Sarubbo gentoo-dev 2013-09-08 12:47:57 UTC
amd64 stable
Comment 14 Agostino Sarubbo gentoo-dev 2013-09-12 18:59:55 UTC
ppc64 stable
Comment 15 Agostino Sarubbo gentoo-dev 2013-09-14 07:42:45 UTC
ia64 stable
Comment 16 Agostino Sarubbo gentoo-dev 2013-09-14 10:56:48 UTC
alpha stable
Comment 17 Agostino Sarubbo gentoo-dev 2013-09-23 19:18:00 UTC
sparc stable
Comment 18 Agostino Sarubbo gentoo-dev 2013-09-25 17:23:15 UTC
ppc stable
Comment 19 Agostino Sarubbo gentoo-dev 2013-09-28 20:46:12 UTC
SH is not anymore a stable arch, removing it from the cc list
Comment 20 Agostino Sarubbo gentoo-dev 2013-09-28 20:49:12 UTC
S390 is not anymore a stable arch, removing it from the cc list
Comment 21 Agostino Sarubbo gentoo-dev 2013-09-28 20:56:16 UTC
M68K is not anymore a stable arch, removing it from the cc list