Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 478188 - <dev-lang/vala-0.20.0 is blocking dev-libs/gobject-introspection-1.36.0 and portage doesn't resolve the block
Summary: <dev-lang/vala-0.20.0 is blocking dev-libs/gobject-introspection-1.36.0 and p...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 300071 gnome3-upgrade-guide 472632 480736
  Show dependency tree
 
Reported: 2013-07-26 00:37 UTC by tman
Modified: 2014-10-12 03:40 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2013-07-26 00:37:17 UTC
[blocks B     ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-51.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/icu-49:0/51.1= required by (dev-qt/qtcore-4.8.5::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/raptor-2.0.9::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-qt/qtwebkit-4.8.5::gentoo, installed)
    dev-libs/icu:0/51.1= required by (sys-apps/gptfdisk-0.8.6::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-qt/qtcore-5.1.0::qt, installed)
    dev-libs/icu:0/51.1= required by (media-libs/libcdr-0.0.14::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/libvisio-0.0.30::gentoo, installed)
    dev-libs/icu:0/51.1= required by (games-simulation/openttd-1.3.1::gentoo, installed)
    dev-libs/icu:0/51.1= required by (app-text/libmspub-0.0.6::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-libs/libxml2-2.9.1-r1::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/harfbuzz-0.9.18-r1::gentoo, installed)
    (and 3 more with the same problems)

  (dev-libs/icu-51.1::gentoo, installed) pulled in by
    >=dev-libs/icu-49:0/51.1= required by (dev-qt/qtcore-4.8.5::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/raptor-2.0.9::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-qt/qtwebkit-4.8.5::gentoo, installed)
    dev-libs/icu:0/51.1= required by (sys-apps/gptfdisk-0.8.6::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-qt/qtcore-5.1.0::qt, installed)
    dev-libs/icu:0/51.1= required by (media-libs/libcdr-0.0.14::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/libvisio-0.0.30::gentoo, installed)
    dev-libs/icu:0/51.1= required by (games-simulation/openttd-1.3.1::gentoo, installed)
    dev-libs/icu:0/51.1= required by (app-text/libmspub-0.0.6::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-libs/libxml2-2.9.1-r1::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/harfbuzz-0.9.18-r1::gentoo, installed)
    (and 3 more with the same problems)

  (dev-libs/icu-51.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)



 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-1.36.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-0.10.1 required by (dev-libs/libpeas-1.6.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.7::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-206::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (app-crypt/gcr-3.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (dev-libs/libgdata-0.13.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (dev-libs/libdbusmenu-0.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.10.2-r300::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.20.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-3.2.6-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (dev-lua/lgi-0.6.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.6.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-glib-0.20.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.0-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.1.1 required by (dev-python/pygobject-3.4.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (media-libs/babl-0.1.10-r1::lokal, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.20::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.14.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.3 required by (dev-libs/libunique-1.1.6-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (dev-libs/libunique-3.0.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-3.2.6-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.40.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.34.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.7::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.20-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.6.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (app-i18n/ibus-1.5.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (dev-libs/libindicate-12.10.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.111::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.2-r1::gentoo, installed)

  (dev-lang/vala-0.18.1::gentoo, installed) pulled in by
    dev-lang/vala:0.18[vapigen] required by (net-libs/telepathy-glib-0.20.3::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (net-libs/gssdp-0.14.3::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (dev-libs/libindicate-12.10.1::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (net-libs/gupnp-0.20.3::gentoo, installed)
    dev-lang/vala:0.18 required by (dev-util/geany-plugins-1.23::lokal, installed)
    dev-lang/vala:0.18[vapigen] required by (dev-libs/libdbusmenu-0.6.2::gentoo, installed)


Reproducible: Always




Portage 2.1.12.13 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.10.2-gentoo x86_64)
=================================================================
System uname: Linux-3.10.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-3740QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    24695284 total,  22565544 free
KiB Swap:   25081852 total,  25081852 free
Timestamp of tree: Fri, 26 Jul 2013 00:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r1, 3.2.5-r1, 3.3.2-r1
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r5::gnome
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo nikai poly-c luman qt Techwolf science mva emacs flameeyes-overlay mpd wirelay ruby alice gnome mgorny scarabeus lokal
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/X11/Sessions/awesome /etc/X11/Sessions/dwm /etc/conf.d/consolefont /etc/conf.d/hostname /etc/conf.d/hwclock /etc/conf.d/keymaps /etc/default/grub /etc/eix-sync.conf /etc/fstab /etc/hosts /etc/locale.gen /etc/make.conf /etc/timezone /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
Comment 1 Ștefan Talpalaru 2013-07-26 16:11:33 UTC
I'm getting the same thing on ~amd64 without the gnome overlay. The workaround is to "emerge -1 vala" in order to install the "0.20" slot. After that, the block disappears.
Comment 2 Aaron Pelton 2013-07-27 12:59:41 UTC
(In reply to Stefan Talpalaru from comment #1)
> I'm getting the same thing on ~amd64 without the gnome overlay. The
> workaround is to "emerge -1 vala" in order to install the "0.20" slot. After
> that, the block disappears.

I was having the same problem and this worked for me.
Comment 3 Pacho Ramos gentoo-dev 2013-07-28 20:23:52 UTC
(In reply to Stefan Talpalaru from comment #1)
> I'm getting the same thing on ~amd64 without the gnome overlay. The
> workaround is to "emerge -1 vala" in order to install the "0.20" slot. After
> that, the block disappears.

CCing portage team as I don't know why it's unable to try to update vala to resolve the blockers
Comment 4 Zac Medico gentoo-dev 2013-07-28 20:41:09 UTC
(In reply to Pacho Ramos from comment #3)
> CCing portage team as I don't know why it's unable to try to update vala to
> resolve the blockers

It can't because of all these deps on the dev-lang/vala:0.18 slot, shown in comment #0:

  (dev-lang/vala-0.18.1::gentoo, installed) pulled in by
    dev-lang/vala:0.18[vapigen] required by (net-libs/telepathy-glib-0.20.3::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (net-libs/gssdp-0.14.3::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (dev-libs/libindicate-12.10.1::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (net-libs/gupnp-0.20.3::gentoo, installed)
    dev-lang/vala:0.18 required by (dev-util/geany-plugins-1.23::lokal, installed)
    dev-lang/vala:0.18[vapigen] required by (dev-libs/libdbusmenu-0.6.2::gentoo, installed)
Comment 5 Pacho Ramos gentoo-dev 2013-07-28 20:54:07 UTC
But all of them are using vala.eclass, letting them to use slots equal or newer than 0.18. Maybe it's because of the way vala.eclass handles this :/
Comment 6 Pacho Ramos gentoo-dev 2013-07-28 20:55:39 UTC
One way to handle this better could be to add a "vala" USE flag to gnome-core-libs pulling in vala:0.20
Comment 7 Zac Medico gentoo-dev 2013-07-28 21:31:29 UTC
With deps like || ( dev-lang/vala:0.20[ dev-lang/vala:0.18 ), if some other package has a hard dep on vala:0.18, it will cause other packages to also pull in vala:0.18 instead of vala:0.20. For example, the whole problem could be due to bad dependencies of that dev-util/geany-plugins-1.23::lokal from the lokal overlay. You can check the deps like this:

  portageq metadata / ebuild ev-util/geany-plugins-1.23::lokal DEPEND RDEPEND
Comment 8 Zac Medico gentoo-dev 2013-07-28 21:46:28 UTC
I'm having the same problem locally, and all of the packages appear to have the || ( dev-lang/vala:0.20 dev-lang/vala:0.18 ) deps. It's like a new case of bug 264434.
Comment 9 Zac Medico gentoo-dev 2013-07-28 21:57:57 UTC
Workaround: emerge --unmerge dev-lang/vala:0.18
Comment 10 Pacho Ramos gentoo-dev 2013-07-28 22:00:55 UTC
Or install :0.20 slot, no? Or does it have any problem?
Comment 11 Zac Medico gentoo-dev 2013-07-28 22:02:40 UTC
(In reply to Pacho Ramos from comment #10)
> Or install :0.20 slot, no? Or does it have any problem?

Yeah, that will probably work.
Comment 12 Zac Medico gentoo-dev 2013-07-29 08:27:47 UTC
The reason for this bug is that portage's || dependency evaluation logic organizes atom choices into bins, and the dev-lang/vala:0.18 atom choice go into a preferred bin when vala:0.18 is installed, even though the dev-lang/vala:0.20 choice represents an available upgrade.

In order to solve this problem, it seems like the logic needs to account for options such as --deep and --update, and use them to decide whether or not it would be appropriate to treat vala:0.20 as the preferred choice.
Comment 14 Zac Medico gentoo-dev 2013-07-30 07:07:04 UTC
This is fixed in 2.1.13.2 and 2.2.0_alpha191.