Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447354 - =x11-libs/cairo-1.12.14-r4 stable request
Summary: =x11-libs/cairo-1.12.14-r4 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 430214 436356 448562
Blocks: 446952 gnome-3.8-stable
  Show dependency tree
 
Reported: 2012-12-15 13:25 UTC by Vicente Olivert Riera (RETIRED)
Modified: 2013-09-21 08:22 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gtkdocize.out (gtkdocize.out,212 bytes, text/plain)
2013-08-27 03:00 UTC, Joe M
Details
build log (x11-libs:cairo-1.12.14-r4:20130827-024512.log,2.81 KB, text/x-csrc)
2013-08-27 03:01 UTC, Joe M
Details
emerge --info (emerge--info.out,27.01 KB, text/plain)
2013-08-27 03:26 UTC, Joe M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vicente Olivert Riera (RETIRED) gentoo-dev 2012-12-15 13:25:21 UTC
Keywords for x11-libs/cairo:
          |                           | u   |  
          | a a             p     s   | n   |  
          | l m   h i m m   p s   p   | u s | r
          | p d a p a 6 i p c 3   a x | s l | e
          | h 6 r p 6 8 p p 6 9 s r 8 | e o | p
          | a 4 m a 4 k s c 4 0 h c 6 | d t | o
----------+---------------------------+-----+-------
1.12.8    | ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ ~ | o   | gentoo

Please stabilize =x11-libs/cairo-1.12.8, needed for the stabilization of =x11-wm/i3-4.3 on bug #446952

Target keywords: alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86
Comment 1 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-12-15 13:54:39 UTC
I'm sorry. Please, forget the above comment and go for =x11-libs/cairo-1.12.2-r4
Comment 2 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-12-15 15:32:22 UTC
Tested amd64: looks fine here.
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-15 15:35:18 UTC
I am against stabilizing cairo-1.12 at this time. Too many regressions still exist.
Comment 4 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-12-15 15:40:17 UTC
(In reply to comment #3)
> I am against stabilizing cairo-1.12 at this time. Too many regressions still
> exist.

Yes, this is a hard stabilization...

At least bug #429580 seems to be fixed on -r4

I will try the issue about invisible fonts on my iBook too...
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-15 15:46:15 UTC
Some 1.12 regressions were fixed in 1.12.8 (e.g. bug 441670), so any lower version should rather not be stabilized.
Comment 6 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-12-15 15:50:53 UTC
(In reply to comment #5)
> Some 1.12 regressions were fixed in 1.12.8 (e.g. bug 441670), so any lower
> version should rather not be stabilized.

We could go for 1.12.8 if you agree.
Comment 7 Ben de Groot (RETIRED) gentoo-dev 2012-12-16 06:54:15 UTC
We should go for 1.12.8 when all remaining issues have been addressed. I agree with Chí-Thanh that earlier 1.12.x versions are not to be considered stable candidates.
Comment 8 Vicente Olivert Riera (RETIRED) gentoo-dev 2012-12-17 10:06:55 UTC
#429580 not present on 1.12.8
#436356 not present on 1.12.8
Comment 9 Pacho Ramos gentoo-dev 2013-08-20 09:58:30 UTC
We will need at least 1.12.10 for Gnome 3.8. I am running 1.12.14-r2 without issues for a long time :/
Comment 10 Justin Snelgrove 2013-08-20 20:44:28 UTC
(In reply to Pacho Ramos from comment #9)
> We will need at least 1.12.10 for Gnome 3.8.

Firefox also needs something >1.12.8 to not segfault on exit (not sure exactly which version is minimum -- I went from 1.12.8 to 1.12.14). 1.12.14-r2 works perfectly for me as well (-r3 causes problems, as does -r4 if xlib-xcb is enabled).
Comment 11 Ben de Groot (RETIRED) gentoo-dev 2013-08-21 06:40:45 UTC
Arches please go ahead and mark stable:

=x11-libs/cairo-1.12.14-r4 alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86
=net-misc/nx-3.5.0.20-r1 amd64 x86
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-08-21 15:44:40 UTC
I dropped the nxserver bug 441878 from the list of dependencies.

Arches, please only stabilize
=x11-libs/cairo-1.12.14-r4 alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86
Comment 13 Agostino Sarubbo gentoo-dev 2013-08-23 09:01:57 UTC
amd64 stable
Comment 14 Agostino Sarubbo gentoo-dev 2013-08-23 09:12:20 UTC
x86 stable
Comment 15 Jeroen Roovers gentoo-dev 2013-08-23 13:07:55 UTC
Stable for HPPA.
Comment 16 Markus Meier gentoo-dev 2013-08-24 08:54:35 UTC
arm stable
Comment 17 Agostino Sarubbo gentoo-dev 2013-08-26 16:58:05 UTC
ppc stable
Comment 18 Joe M 2013-08-27 03:00:03 UTC
Created attachment 357140 [details]
gtkdocize.out
Comment 19 Joe M 2013-08-27 03:01:03 UTC
Created attachment 357142 [details]
build log
Comment 20 Joe M 2013-08-27 03:26:58 UTC
Created attachment 357144 [details]
emerge --info
Comment 21 Joe M 2013-08-27 03:28:06 UTC
cairo does not build. It appears to require the testing version of gtk-doc.

Attached are the logs.
Comment 22 Ben de Groot (RETIRED) gentoo-dev 2013-08-27 07:53:53 UTC
(In reply to Joe M from comment #21)
> cairo does not build. It appears to require the testing version of gtk-doc.
> 
> Attached are the logs.

That's a separate issue, for which you should file a separate bug. (And make sure to disable ccache before you do.)
Comment 23 Agostino Sarubbo gentoo-dev 2013-08-29 19:54:05 UTC
ia64 stable
Comment 24 Agostino Sarubbo gentoo-dev 2013-09-01 16:05:40 UTC
alpha stable
Comment 25 Agostino Sarubbo gentoo-dev 2013-09-05 10:46:57 UTC
ppc64 stable
Comment 26 Agostino Sarubbo gentoo-dev 2013-09-06 14:59:50 UTC
sparc stable
Comment 27 Pacho Ramos gentoo-dev 2013-09-21 08:22:03 UTC
That arches will go to testing only