Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 440866 - sys-apps/gnome-disk-utility, gnome-base/{gvfs,libgdu}: remove support for sys-fs/udisks:0 where possible
Summary: sys-apps/gnome-disk-utility, gnome-base/{gvfs,libgdu}: remove support for sys...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 465366 (view as bug list)
Depends on: 457568 gnome-3.8-stable gnome-3.10-stable gnome2-mask
Blocks: 439624
  Show dependency tree
 
Reported: 2012-11-01 23:49 UTC by Samuli Suominen
Modified: 2014-11-13 13:12 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2012-11-01 23:49:08 UTC
tracking whole UDisks1 -> UDisks2 migration of gvfs -> gnome-disk-utility -> libgdu ...

please punt :0 support in favour of :2. tracked at bug
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-11-02 05:20:17 UTC
We would need to:

* remove gnome-base/libgdu
* remove <sys-apps/gnome-disk-utility-3.4
* stabilize sys-apps/gnome-disk-utility-3.4.1
* remove <gnome-base/gvfs-1.12
* remove the gdu USE flag for gnome-base/gvfs and rox-base/rox-media

Pacho, do you foresee any problems with stabilizing gnome-disk-utility-3.4.1 and using it with gnome-2?

@rox, please migrate rox-media from gdu to udisks:2.
Comment 2 Pacho Ramos gentoo-dev 2012-11-05 21:04:59 UTC
udisks:2 won't work ok until recent udev is stabilized with it -> bug 417629

udev stabilization shouldn't take so long, WilliamH updated tracker and looks like there is no difficult bugs to fix (only pending stabilizations) -> bug 411627
Comment 3 Samuli Suominen gentoo-dev 2013-04-10 08:04:58 UTC
*** Bug 465366 has been marked as a duplicate of this bug. ***
Comment 4 Nikoli 2013-04-19 10:19:06 UTC
Not sure if gnome-disk-utility-3.4.1 is good for stable: it the first version ported to udisks2 and has major regression - no benchmarks. 3.6.1 has benchmarks again:
http://www.muktware.com/4081/gnome-disks-gets-major-overhaul
Comment 5 Alan Hourihane 2014-06-23 20:02:25 UTC
I can't emerge gnome at the moment, due to this error. And even specifying USE="udisks" emerge gnome results in the same problem.

This bug looks related.

!!! The ebuild selected to satisfy "gnome-base/gvfs" has unmet requirements.
- gnome-base/gvfs-1.18.3-r1::gentoo USE="cdda gtk http libsecret systemd udev -afp -archive -avahi (-bluetooth) (-bluray) -fuse (-gnome-online-accounts) -gphoto2 (-ios) (-mtp) -samba -test (-udisks)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    systemd? ( udisks )

  The above constraints are a subset of the following complete expression:
    cdda? ( udev ) udisks? ( udev ) systemd? ( udisks )

(dependency required by "app-cdr/brasero-2.32.1-r1" [ebuild])
(dependency required by "gnome-base/gnome-2.32.1-r2[cdr,dvdr]" [ebuild])
(dependency required by "gnome" [argument])
Comment 6 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-06-24 14:02:17 UTC
(In reply to Alan Hourihane from comment #5)
> !!! The ebuild selected to satisfy "gnome-base/gvfs" has unmet requirements.
> - gnome-base/gvfs-1.18.3-r1::gentoo USE="cdda gtk http libsecret systemd
> udev -afp -archive -avahi (-bluetooth) (-bluray) -fuse
> (-gnome-online-accounts) -gphoto2 (-ios) (-mtp) -samba -test (-udisks)"

This means udisks flag was package.use.masked for gnome-base/gvfs - either in your profile (because you are using sparc, where udisks doesn't work), or in your /etc/portage.

> (dependency required by "gnome-base/gnome-2.32.1-r2[cdr,dvdr]" [ebuild])

Gnome3 is stable and gnome2 is going to be removed from portage soon. Therefore, fixing gnome2 problems is basically not a priority for us; please update to gnome3, mate, or xfce.
Comment 7 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-06-24 14:27:35 UTC
(In reply to Alexandre Rostovtsev from comment #6)
> (In reply to Alan Hourihane from comment #5)
> > !!! The ebuild selected to satisfy "gnome-base/gvfs" has unmet requirements.
> > - gnome-base/gvfs-1.18.3-r1::gentoo USE="cdda gtk http libsecret systemd
> > udev -afp -archive -avahi (-bluetooth) (-bluray) -fuse
> > (-gnome-online-accounts) -gphoto2 (-ios) (-mtp) -samba -test (-udisks)"
> 
> This means udisks flag was package.use.masked for gnome-base/gvfs - either
> in your profile (because you are using sparc, where udisks doesn't work), or
> in your /etc/portage.

I now see the problem: udisks works on sparc and alpha since 2013, but we forgot to remove the flag mask from gvfs. Should be fixed now :)

+  24 Jun 2014; Alexandre Rostovtsev <tetromino@gentoo.org> package.use.mask:
+  Remove obsolete gvfs[udisks] mask (bug #412801 and #440866)
Comment 8 Pacho Ramos gentoo-dev 2014-11-13 13:12:51 UTC
remaining ebuilds should be ok now after the removal of old stuff