Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 411627 - [TRACKER] tasks to complete before =sys-fs/udev-197-r4 can be stabilized
Summary: [TRACKER] tasks to complete before =sys-fs/udev-197-r4 can be stabilized
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: udev maintainers
URL:
Whiteboard:
Keywords: Tracker
Depends on: 407959 409563 417629 419689 421839 udev-186 427776 429326 430482 434632 435072 435074 435756 441004 448792 448908 451128 452554 453494
Blocks: 452556
  Show dependency tree
 
Reported: 2012-04-11 19:13 UTC by William Hubbs
Modified: 2013-02-08 17:15 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Hubbs gentoo-dev 2012-04-11 19:13:29 UTC
All,

This bug is a tracker for things that need to be done before >=udev-182
can be stabilized.

I would prefer that no comments be put on this bug, but that we have
other bugs block this tracker. This way, everyone sees what needs to be
done before we can stabilize newer versions of udev.
Comment 1 Pacho Ramos gentoo-dev 2012-09-14 20:49:48 UTC
Looks like now the real blocker is bug 421839, but not sure how to proceed with it :(
Comment 2 William Hubbs gentoo-dev 2012-11-02 20:24:05 UTC
(In reply to comment #1)
> Looks like now the real blocker is bug 421839, but not sure how to proceed
> with it :(

That bug has been removed from the blockers for this tracker; it doesn't have any bearing on when we can stabilize the newer udev.
Comment 3 Samuli Suominen gentoo-dev 2012-12-12 11:24:17 UTC
I think bug 442384 is serious enough to block this one, as sys-apps/kmod should be capable of picking up both /usr/lib/modprobe.d and /lib/modprobe.d

Also changed target of stabilization to 196-r1
Comment 4 Samuli Suominen gentoo-dev 2013-01-26 21:56:36 UTC
*** Bug 450938 has been marked as a duplicate of this bug. ***
Comment 5 Kirill Elagin 2013-01-26 22:04:12 UTC
I'm sorry, is that something wrong with me or udev-197-r3 is being stable for at least a few days?
Comment 6 Samuli Suominen gentoo-dev 2013-01-26 22:11:39 UTC
(In reply to comment #5)
> I'm sorry, is that something wrong with me or udev-197-r3 is being stable
> for at least a few days?

Since udev-197-r3 is now stable on amd64/x86 and installs to / just like udev-171 installed, the path to modprobe.d is back to /lib/modprobe.d
So Comment #3 now moot.

So yes, new udev is being stabilized in bug 452556 and once it's done, udev-171 and module-init-tools leaves the tree. It's 197-r3 or higher or sys-fs/eudev if you need kernel older than 2.6.39. Otherwise there is no need to change.
Comment 7 Samuli Suominen gentoo-dev 2013-01-26 22:12:23 UTC
(In reply to comment #5)
> I'm sorry, is that something wrong with me or udev-197-r3 is being stable
> for at least a few days?

And re-read Comment #0 and lets stop talking here. Use http://forums.gentoo.org/ if you have move helpdesk questions. Thanks.