Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 421839 - missing /run directory?
Summary: missing /run directory?
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: LiveCD/DVD (show other bugs)
Hardware: All Linux
: Normal critical with 6 votes (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 436862 437224 437812 438008 438140 438454 439128 440714 444452 (view as bug list)
Depends on: 435756
Blocks: 361349 411627 438234
  Show dependency tree
 
Reported: 2012-06-18 20:04 UTC by Kevin Haddock
Modified: 2013-01-26 21:17 UTC (History)
23 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Haddock 2012-06-18 20:04:58 UTC
when booting the latest ppc version, it tries to create a /var/run directory which is merely symlinked back to "/" so it can't create that but then it doesn't have a valid directory to put whatever goes in there (lockfiles?) so many things end up not starting.

Perhaps a directory "/run" should be created with liberal permissions so the various programs that rely on it can access it.  Sure the directory creation will fail because of the symlink on r/o CDROM, but at least the subsequent programs shouldn't.

Reproducible: Always

Steps to Reproduce:
1. burn PPC minimal install
2. insert in drive
3. reboot computer (holding "c" as you do so for apple like mine)
Actual Results:  
bunch of errors and unstarted services

Expected Results:  
no errors and everything starts
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2012-06-19 13:55:31 UTC
The stages/autobuilds are a DIRECT representation of the status of the tree. You may have found an issue with baselayout or so. Please provide what version of the autobuild cd (and stage3?)
Comment 2 Kevin Haddock 2012-06-19 14:21:30 UTC
it does it while booting this, and you never get to stage 3

install-powerpc-minimal-20120617.iso
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-07-23 10:42:24 UTC
I confirm the same issue on an amd64 installcd built on my build box.

@base-system / @udev:

what package should be creating /run ? Should it be part of baselayout / udev / some other package?
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2012-07-24 14:00:32 UTC
(In reply to comment #3)
> I confirm the same issue on an amd64 installcd built on my build box.
> 
> @base-system / @udev:
> 
> what package should be creating /run ? Should it be part of baselayout /
> udev / some other package?

baselayout in pkg_postinst() wrt bug 361349:

	if use kernel_linux; then
		mkdir -p "${ROOT}"/run

[ ... ]
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-07-24 15:12:03 UTC
(In reply to comment #4)
> (In reply to comment #3)
> baselayout in pkg_postinst() wrt bug 361349:
> 
> 	if use kernel_linux; then
> 		mkdir -p "${ROOT}"/run
> 
> [ ... ]

This isn't working for the stages / cds. I also see we try to create /run from 2 different places:

grep "${ROOT}\"/run" $(portageq portdir)/sys-fs/udev/udev-*
/usr/portage/sys-fs/udev/udev-182-r2.ebuild:    mkdir -p "${ROOT}"/run
/usr/portage/sys-fs/udev/udev-182-r3.ebuild:    mkdir -p "${ROOT}"/run
/usr/portage/sys-fs/udev/udev-186.ebuild:       mkdir -p "${ROOT}"/run
/usr/portage/sys-fs/udev/udev-9999.ebuild:      mkdir -p "${ROOT}"/run

grep "/run" $(portageq portdir)/sys-apps/baselayout/baselayout-2.1-r1.ebuild
:              mkdir -p "${ROOT}"/run
:              if ! grep -qs "^tmpfs.*/run " "${ROOT}"/proc/mounts ; then
:                      ewarn "You should reboot the system now to get /run mounted with tmpfs!"
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2012-07-26 11:05:55 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > baselayout in pkg_postinst() wrt bug 361349:
> > 
> > 	if use kernel_linux; then
> > 		mkdir -p "${ROOT}"/run
> > 
> > [ ... ]
> 
> This isn't working for the stages / cds. 

why? the build scripts/tools remove empty directories or skip pkg_ phases or...?

> I also see we try to create /run from 2 different places:

well, everything using /run can create it on their own too, consider it sort of a fallback
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2012-08-11 17:11:14 UTC
any news?
Comment 8 Michael Weber (RETIRED) gentoo-dev 2012-08-24 07:51:09 UTC
(In reply to comment #6)
> well, everything using /run can create it on their own too, consider it sort
> of a fallback
I hit this problem running an dhcp client inside an fresh started livecd.
This client wanted to create /var/run/<pidfile> which failed, due to /var/run being symlinked to an non-existing /run.

So basically /var/run existed but was non-functional, dhcp client had no glue of /run being involved.

(In reply to comment #7)
> any news?
I saw this on install-powerpc-minimal-20120812.iso
Comment 9 Pacho Ramos gentoo-dev 2012-08-24 08:41:49 UTC
I don't understand why /run needs to be manually created with mkdir from baselayout ebuilds, shouldn't it be generated by baselayout  itself like other dirs (/media for example)? 

But looking to baselayout Makefile I see "/run" under KEEP_DIRS-Linux :/
Comment 10 SpanKY gentoo-dev 2012-08-24 15:52:38 UTC
(In reply to comment #9)

if you read the ebuild you'll see that the layout is only created when USE=build.  the manual `mkdir` is only there for people doing upgrades and not a full install (and hence USE=build will never be set again for them).
Comment 11 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-08-25 20:42:09 UTC
This seems to be working again for me in my build box:

$ tar tvf /home/release/buildroot/amd64-dev/builds/default/stage3-amd64-20120821.tar.bz2 | grep /run
drwxr-xr-x root/root         0 2012-08-21 18:45 ./run/
drwxr-xr-x root/root         0 2012-08-21 18:45 ./run/sepermit/
-rw-r--r-- root/root         0 2012-08-21 16:58 ./run/.keep


$ tar tvf /home/release/buildroot/amd64-dev/builds/hardened/stage3-amd64-hardened-20120821.tar.bz2 | grep /run
drwxr-xr-x root/root         0 2012-08-21 23:23 ./run/
drwxr-xr-x root/root         0 2012-08-21 23:23 ./run/sepermit/
-rw-r--r-- root/root         0 2012-08-21 21:20 ./run/.keep

I'll double check on poseidon as soon as I get a working catalyst version on it.
Comment 12 Michael Weber (RETIRED) gentoo-dev 2012-08-27 18:14:46 UTC
(In reply to comment #9)
> I don't understand why /run needs to be manually created with mkdir from
> baselayout ebuilds, shouldn't it be generated by baselayout  itself like
> other dirs (/media for example)? 
During ppc livecd bootup, OpenRC tries to create /var/run /var/lock, but they exist as broken links into non-existing /run{,/lock}.
Comment 13 William Hubbs gentoo-dev 2012-08-27 21:16:04 UTC
Baselayout should not be linking /var/run and /var/lock to /run yet.
There is a missing piece for this in OpenRC.

I'm not sure how this got into BaseLayout yet, but I think we should
reverse it.
/var/run and /var/lock should still be directories.
Comment 14 William Hubbs gentoo-dev 2012-08-27 21:20:32 UTC
 thought we couldn't do this until openrc has full tmpfiles.d support,
 and we do not have that completed yet.
Comment 15 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-02 08:27:20 UTC
(In reply to comment #11)
> This seems to be working again for me in my build box:
> 
> $ tar tvf
> /home/release/buildroot/amd64-dev/builds/default/stage3-amd64-20120821.tar.
> bz2 | grep /run
> drwxr-xr-x root/root         0 2012-08-21 18:45 ./run/
> drwxr-xr-x root/root         0 2012-08-21 18:45 ./run/sepermit/
> -rw-r--r-- root/root         0 2012-08-21 16:58 ./run/.keep

This is not about the stages, but the installation .iso files. I confirm the missing /run directory with install-amd64-minimal-20120917.iso
Comment 16 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-10-02 09:07:06 UTC
(In reply to comment #15)
> (In reply to comment #11)
> > This seems to be working again for me in my build box:
> > 
> > $ tar tvf
> > /home/release/buildroot/amd64-dev/builds/default/stage3-amd64-20120821.tar.
> > bz2 | grep /run
> > drwxr-xr-x root/root         0 2012-08-21 18:45 ./run/
> > drwxr-xr-x root/root         0 2012-08-21 18:45 ./run/sepermit/
> > -rw-r--r-- root/root         0 2012-08-21 16:58 ./run/.keep
> 
> This is not about the stages, but the installation .iso files. I confirm the
> missing /run directory with install-amd64-minimal-20120917.iso

Right. I've noticed yesterday that the installation cd doesn't have /run, but it does have /mnt/livecd/run. I suspect we're creating manually the contents of / on the livecd targets.
Comment 17 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-04 11:42:51 UTC
*** Bug 436862 has been marked as a duplicate of this bug. ***
Comment 18 Jack Morgan (RETIRED) gentoo-dev 2012-10-04 12:47:35 UTC
I've also noticed that /var/lib/misc is missing. This causes syslog-ng, gpm, rpcbind services to not start. I was able to create these two directories and start those services. ssh service still fails to start with a EC_KEY_new_by_curve_name error.
Comment 19 Ben Kohler gentoo-dev 2012-10-09 18:09:56 UTC
sshd failure reported separately here: https://bugs.gentoo.org/show_bug.cgi?id=437480
Comment 20 Dan Johnson 2012-10-09 18:15:28 UTC
*** Bug 437224 has been marked as a duplicate of this bug. ***
Comment 21 白川間瀬流 2012-10-10 06:40:11 UTC
Its impossible to follow the official Gentoo Install documentation using the recent amd64 CD and so not possible to install for newcomers.

This really needs to be fixed asap
Comment 22 白川間瀬流 2012-10-10 06:41:31 UTC
(In reply to comment #21)
> Its impossible to follow the official Gentoo Install documentation using the
> recent amd64 CD and so not possible to install for newcomers.
> 
> This really needs to be fixed asap

Sorry for double post

> Platform:	PPC Linux

this should be changed to amd64 as this also happens on amd64 and i think amd64 affects more the masses
Comment 23 gdsuper4 2012-10-10 07:00:17 UTC
I don't mean to be rude but shouldn't this bug receive more attention? In the current state it's a completely hopeless task trying to install gentoo using the official cds.
Comment 24 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-10-10 14:31:06 UTC
We're aware of the bug and trying to fix it.
As far as I can see, somewhere during the run of livecd-stage2 target, catalyst picks the contents of livecd-stage1, that is based on stage3 and has /run, and creates a new /. This new / doesn't have /run.
This is open source, so if any of you wants to look at the catalyst code, feel free to do so[1]. If I knew the source of the issue, I would have fixed it by now.

 [1] - http://git.overlays.gentoo.org/gitweb/?p=proj/catalyst.git
Comment 25 Themsay 2012-10-10 17:08:44 UTC
As newbie to Gentoo. I having been trying install-amd64-minimal-20120917.iso for days now but it ain't doing well. Even try to use Systemrescuecd livecd after chroot, emerge --sync was unable to run left me with no choice than to go for official amd64-minimal cd from Gentoo mirrors.
Please, can anyone suggest any old amd64-minimal cd I can try as well because I'm fade-up of burning all my empty cds, or other third party livecd. All comment and suggestion is welcome. Thank you.
Comment 26 Dan Johnson 2012-10-10 17:15:01 UTC
For newbies to gentoo or other people stuck with a "bad" livecd with this issue, I have found that a workaround exists:

mkdir /run #make the missing directory
rc default #start the services that could not start due to missing /run

Hopefully this issue will be resolved soon, but I have found this to be only a minor inconvenience.
Comment 27 Pacho Ramos gentoo-dev 2012-10-10 18:04:36 UTC
(In reply to comment #26)
> For newbies to gentoo or other people stuck with a "bad" livecd with this
> issue, I have found that a workaround exists:
> 
> mkdir /run #make the missing directory
> rc default #start the services that could not start due to missing /run
> 

Maybe that services that need /run could create it when it's not present :/ What do you think?

For example dbus script creates /var/run/dbus when it's not present, that could be extended to create /run also

> Hopefully this issue will be resolved soon, but I have found this to be only
> a minor inconvenience.
Comment 28 Themsay 2012-10-12 10:18:24 UTC
(In reply to comment #26)
> For newbies to gentoo or other people stuck with a "bad" livecd with this
> issue, I have found that a workaround exists:
> 
> mkdir /run #make the missing directory

Where should I make this dir?

>
 rc default #start the services that could not start due to missing /run
> 
> Hopefully this issue will be resolved soon, but I have found this to be only
> a minor inconvenience.

Amd64 stage3-20120917 has a bug too.

If pro also complain about this bug. What next for newbies who want to try Gentoo out, end up loosing hope from what red from handbook.

Any thing in life new users basically can't use as described; is simply depreciate in popularity.
Comment 29 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-12 16:13:10 UTC
*** Bug 438140 has been marked as a duplicate of this bug. ***
Comment 30 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-12 16:13:26 UTC
*** Bug 438008 has been marked as a duplicate of this bug. ***
Comment 31 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-12 16:13:40 UTC
*** Bug 437812 has been marked as a duplicate of this bug. ***
Comment 32 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2012-10-12 16:14:47 UTC
(In reply to comment #24)
> We're aware of the bug and trying to fix it.
> As far as I can see, somewhere during the run of livecd-stage2 target,
> catalyst picks the contents of livecd-stage1, that is based on stage3 and
> has /run, and creates a new /. This new / doesn't have /run.
> This is open source, so if any of you wants to look at the catalyst code,
> feel free to do so[1]. If I knew the source of the issue, I would have fixed
> it by now.
> 
>  [1] - http://git.overlays.gentoo.org/gitweb/?p=proj/catalyst.git

CC-ing Catalyst team.
Comment 33 Alon Bar-Lev 2012-10-12 16:22:26 UTC
Amazing! livecd is broken for [at least] 4 months! This is the core of Gentoo installation. This the same as bug#437320 case... These trivial issues should be discussed after a solution is provided to users. And after a conclusion optionally provide a better solution.
Comment 34 Timothy Messier 2012-10-12 16:58:19 UTC
So I started looking into this when attempting to build a custom livecd. I noticed that /run exists in the tmp directory of catalyst after a livecd-stage1 build. I then looked in the tmp directory of the livecd-stage2 build, it was also still there, it is also in the build directory of the livecd-stage2. So I started looking into the final iso. I unpacked the squashfs, still have a /run. I unpacked the initrd also has a /run. Thus the last place to look is in the init in the initrd itself.

Around line 347 is where init handles creating NEW_ROOT if CDROOT is set:

if [ "${CDROOT}" = '1' ]
then
    good_msg "Making tmpfs for ${NEW_ROOT}"
    mount -n -t tmpfs tmpfs "${NEW_ROOT}"

    for i in dev mnt mnt/livecd mnt/key tmp tmp/.initrd mnt/gentoo sys
    do
        mkdir -p "${NEW_ROOT}/${i}"
        chmod 755 "${NEW_ROOT}/${i}"
    done

It seems that perphaps the init script needs to create ${NEW_ROOT}/run and mount a tmpfs one it (or perpahs not mount a tmpfs since ${NEW_ROOT} already is a tmpfs?

Or I may be completely wrong here as I am not very familiar with genkernel's inner workings.
Comment 35 Rick Farina (Zero_Chaos) gentoo-dev 2012-10-12 17:10:20 UTC
This is resolved in newer openrc which we are waiting to have marked stable.
Comment 36 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-10-13 04:32:35 UTC
(In reply to comment #33)
> Amazing! livecd is broken for [at least] 4 months! This is the core of
> Gentoo installation. This the same as bug#437320 case... These trivial
> issues should be discussed after a solution is provided to users. And after
> a conclusion optionally provide a better solution.

The two bugs have nothing in common. This is about a change in the base-system that was introduced during a period the weekly builds weren't running and thus was unnoticed. The other bug is about an issue with the new box that should be fixed now - I'll be doing a new build run in a bit to confirm that.

We were without stages and CDs for so long because of a change in the tree that required changes to catalyst. Those changes and a few other enhancements are now integrated into catalyst.
Comment 37 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-10-13 04:41:32 UTC
(In reply to comment #34)
> So I started looking into this when attempting to build a custom livecd. I
> noticed that /run exists in the tmp directory of catalyst after a
> livecd-stage1 build. I then looked in the tmp directory of the livecd-stage2
> build, it was also still there, it is also in the build directory of the
> livecd-stage2. So I started looking into the final iso. I unpacked the
> squashfs, still have a /run. I unpacked the initrd also has a /run. Thus the
> last place to look is in the init in the initrd itself.
> 
> Around line 347 is where init handles creating NEW_ROOT if CDROOT is set:
> 
> if [ "${CDROOT}" = '1' ]
> then
>     good_msg "Making tmpfs for ${NEW_ROOT}"
>     mount -n -t tmpfs tmpfs "${NEW_ROOT}"
> 
>     for i in dev mnt mnt/livecd mnt/key tmp tmp/.initrd mnt/gentoo sys
>     do
>         mkdir -p "${NEW_ROOT}/${i}"
>         chmod 755 "${NEW_ROOT}/${i}"
>     done
> 
> It seems that perphaps the init script needs to create ${NEW_ROOT}/run and
> mount a tmpfs one it (or perpahs not mount a tmpfs since ${NEW_ROOT} already
> is a tmpfs?
> 
> Or I may be completely wrong here as I am not very familiar with genkernel's
> inner workings.

Thank you for looking into this.
I had confirmed your results about livecd-stage{1,2}, but hadn't checked the initrd.

So this is caused by genkernel[1]

 [1] - http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=blob;f=defaults/linuxrc;h=d6766b883517b8c25c3fee07c7d6f4235748d843;hb=refs/heads/master

@genkernel:

Can you please fix the initrd to create /run?
Comment 38 Rick Farina (Zero_Chaos) gentoo-dev 2012-10-13 04:53:20 UTC
> 
> So this is caused by genkernel[1]
> 
>  [1] -
> http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=blob;
> f=defaults/linuxrc;h=d6766b883517b8c25c3fee07c7d6f4235748d843;hb=refs/heads/
> master
> 
For context, line 822 and 897 seem to create run but I don't see it in the context of NEWROOT. This may be an issue.
Comment 39 Alon Bar-Lev 2012-10-13 08:03:52 UTC
(In reply to comment #36)
> (In reply to comment #33)
> > Amazing! livecd is broken for [at least] 4 months! This is the core of
> > Gentoo installation. This the same as bug#437320 case... These trivial
> > issues should be discussed after a solution is provided to users. And after
> > a conclusion optionally provide a better solution.
> 
> The two bugs have nothing in common.

The common is that malformed stages/livecd is published as stable for download by users. If you know of major problems, revert the malformed ones and provide something that is working.

I don't remember this kind of issues not being fixed immediately.

What you expect of people trying to install Gentoo? To go over bugzilla issues to find workarounds? To wait for a few months until they can use the installation media?
Comment 40 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2012-10-13 09:18:43 UTC
(In reply to comment #38)
> > 
> > So this is caused by genkernel[1]
> > 
> >  [1] -
> > http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=blob;
> > f=defaults/linuxrc;h=d6766b883517b8c25c3fee07c7d6f4235748d843;hb=refs/heads/
> > master
> > 
> For context, line 822 and 897 seem to create run but I don't see it in the
> context of NEWROOT. This may be an issue.

line 822 creates /run in initramfs env.
line 897 creates /run in the real root.

However, by default, root is mounted ro, not rw, as it's NOT safe to create things on the filesystem until it's been fsck'd. You will find that dracut does this as well - as we don't want to have to include all the fsck stuff inside the initramfs (it would get big quickly).

The line 897 is there for users that have real_rootflags=rw or use zfs (where it defaults to rw) and need it to get fixed up.

genkernel is really NOT the tool that should be creating /run, because it's NOT safe to do so. It needs to be created on your systems during install. The stages also contain /run/.keep, so I don't know why y'all don't have /run on your filesystems.
Comment 41 Themsay 2012-10-13 10:31:13 UTC
I wonder if Gentoo Dev specifically Bugzilla even have the interest of new users at heart. Which should be the first and more important. 


Who knows thousands of new users that has ran away to try other distro, without clicking report issue. I see this as basic Gentoo installation and shouldn't fail for a very longtime, without appropriate documentation for new user on the Amd64 handbook about this issue.


I'm still waiting to see a stable Amd64-minimal-iso and his stage3. Not encouraging to create /run, /dev/console etc. Which I don't even know where to start because is total off the handbook.
Comment 42 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-10-13 12:42:52 UTC
(In reply to comment #40)

> line 822 creates /run in initramfs env.
> line 897 creates /run in the real root.
> 
> However, by default, root is mounted ro, not rw, as it's NOT safe to create
> things on the filesystem until it's been fsck'd. You will find that dracut
> does this as well - as we don't want to have to include all the fsck stuff
> inside the initramfs (it would get big quickly).
> 
> The line 897 is there for users that have real_rootflags=rw or use zfs
> (where it defaults to rw) and need it to get fixed up.
> 
> genkernel is really NOT the tool that should be creating /run, because it's
> NOT safe to do so. It needs to be created on your systems during install.
> The stages also contain /run/.keep, so I don't know why y'all don't have
> /run on your filesystems.

Robin,

if we update line 412 like the following, shouldn't that provide /run for the CD?

-for i in dev mnt mnt/livecd mnt/key tmp tmp/.initrd mnt/gentoo sys
+for i in dev mnt mnt/livecd mnt/key run tmp tmp/.initrd mnt/gentoo sys
Comment 43 Timothy Messier 2012-10-13 17:40:29 UTC
(In reply to comment #40)
> (In reply to comment #38)
> > > 
> > > So this is caused by genkernel[1]
> > > 
> > >  [1] -
> > > http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=blob;
> > > f=defaults/linuxrc;h=d6766b883517b8c25c3fee07c7d6f4235748d843;hb=refs/heads/
> > > master
> > > 
> > For context, line 822 and 897 seem to create run but I don't see it in the
> > context of NEWROOT. This may be an issue.
> 
> line 822 creates /run in initramfs env.
> line 897 creates /run in the real root.
> 
> However, by default, root is mounted ro, not rw, as it's NOT safe to create
> things on the filesystem until it's been fsck'd. You will find that dracut
> does this as well - as we don't want to have to include all the fsck stuff
> inside the initramfs (it would get big quickly).
> 
> The line 897 is there for users that have real_rootflags=rw or use zfs
> (where it defaults to rw) and need it to get fixed up.
> 
> genkernel is really NOT the tool that should be creating /run, because it's
> NOT safe to do so. It needs to be created on your systems during install.
> The stages also contain /run/.keep, so I don't know why y'all don't have
> /run on your filesystems.

The issue that I am seeing is in the LiveCD its self. Like I mentioned about the squashfs for the live cd *does* contain a /run. The squashfs is mounted to ${NEWROOT}/mnt/livecd so there is a ${NEWROOT}/mnt/livecd/run but it is not used. The line 897 does not seem to make the /run in the case of the livecd (not sure why...) but once the LiveCD boots there is no /run in the / that the initrd created. You are right that in general genkernel should not need to create /run as the stages will have it already, but the LiveCD is a different case.
Comment 44 William Hubbs gentoo-dev 2012-10-13 18:15:43 UTC
Yes, after reading over this bug, it sounds like the issue is in the live cd itself, not on users' filesystems or in the stages.
I also agree with Robin that genkernel shouldn't in general be creating /run in the real root fs.

@jmbsvisetto:
Baselayout *only* creates the /run directory if the build use flag is set when it is emerged. Off the top of my head, I'm guessing that catalyst, when it is building the live cd doesn't set the "build" use flag. If that is right, that is why /run isn't created on the live cd.
Comment 45 Timothy Messier 2012-10-13 18:18:51 UTC
(In reply to comment #44)
> Yes, after reading over this bug, it sounds like the issue is in the live cd
> itself, not on users' filesystems or in the stages.
> I also agree with Robin that genkernel shouldn't in general be creating /run
> in the real root fs.
> 
> @jmbsvisetto:
> Baselayout *only* creates the /run directory if the build use flag is set
> when it is emerged. Off the top of my head, I'm guessing that catalyst, when
> it is building the live cd doesn't set the "build" use flag. If that is
> right, that is why /run isn't created on the live cd.

The LiveCD catalyst builds *do* create the /run. /run is on the livecd-stage1 catalyst tmp directory, livecd-stage2, and the squashfs within the iso. It is only missing from the root that the initrd creates for the livecd.
Comment 46 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2012-10-13 18:36:07 UTC
I've just pushed commit 097e88f to genkernel creating the run directory you asked for, but I don't think it's going to help...

jmbsvicetto:
What version of genkernel are you bundling into the LiveCD as of 20120917? I ask because I extracted the linuxrc from the initramfs on it, and found that copy doesn't create ANY /run directories. We don't have a genkernel version tag in the output initramfs I see, so I'm going to add one and we'll know about why next time. /run support was added in v3.4.37.
Comment 47 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-10-15 11:57:52 UTC
*** Bug 438454 has been marked as a duplicate of this bug. ***
Comment 48 Timothy Messier 2012-10-15 13:59:24 UTC
(In reply to comment #46)
> I've just pushed commit 097e88f to genkernel creating the run directory you
> asked for, but I don't think it's going to help...
> 
> jmbsvicetto:
> What version of genkernel are you bundling into the LiveCD as of 20120917? I
> ask because I extracted the linuxrc from the initramfs on it, and found that
> copy doesn't create ANY /run directories. We don't have a genkernel version
> tag in the output initramfs I see, so I'm going to add one and we'll know
> about why next time. /run support was added in v3.4.37.

I was able to build a functional cd using the latest git (3.4.44.1). I did notice that I had been using the latest stable genkernel (3.4.24_p2), I will give 3.4.37 a try to see if it was already fixed by then.
Comment 49 Timothy Messier 2012-10-15 14:43:21 UTC
(In reply to comment #48)
> (In reply to comment #46)
> > I've just pushed commit 097e88f to genkernel creating the run directory you
> > asked for, but I don't think it's going to help...
> > 
> > jmbsvicetto:
> > What version of genkernel are you bundling into the LiveCD as of 20120917? I
> > ask because I extracted the linuxrc from the initramfs on it, and found that
> > copy doesn't create ANY /run directories. We don't have a genkernel version
> > tag in the output initramfs I see, so I'm going to add one and we'll know
> > about why next time. /run support was added in v3.4.37.
> 
> I was able to build a functional cd using the latest git (3.4.44.1). I did
> notice that I had been using the latest stable genkernel (3.4.24_p2), I will
> give 3.4.37 a try to see if it was already fixed by then.

Also worked with 3.4.37, so the change you added (commit 097e88f) was not needed. Simply using >=sys-kernel/genkernel-3.4.37. 

Note, using genkernel 3.4.37 requires using >sys-apps/openrc-0.9.9.
Comment 50 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-11-01 17:49:29 UTC
*** Bug 439128 has been marked as a duplicate of this bug. ***
Comment 51 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-11-01 17:56:05 UTC
*** Bug 440714 has been marked as a duplicate of this bug. ***
Comment 52 Robin Hunt 2012-11-02 16:34:05 UTC
(In reply to comment #49)
> (In reply to comment #48)
> > (In reply to comment #46)
> > > I've just pushed commit 097e88f to genkernel creating the run directory you
> > > asked for, but I don't think it's going to help...
> > > 
> > > jmbsvicetto:
> > > What version of genkernel are you bundling into the LiveCD as of 20120917? I
> > > ask because I extracted the linuxrc from the initramfs on it, and found that
> > > copy doesn't create ANY /run directories. We don't have a genkernel version
> > > tag in the output initramfs I see, so I'm going to add one and we'll know
> > > about why next time. /run support was added in v3.4.37.
> > 
> > I was able to build a functional cd using the latest git (3.4.44.1). I did
> > notice that I had been using the latest stable genkernel (3.4.24_p2), I will
> > give 3.4.37 a try to see if it was already fixed by then.
> 
> Also worked with 3.4.37, so the change you added (commit 097e88f) was not
> needed. Simply using >=sys-kernel/genkernel-3.4.37. 
> 
> Note, using genkernel 3.4.37 requires using >sys-apps/openrc-0.9.9.

So has this been fixed and as a newbee this is dishartening
Comment 53 William Hubbs gentoo-dev 2012-11-02 20:22:33 UTC
This bug is for release media, and it should not block bug #411627. This
has nothing to do with stabilizing udev. I am removing the blocker.
Comment 54 gdsuper4 2012-11-03 16:30:22 UTC
I guess gentoo is dead...
Comment 55 白川間瀬流 2012-11-03 17:15:04 UTC
(In reply to comment #54)
> I guess gentoo is dead...

lol for sure not ;)
Comment 56 David Coornaert 2012-11-06 07:52:20 UTC
Same story here,
minimal 64bit iso barely usable (20121013).
I confirm the /var/run issues already described
nano is broken (but vi is included, that's new no ?)
no way to get dhcpcd to work.

I rolled back to a June version and everything's fine
Comment 57 rop 2012-11-06 15:54:08 UTC
Try ssh or sshd its probably broken too...
Comment 58 Timothy Messier 2012-11-06 19:21:49 UTC
I have been able to build custom live-cds with functional /run by using >=sys-kernel/genkernel-3.4.37 in the catalyst build. Is there anything preventing this from being used in official live cd builds?
Comment 59 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-11-08 03:33:36 UTC
Just a heads up, the 20121107 ISO is also broken - no /run directory.
This version should be ok, so I'll have to check why it seems to be working on my build box, but not skimmer. I'll work on this tomorrow.
Comment 60 Massimo Burcheri 2012-11-27 13:24:49 UTC
*** Bug 444452 has been marked as a duplicate of this bug. ***
Comment 61 Zsolti 2012-12-09 12:11:17 UTC
I can confirm this with install-amd64-minimal-20121013.iso and install-amd64-minimal-20121107.iso via booting from an usb pen-drive installed on it via unetbootin.
From what I have read, it is the same with other installation methods and mediums like booting via CD/DVD.
This is really annoying and a show stopper. To summarize the problems of the this installation images:
- Missing directories like /run
- Problem with startin sshd
- nano not working, wrong lib linking

How can I help to resolve these.
Can newer releases (installation images) been built with catalyst?
Comment 62 Pacho Ramos gentoo-dev 2012-12-10 19:56:37 UTC
Should be fixed soon, sorry for the inconvenience:
https://bugs.gentoo.org/show_bug.cgi?id=441004#c5
Comment 63 Richard Yao (RETIRED) gentoo-dev 2012-12-16 05:00:59 UTC
(In reply to comment #62)
> Should be fixed soon, sorry for the inconvenience:
> https://bugs.gentoo.org/show_bug.cgi?id=441004#c5

This is partly my fault for falling behind on bug mail. With that said, I don't think this is a genkernel bug. I am reassigning it to the Gentoo Release Team.
Comment 64 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-12-16 06:01:08 UTC
(In reply to comment #63)
> (In reply to comment #62)
> > Should be fixed soon, sorry for the inconvenience:
> > https://bugs.gentoo.org/show_bug.cgi?id=441004#c5
> 
> This is partly my fault for falling behind on bug mail. With that said, I
> don't think this is a genkernel bug. I am reassigning it to the Gentoo
> Release Team.

This was a genkernel "bug" as it wasn't creating the required /run directory.
In any case, a "fixed" version of genkernel has been marked stable and the latest CDs have this issue fixed.
Comment 65 bretagus 2013-01-20 12:36:01 UTC
FYI the fix has not been added to the PPC install disk.

For anyone else trying, if you delete / remake the following directories:
rm -rf (directory)
mkdir (directory)
/var/lock 
/var/run 
/var/mail 
/var/lib/misc 

then check rc-status and restart anything that crashed
e.g. /etc/init.d/syslog-ng start

For me, gpm, syslog-ng and dhcpcd had to be restarted. autoconfig was also stopped, though I couldn't figure out how to get it back up.

http://forums.gentoo.org/viewtopic-t-938278.html is a helpful thread
Comment 66 Pacho Ramos gentoo-dev 2013-01-20 12:39:55 UTC
(In reply to comment #65)
> FYI the fix has not been added to the PPC install disk.
> 

Probably because fixed genkernel version was stabilized later for ppc