Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 359595 (linux-headers-2.6.38)

Summary: [TRACKER] Packages that fail to compile against sys-kernel/linux-headers-2.6.38
Product: Gentoo Linux Reporter: Samuli Suominen <ssuominen>
Component: Current packagesAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED FIXED    
Severity: normal CC: axiator, defuebr, doug.hunley, gentoo, helmut, M4rkusXXL, Marc-Antoine, neonkowy, nikoli, tetromino, zioalex
Priority: Normal Keywords: Tracker
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 359409, 359491, 359513, 359599, 359647, 359735, 359743, 359745, 359747, 359773, 359791, 359793, 360871, 360875, 360967, 361107, 361509, 361581, 361585, 361705, 361709, 361943, 362543, 362601, 362993, 363201, 363469, 363505, 364669, 364821, 364843, 364845, 365255, 365683, 367085, 368921, 369701, 370417, 376443, 396635    
Bug Blocks: 384733    

Description Samuli Suominen gentoo-dev 2011-03-20 10:10:34 UTC
No talking here. 
If you have a package failing, file a new bug and make it block this one.

I guess the most common failure is this:

error: linux/videodev.h: No such file or directory

Because of v4lv1 removal in favour of v4lv2.
Comment 1 Samuli Suominen gentoo-dev 2011-04-04 20:50:14 UTC
*** Bug 361965 has been marked as a duplicate of this bug. ***
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-04-10 05:39:25 UTC
Note: packages that need to use v4l and don't have any support for v4l2 can probably be patched to use media-libs/libv4l, which provides a userspace v4l1 emulation library (libv4l1-videodev.h, libv4l1.so, libv4l1.pc) for accessing v4l2 devices.
Comment 3 Samuli Suominen gentoo-dev 2011-10-02 12:06:09 UTC
I've reviewed all the bugs here and opened stablization reqs to block bug 384733. 

I think we can close this one soon.