Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 361965 - removal of v4l1 from linux-headers-2.6.38 breaks packages
Summary: removal of v4l1 from linux-headers-2.6.38 breaks packages
Status: RESOLVED DUPLICATE of bug 359595
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-04 20:47 UTC by Guy
Modified: 2011-04-04 20:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guy 2011-04-04 20:47:25 UTC
Several packages fail with this message:

v4l.h:43:28: fatal error: linux/videodev.h: No such file or directory

See bug# 359491  -- mjpegtools
See bug# 361943  -- lives

mjpegtools has a patch you can manually install to get around this. However, this is probably something which needs to be fixed upstream for various packages.

I suspect all packages which depend on mjpegtools will also break in a simular fashion. I tested this supposition on 'lives' and on 'kino' and received the same missing 'videodev.h' message as from mjpegtools.

Adding

>-sys-kernel/linux-headers-2.6.38

to /etc/portage/package.mask (locally masking this version of linus-headers and higher) eliminated the problem.

# equery d mjpegtools
 * These packages depend on mjpegtools:

media-plugins/kipi-plugins-1.9.0 (mjpeg ? media-video/mjpegtools)
media-video/2mandvd-1.4 (media-video/mjpegtools)
media-video/cinelerra-20101104 (media-video/mjpegtools)
media-video/kino-1.3.3 (media-video/mjpegtools)
media-video/lives-1.3.3 (>=media-video/mjpegtools-1.6.2)
media-video/ripmake-1.39 (>=media-video/mjpegtools-1.6.0-r7)
media-video/transcode-1.1.5-r2 (mjpeg ? media-video/mjpegtools)
media-video/videotrans-1.6.0 (media-video/mjpegtools)
Comment 1 Samuli Suominen gentoo-dev 2011-04-04 20:50:14 UTC
no kidding... try searching the bugzilla first...

*** This bug has been marked as a duplicate of bug 359595 ***