Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363469 - media-video/setpwc fails to build with linux-headers 2.6.38
Summary: media-video/setpwc fails to build with linux-headers 2.6.38
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick Kursawe (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: linux-headers-2.6.38
  Show dependency tree
 
Reported: 2011-04-13 10:38 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2011-06-09 11:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (setpwc-1.2:20110412-211639.log,1.51 KB, text/plain)
2011-04-13 10:38 UTC, Diego Elio Pettenò (RETIRED)
Details
Patch to convert setpwc from V4L1 to V4L2 (setpwc-1.2-convert_to_v4l2.patch,9.66 KB, patch)
2011-05-21 16:51 UTC, Bruno
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-04-13 10:38:49 UTC
Created attachment 269793 [details]
Build log

Portage 2.1.9.45 (default/linux/x86/10.0, gcc-4.6.0-asneeded, glibc-2.13-r2, 2.6.38.2 i686)
=================================================================
System uname: Linux-2.6.38.2-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.2
Timestamp of tree: Thu, 07 Apr 2011 11:00:01 +0000
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.6.0
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.wheel.sk/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree"
PORTDIR_OVERLAY=""
SYNC="rsync://yamato.home.flameeyes.eu/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 java5 java6 modules mudflap mysql ncurses nls nostatic nptl nptlonly openmp pam pcre pcsc-lite perl postgres pppd python qt3support readline ruby session ssl sysfs tcpd unicode vhosts x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest cgi" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 jruby ruby19 ree18" USERLAND="GNU" VIDEO_CARDS="intel radeon nouveau vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Tolga Dalman 2011-04-13 10:40:45 UTC
I get the same error with gcc-4.5.2. Thus, this is not a blocker for gcc-4.6.
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2011-04-13 10:46:00 UTC
Gha, thanks Tolga, I got the wrong blocker by force of habit.
Comment 3 Bruno 2011-05-21 10:23:15 UTC
Looks like the issue is that setpwc is still using V4L1 API which is being deprecated. Probably would need porting to V4L2 (kernel driver was converted to V4L2 last summer/fall)
Comment 4 Bruno 2011-05-21 16:51:15 UTC
Created attachment 274211 [details, diff]
Patch to convert setpwc from V4L1 to V4L2

Patch to make setpwc compile against recent linux-headers, including those that drop linux/videodev.h include (and thus support for compiling V4L-1 programs)

This patch replaces V4L-1 ioctls with appropriate V4L2 ioctls and changes include from linux/videodev.h to linux/videodev2.h.


Note: did minor runtime testing against 2.6.39 kernel, no idea if it works as expected against older kernels where pwc driver is still V4L1 based.
Comment 5 orionbelt2 2011-05-25 09:59:14 UTC
Many thanks for the patch, Bruno! I hope it works, and no doubt you must have gotten yourself lots of tree-hugs, it would have been horrible having to throw away a perfectly working webcam because of this (even though its specs are outdated by now, but that's OK for the occasional use, and isn't Linux supposed to be great for running older hardware...) :)

I hope someone looks into this soon and removes media-video/setpwc from package.mask to spare us the annoying message every time we update world :)
Comment 6 Bruno 2011-05-28 10:33:47 UTC
FYI: my patch or a variant of it has been applied upstream and a new version released there.

Please consider bumping setpwc to 1.3 to resolve this bug!
Comment 7 Samuli Suominen gentoo-dev 2011-06-09 11:10:06 UTC
1.3 in Portage, thanks guys.  Also unmasked now.