Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 359735 - media-libs/libdc1394-2.1.2 will not compile against linux-headers 2.6.38 due to V4L1 removal
Summary: media-libs/libdc1394-2.1.2 will not compile against linux-headers 2.6.38 due ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal with 4 votes (vote)
Assignee: Stefaan De Roeck (RETIRED)
URL:
Whiteboard:
Keywords:
: 359739 361825 (view as bug list)
Depends on:
Blocks: linux-headers-2.6.38
  Show dependency tree
 
Reported: 2011-03-21 12:25 UTC by Billy DeVincentis
Modified: 2011-05-29 21:46 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed patch, just does not compile the examples anymore (disable-examples.patch,3.14 KB, patch)
2011-03-25 23:16 UTC, Stefaan De Roeck (RETIRED)
Details | Diff
build log for dbus (dbus.txt,46.52 KB, text/plain)
2011-03-27 16:43 UTC, blain 'Doc' Anderson
Details
ebuild with applied remove-examples patch (libdc1394-2.1.2.ebuild,957 bytes, text/plain)
2011-03-30 23:49 UTC, brent
Details
Patch to disable examples compilation for version 1.2.2 (libdc1394-1.2.2-disable-examples.patch,462 bytes, patch)
2011-04-02 12:09 UTC, Adrien Duviviers
Details | Diff
patch for the ebuild (disable-examples-v1.patch,317 bytes, patch)
2011-04-02 12:09 UTC, Adrien Duviviers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Billy DeVincentis 2011-03-21 12:25:05 UTC
mv -f .deps/affine.Tpo .deps/affine.Po
mv -f .deps/dc1394_reset_bus.Tpo .deps/dc1394_reset_bus.Po
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I..   -Wall -Wunused -std=gnu99 -march=native -O2 -pipe -MT grab_partial_pvn.o -MD -MP -MF .deps/grab_partial_pvn.Tpo -c -o grab_partial_pvn.o grab_partial_pvn.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I..   -Wall -Wunused -std=gnu99 -march=native -O2 -pipe -MT basler_sff_info.o -MD -MP -MF .deps/basler_sff_info.Tpo -c -o basler_sff_info.o basler_sff_info.c
grab_gray_image.c: In function ‘main’:
grab_gray_image.c:171:11: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
dc1394_vloopback.c:49:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[2]: *** [dc1394_vloopback.o] Error 1
make[2]: *** Waiting for unfinished jobs....
grab_color_image.c: In function ‘main’:
grab_color_image.c:122:11: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
grab_color_image2.c: In function ‘main’:
grab_color_image2.c:268:11: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
mv -f .deps/grab_partial_image.Tpo .deps/grab_partial_image.Po
grab_partial_pvn.c: In function ‘main’:
grab_partial_pvn.c:134:13: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
mv -f .deps/grab_color_image.Tpo .deps/grab_color_image.Po
ladybug.c: In function ‘main’:
ladybug.c:131:27: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
ladybug.c:138:15: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
mv -f .deps/helloworld.Tpo .deps/helloworld.Po
mv -f .deps/grab_partial_pvn.Tpo .deps/grab_partial_pvn.Po
mv -f .deps/grab_gray_image.Tpo .deps/grab_gray_image.Po
mv -f .deps/basler_sff_info.Tpo .deps/basler_sff_info.Po
mv -f .deps/grab_color_image2.Tpo .deps/grab_color_image2.Po
mv -f .deps/ladybug.Tpo .deps/ladybug.Po
make[2]: Leaving directory `/var/tmp/portage/media-libs/libdc1394-2.1.2/work/libdc1394-2.1.2/examples'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/libdc1394-2.1.2/work/libdc1394-2.1.2'
make: *** [all] Error 2
emake failed
 * ERROR: media-libs/libdc1394-2.1.2 failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 2194:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";
 * 
 * If you need support, post the output of 'emerge --info =media-libs/libdc1394-2.1.2',
 * the complete build log and the output of 'emerge -pqv =media-libs/libdc1394-2.1.2'.
 * The complete build log is located at '/var/tmp/portage/media-libs/libdc1394-2.1.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/libdc1394-2.1.2/temp/environment'.
 * S: '/var/tmp/portage/media-libs/libdc1394-2.1.2/work/libdc1394-2.1.2'

>>> Failed to emerge media-libs/libdc1394-2.1.2, Log file:

>>>  '/var/tmp/portage/media-libs/libdc1394-2.1.2/temp/build.log'
 * 
 * The following package has failed to build or install:
 * 
 *  (media-libs/libdc1394-2.1.2::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-libs/libdc1394-2.1.2/temp/build.log'
 * 



Reproducible: Always




emerge --info
Portage 2.2.0_alpha28 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_870_@_2.93GHz-with-gentoo-2.0.2
Timestamp of tree: Sun, 20 Mar 2011 11:00:01 +0000
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.6.3-r1, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
Repositories: gentoo miscellaneous
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="assume-digests binpkg-logs buildpkg distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow S3TC X a52 aac aalib accessibility acl acpi aften akonadi alsa amarok amd64 amrnb archive ares arts artworkextra audio audiofile automount avahi bash-completion berkdb bidi binary-drivers bittorrent bluetooth bookmarks branding bzip2 cairo calendar cdda cddb cdio cdr chm clamav clamd cleartype cli clucene consolekit corefonts cpudetection cracklib crypt css cups curl cxx dbus deprecated designer-plugin device-mapper devil dga directfb discouraged distribution divx dns doc dri dts dv dvb dvd dvdnav dvdr dvdread ebook eds elisp emacs emboss emerald encode esd eselect etc-proposals evo examples exif expat extra-tools extraicons extras fam fat fax fbcon fbcondecor fbsplash ffmpeg firefox flac flash fltk foomaticdb fortran ftp fts3 fuse gcj gd gdbm gdu gedit ggi gif gimp glep glib glitz gmedia gnome gnutls google google-gadgets gphoto2 gpm gstreamer gtk gtkhtml handbook hddtemp hfs hpcups hpijs html htmlhandbook httpd hyperestraier iconv idn ieee1394 imagemagick imlib inkjar inotify ipv6 isdnlog jack jadetex java java6 jfs joystick jpeg jpeg2k kde kdehiddenvisibility kdrive kerberos konqueror kpathsea lame lcms ldap libcaca libnotify libsamplerate lirc live lm_sensors logrotate mad mail matroska md5sum mdnsresponder-compat mikmod mime mjpeg mmx mmxext mng modules mono mozilla mp2 mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql nas nautilus ncurses networking new-login nforce2 nls npp nptl nptlonly nsplugin ntfs nvidia objc odbc offensive ogg ole openal openexr opengl openmp osdmenu pam pango parport pcre pdf perl pipechan plasma pmu png policykit postgres ppds pppd pulseaudio python qt3support qt4 quicktime raptor rar rdesktop readline realmedia reflection regex reiser4 reiserfs reports samba sametime scanner sdl secure-delete semantic-desktop servletapi session sip skins slang slp smbclient smp sndfile snmp sound sounds speex spell spl sql sqlite sse sse2 ssl startup-notification static-ppds stream subversion svg swat sysfs syslog tcpd templates theora thesaurus threads thumbnail thunderbird tidy tiff timidity tk tools truetype type1 udev unicode unsupported usb userlocales utempter utils v4l vcd vdpau vdr video vlm voice vorbis vram wav wavpack weather webkit wmf wmp wordperfect wxwindows x264 xattr xcb xcomposite xforms xfs xine xml xorg xpm xprint xscreensaver xulrunner xv xvid xvmc zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 SpanKY gentoo-dev 2011-03-21 13:12:45 UTC
*** Bug 359739 has been marked as a duplicate of this bug. ***
Comment 2 Stefan Richter 2011-03-24 20:57:25 UTC
I sent a notice to the libdc1394-devel mailinglist.
Comment 3 Stefan Richter 2011-03-24 21:04:26 UTC
PS:  The dc1394_vloopback tool of libdc1394 example utilities which cannot be built anymore is not a required part of libdc1394 itself.
Comment 4 Jules 2011-03-25 15:49:11 UTC
And indeed amd64 is affected... blocking the package should work until it is fixed, hopefully soon. v4l shouldve been gone a long time ago.
Comment 5 Stefaan De Roeck (RETIRED) gentoo-dev 2011-03-25 23:16:41 UTC
Created attachment 267221 [details, diff]
Proposed patch, just does not compile the examples anymore

This proposed patch seems to fix it, albeit by disabling compilation of the examples altogether. Feel free to double-check whether I forgot something, have not tested it thoroughly.
Comment 6 blain 'Doc' Anderson 2011-03-27 16:40:08 UTC
amd64 will not build

build log attached
Comment 7 blain 'Doc' Anderson 2011-03-27 16:43:45 UTC
Created attachment 267417 [details]
build log for dbus
Comment 9 Robert Cabrera 2011-03-28 14:28:27 UTC
Similar issue on my ~x86 laptop. The build fails for me since upgrade in kernel headers. My build fails with the following error:

creating libdc1394.la
(cd .libs && rm -f libdc1394.la && ln -s ../libdc1394.la libdc1394.la)
Making all in examples
mkdir .libs
i686-pc-linux-gnu-gcc -Wall -Wunused -std=gnu99 -march=native -O2 -pipe -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -o .libs/dc1394_reset_bus dc1394_reset_bus.o  ../dc1394/.libs/libdc1394.so /usr/lib/libraw1394.so /usr/lib/libusb-1.0.so -lrt -lm 
creating dc1394_reset_bus
dc1394_vloopback.c:49:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[2]: *** [dc1394_vloopback.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
emake failed
 * ERROR: media-libs/libdc1394-2.1.2 failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 2160:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";
 * 
 * If you need support, post the output of 'emerge --info =media-libs/libdc1394-2.1.2',
 * the complete build log and the output of 'emerge -pqv =media-libs/libdc1394-2.1.2'.
 * The complete build log is located at '/var/tmp/portage/media-libs/libdc1394-2.1.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/libdc1394-2.1.2/temp/environment'.
 * S: '/var/tmp/portage/media-libs/libdc1394-2.1.2/work/libdc1394-2.1.2'

>>> Failed to emerge media-libs/libdc1394-2.1.2, Log file:

>>>  '/var/tmp/portage/media-libs/libdc1394-2.1.2/temp/build.log'

My emerge --info
Portage 2.2.0_alpha29 (default/linux/x86/10.0/desktop/kde, gcc-4.5.2, glibc-2.13-r2, 2.6.38-pf1 i686)
=================================================================
System uname: Linux-2.6.38-pf1-i686-Intel-R-_Pentium-R-_M_processor_2.26GHz-with-gentoo-2.0.2
Timestamp of tree: Mon, 28 Mar 2011 13:15:01 +0000
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
Repositories: gentoo portage
Installed sets: 
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/config/kdm /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/skel /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://gentoo.netnitco.net http://gentoo.osuosl.org/ http://gentoo.mirrors.tds.net/gentoo http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.wetzlmayr.com/ http://osmirrors.cerias.purdue.edu/pub/gentoo/ http://www.cyberuse.com/gentoo/ http://gentoo.mirrors.hoobly.com/ ftp://gentoo.imj.fr/pub/gentoo/ http://130.59.10.35/ftp/mirror/gentoo/"
LANG="en_US.utf8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j1 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="S3TC X a52 aac aalib acl acpi addressbook alsa amr apm archive audiofile autoipd avahi bash-completion berkdb binfilter bittorrent bluetooth bonjour branding bzip2 cairo cdda cdinstall cdr chm cleartype cli clucene connection-sharing consolekit contrast cracklib crypt cups custom-cflags custom-optimization cxx dbus dc1394 dell designer-plugin desktopglobe dga dhcpcd dirac djvu dri drm dts dv dvb dvd dvdr ebook editor eix embedded emboss emovix enca encode exif extensions faac faad fam fat fbcon fbcondecor fbsplash ffmpeg firefox fits flac flash fortran ftp fuse gallium gcrypt gd gdbm gdu geolocation ggi gif gimp git gles glib glibc-omitfp gmm gmp gnutls gphoto2 gpm graphviz groupwise gsm gtk handbook httpd hyperestraier iconv id3tag ieee1394 imagemagick imlib indi inotify ipod ipv6 jabber jack java javascript jbig jce jingle joystick jpeg jpeg2k kate kde kerberos kig-scripting kipi konqueror ladspa lame laptop lastfm latex lcms ldap libass libcaca libnotify libproxy libsamplerate libtiger live llvm lm_sensors lua lzma lzo mad matroska md5sum meanwhile mikmod mjpeg mmx mng modplug modules mozilla mp3 mp3tunes mp4 mpeg mplayer msn mtp mudflap musepack musicbrainz ncurses network networkmanager nls nova npp nptl nptlonly nsplugin ntfs nut offensive ogg openal openexr opengl openmp optimization optimized-qmake oscar otr pam pango pch pcmcia pcre pdf perl plasma pm-utils pmu png pnm policykit ppds ppp pppd pvr python python3 qalculate qt-faststart qt3support qt4 quicktime qwt rar raw rdp readline remote-access reports resolvconf rle rss rtmp rtsp samba sasl scanner schroedinger sdl sdl-image secure-delete semantic-desktop session shout shutdown skins skype slp smbclient sms sndfile solver sox speex spell sse sse2 ssl stable startup-notification stream strong-optimization subversion svg svga symlink sysfs system-sqlite taglib tcl tcpd teamarena templates tga themedesigner theora threads thumbnail tidy tiff timidity tremor truetype twolame udev udis86 unicode upnp usb vaapi vcd vcdx video vidix vlc vlm vnc vorbis vpx watchdog wavpack webpresence wicd wifi win32codecs windeco winpopup wireshark wmf wpd wpg wps wv2 wxwidgets x264 x86 xanim xattr xcb xcomposite xine xml xorg xosd xulrunner xv xvid xvmc yahoo yv12 zeroconf zlib" ALSA_CARDS="intel8x0 intel8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" RUBY_TARGETS="ruby18" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 10 Robert Cabrera 2011-03-29 05:19:48 UTC
Any chance of the upstream patch making it into portage anytime soon? If not, can somebody please post explaining how to use it in my overlay so I can get this to compile?
TIA
Comment 11 brent 2011-03-30 23:47:28 UTC
(In reply to comment #10)
> Any chance of the upstream patch making it into portage anytime soon? If not,
> can somebody please post explaining how to use it in my overlay so I can get
> this to compile?
> TIA

1.) cd into your local overlay.. (for me, /usr/local/portage)

2.) mkdir -p media-libs/libdc1394

3.) cd media-liba/libdc1394

4.) cp -a /usr/portage/media-libs/libdc1394/{files,Manifest,libdc1394-2.1.2.ebuild} .

5.) wget -O disable-examples.patch "http://bugs.gentoo.org/attachment.cgi?id=267221"

6.) patch -i disable-examples.patch

# should be fixed by the patch, but juuuuust in case...
7.) ebuild libdc1394-2.1.2.ebuild manifest

8.) eix-sync / emerge --sync (depending on if you have eix installed/are using it)

9.) emerge -1va "=media-libs/libdc1394-2.1.2"

i'm about to attach a copy of the patched ebuild itself, which should skip steps 4(ish)-7 for you (though you still have to place it wherever your local overlay is, etc.)
Comment 12 brent 2011-03-30 23:49:07 UTC
Created attachment 267925 [details]
ebuild with applied remove-examples patch

make sure you rebuild the manifest. files dir may or may not need to be copied over to local overlay.
Comment 13 brent 2011-03-30 23:51:01 UTC
(In reply to comment #5)
> Created attachment 267221 [details, diff]
> Proposed patch, just does not compile the examples anymore
> 
> This proposed patch seems to fix it, albeit by disabling compilation of the
> examples altogether. Feel free to double-check whether I forgot something, have
> not tested it thoroughly.

great work, buddy; just applied and installed, no errors on AMD64 with USE="X -doc"
Comment 14 Simeon Maryasin 2011-04-02 12:03:13 UTC
(In reply to comment #12)
> Created attachment 267925 [details]
> ebuild with applied remove-examples patch
> 
> make sure you rebuild the manifest. files dir may or may not need to be copied
> over to local overlay.

Maybe X use flag must be also removed from ebuild, as it isn't used anymore.

Please also fix v1.2.2, as it is used by dev-libs/pwlib and maybe some others.
Comment 15 Adrien Duviviers 2011-04-02 12:09:07 UTC
Created attachment 268199 [details, diff]
Patch to disable examples compilation for version 1.2.2

This bug also affect version 1.2.2 (as described in bug #359739 marked duplicate of this bug ).
Here is a simple patch which disable compilation of examples for version 1.2.2, whose configure script does not seems to take into account "--disable-examples".
I don't know if my patch do it the right way, but it seems to work.
Comment 16 Adrien Duviviers 2011-04-02 12:09:55 UTC
Created attachment 268201 [details, diff]
patch for the ebuild
Comment 17 Stefan Richter 2011-04-02 19:44:52 UTC
A note on libdc1394 v1.x:
This version requires kernel 2.6.36 or older at runtime.
Comment 18 Rafał Mużyło 2011-04-03 19:23:26 UTC
*** Bug 361825 has been marked as a duplicate of this bug. ***
Comment 19 water 2011-04-05 05:20:32 UTC
when does the patch go into portage ? thanks
Comment 20 hirakendu 2011-04-08 04:24:17 UTC
Thanks, works. Also came across http://comments.gmane.org/gmane.comp.multimedia.libdc1394.devel/745 .
Comment 21 Brad Laue 2011-04-11 20:17:20 UTC
Can confirm the included patches work. 

I'd be for applying these rather than depending on older kernel headers or blocking builds - currently these packages are depended on by a variety of others.
Comment 22 Alessandro Surace 2011-04-24 08:49:21 UTC
works for me too
Comment 23 Justin Lecher gentoo-dev 2011-04-30 17:24:26 UTC
+*libdc1394-2.1.3 (30 Apr 2011)
+
+  30 Apr 2011; Justin Lecher <jlec@gentoo.org>
+  +files/libdc1394-videodev.h.patch, +libdc1394-2.1.3.ebuild:
+  Non Maintainer version bump, Build without V4L1 support, #359735 & #363303
+
Comment 24 Silvio 2011-05-01 21:29:06 UTC
But for the version:

media-libs/libdc1394-1.2.2

the bug is still there!

and this is required for instance by:

net-libs/ptlib-2.6.7-r1[video,ieee1394]
dev-libs/pwlib-1.10.10-r2[ieee1394]
Comment 25 Stefan Richter 2011-05-01 22:16:28 UTC
(In reply to comment #24)
> But for the version:
> 
> media-libs/libdc1394-1.2.2
> 
> the bug is still there!
> 
> and this is required for instance by:
> 
> net-libs/ptlib-2.6.7-r1[video,ieee1394]
> dev-libs/pwlib-1.10.10-r2[ieee1394]

While it would surely be nice to be able to build libdc1394 v1 in presence of linux-headers v2.6.38 or later, keep in mind that libdc1394 v1 does not do anything at all anymore if you have kernel 2.6.37 or later at runtime.
Comment 26 Justin Lecher gentoo-dev 2011-05-02 06:07:26 UTC
(In reply to comment #24)
> But for the version:
> 
> media-libs/libdc1394-1.2.2
> 
This is a stable version, the headers are unstable. MIxing of stable and unstable is your fun.
Comment 27 Justin Lecher gentoo-dev 2011-05-02 06:07:33 UTC
(In reply to comment #24)
> But for the version:
> 
> media-libs/libdc1394-1.2.2
> 
This is a stable version, the headers are unstable. MIxing of stable and unstable is your fun.
Comment 28 Neil Bothwick 2011-05-02 10:03:26 UTC
It may be stable, but it is also the latest version in that slot, so it is the default for stable and testing systems to install. I agree that mixing keywords can cause headaches, but this package is also installed on a pure testing system.