Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 396635 - media-video/camserv-0.5.1-r2 fails to build libvideo_v4l.so module without linux/videodev.h header
Summary: media-video/camserv-0.5.1-r2 fails to build libvideo_v4l.so module without li...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on: 417333
Blocks: linux-headers-2.6.38
  Show dependency tree
 
Reported: 2011-12-31 21:00 UTC by Dave Griffith
Modified: 2012-05-24 03:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Griffith 2011-12-31 21:00:18 UTC
camserv fails to build its v4l capture module and thus cannot capture v4l video.
This is due to the v4l headers missing from the kernel package.



Reproducible: Always

Steps to Reproduce:
1. Install kernel 3.0.6 
2. Emerge camserv
3. Setup camserv to capture from /dev/video0
Actual Results:  
camserv fails to run with the error 'cannot load libvideo_v4l.so'

Expected Results:  
Should have started capturing from /dev/video0

I attempted to include the v4l header file from libv4l2 as per bug with motion (376225), but no go. The libvide_v4l.so library now builds, but on running camserv I now get - 
'(V4L) GCAP && GWIN: Invalid argument' 
instead, so whilst that is progress, I'm unsure what further work is needed from here.
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-01-03 01:58:47 UTC
Please attach build.log
Comment 2 Samuli Suominen gentoo-dev 2012-05-24 03:50:19 UTC
Well, I've fixed this somewhat:

http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/camserv/camserv-0.5.1-r2.ebuild?r1=1.15&r2=1.16

Now it will use libv4l1-videodev.h from media-libs/libv4l instead of linux/videodev.h from linux-headers

The module gets installed:

$ qlist camserv |grep v4l
/usr/lib64/camserv/libvideo_v4l.la
/usr/lib64/camserv/libvideo_v4l.so
/usr/lib64/camserv/libvideo_v4l.so.0
/usr/lib64/camserv/libvideo_v4l.so.0.0.0

But that doesn't mean it will run on modern kernels, you need to run something like 2.6.37 to get a kernel that still has Video4Linux version 1

Since 2.6.38 it was removed

So closing this bug now as FIXED, but opening another bug for the package removal
Comment 3 Samuli Suominen gentoo-dev 2012-05-24 03:55:22 UTC
See bug 417333 for removal process. Unless someone is willing to port this from v4l1 to v4l2 (or libv4l's compability libraries).